summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-06-03 15:20:41 +0100
committerColin Watson <cjwatson@debian.org>2019-06-03 15:20:41 +0100
commit7c64486d66d3c54ad8ef16fcc4eb045916ad720e (patch)
treedcf2a6c31e2aed2dae7f654bd4302906a54fbef0
parentb95b512841c9756e343e81df98c847aa07a61694 (diff)
parent55e7bade4383ad3a71e37187c5ccad1f13432766 (diff)
Import iprutils_2.4.18.1.orig.tar.gz
-rwxr-xr-xconfigure20
-rw-r--r--configure.ac2
-rw-r--r--iprconfig.c2
-rw-r--r--iprlib.c6
-rw-r--r--spec/iprutils.spec5
5 files changed, 20 insertions, 15 deletions
diff --git a/configure b/configure
index c59d67c..f943ea1 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for iprutils 2.4.17.1.
+# Generated by GNU Autoconf 2.69 for iprutils 2.4.18.1.
#
# Report bugs to <iprdd-devel@lists.sourceforge.net>.
#
@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='iprutils'
PACKAGE_TARNAME='iprutils'
-PACKAGE_VERSION='2.4.17.1'
-PACKAGE_STRING='iprutils 2.4.17.1'
+PACKAGE_VERSION='2.4.18.1'
+PACKAGE_STRING='iprutils 2.4.18.1'
PACKAGE_BUGREPORT='iprdd-devel@lists.sourceforge.net'
PACKAGE_URL=''
@@ -1338,7 +1338,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures iprutils 2.4.17.1 to adapt to many kinds of systems.
+\`configure' configures iprutils 2.4.18.1 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1408,7 +1408,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of iprutils 2.4.17.1:";;
+ short | recursive ) echo "Configuration of iprutils 2.4.18.1:";;
esac
cat <<\_ACEOF
@@ -1519,7 +1519,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-iprutils configure 2.4.17.1
+iprutils configure 2.4.18.1
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1996,7 +1996,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by iprutils $as_me 2.4.17.1, which was
+It was created by iprutils $as_me 2.4.18.1, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2860,7 +2860,7 @@ fi
# Define the identity of the package.
PACKAGE='iprutils'
- VERSION='2.4.17.1'
+ VERSION='2.4.18.1'
cat >>confdefs.h <<_ACEOF
@@ -13049,7 +13049,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by iprutils $as_me 2.4.17.1, which was
+This file was extended by iprutils $as_me 2.4.18.1, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -13106,7 +13106,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-iprutils config.status 2.4.17.1
+iprutils config.status 2.4.18.1
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index 969300e..14344d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,7 @@
AC_PREREQ([2.63])
# For RC releases, version should be set to 2.4.10.0.rc1, 2.4.10.0.rc2, etc.
# For GA releases, version should be set to 2.4.10.1, 2.4.10.2, etc.
-AC_INIT([iprutils], [2.4.17.1], [iprdd-devel@lists.sourceforge.net])
+AC_INIT([iprutils], [2.4.18.1], [iprdd-devel@lists.sourceforge.net])
AM_INIT_AUTOMAKE([1.9 foreign])
AC_CONFIG_MACRO_DIR([build-aux])
diff --git a/iprconfig.c b/iprconfig.c
index 6a5fd21..5f31beb 100644
--- a/iprconfig.c
+++ b/iprconfig.c
@@ -232,7 +232,7 @@ static int wait_for_formatted_af_dasd(int timeout_in_secs)
int num_devs, j, af_found, jbod2af_formats, num_secs;
u64 device_id;
- for (num_secs = 0; num_secs < timeout_in_secs; timeout_in_secs++) {
+ for (num_secs = 0; num_secs < timeout_in_secs; num_secs++) {
af_found = 0;
jbod2af_formats = 0;
scsi_devs = NULL;
diff --git a/iprlib.c b/iprlib.c
index 4d3ab5f..516f069 100644
--- a/iprlib.c
+++ b/iprlib.c
@@ -10345,7 +10345,8 @@ int ipr_jbod_sysfs_bind(struct ipr_dev *dev, u8 op)
char *sysfs_device_name;
sysfs_device_name = dev->scsi_dev_data->sysfs_device_name;
- size = strnlen(sysfs_device_name, sizeof(sysfs_device_name));
+ size = strnlen(sysfs_device_name,
+ sizeof(dev->scsi_dev_data->sysfs_device_name));
if (op == IPR_JBOD_SYSFS_BIND) {
fd = open("/sys/bus/scsi/drivers/sd/bind", O_WRONLY);
@@ -10367,7 +10368,8 @@ int ipr_jbod_sysfs_bind(struct ipr_dev *dev, u8 op)
mp_dev = find_multipath_jbod(dev);
if (mp_dev) {
sysfs_device_name = mp_dev->scsi_dev_data->sysfs_device_name;
- size = strnlen(sysfs_device_name, sizeof(sysfs_device_name));
+ size = strnlen(sysfs_device_name,
+ sizeof(mp_dev->scsi_dev_data->sysfs_device_name));
rc = write(fd, sysfs_device_name, size);
if (rc < 0) {
close(fd);
diff --git a/spec/iprutils.spec b/spec/iprutils.spec
index 28e1654..b5a52f7 100644
--- a/spec/iprutils.spec
+++ b/spec/iprutils.spec
@@ -1,6 +1,6 @@
Summary: Utilities for the IBM Power Linux RAID adapters
Name: iprutils
-Version: 2.4.17
+Version: 2.4.18
# For RC releases, release_prefix should be set to 0.rc1, 0.rc2, etc.
# For GA releases, release_prefix should be set to 1, 2, 3, etc.
%define release_prefix 1
@@ -307,6 +307,9 @@ fi
%endif #WITH_STATIC
%changelog
+* Fri May 31 2019 Brian King <brking@linux.ibm.com> 2.4.18
+- Fix format for RAID hang
+- Fix driver unbind on format
* Fri Oct 26 2018 Brian King <brking@linux.ibm.com> 2.4.17
- Additional speedup for show-details
- Utilize udev rules for systemd daemon activation