summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore4
-rw-r--r--CHANGES.md10
-rw-r--r--debian/changelog11
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/upstream/metadata5
-rw-r--r--debian/watch2
-rw-r--r--dune-project1
-rw-r--r--ocaml-compiler-libs.opam13
-rw-r--r--src/shadow/gen/gen.ml12
9 files changed, 46 insertions, 14 deletions
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 85f39e5..0000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-_build
-*.install
-*.merlin
-
diff --git a/CHANGES.md b/CHANGES.md
new file mode 100644
index 0000000..e06db86
--- /dev/null
+++ b/CHANGES.md
@@ -0,0 +1,10 @@
+v0.12.3
+-------
+
+- Update opam file
+
+v0.12.2
+-------
+
+- Fix deprecation messages in `Ocaml_shadow` (fixes #7,
+ @jeremiedimino)
diff --git a/debian/changelog b/debian/changelog
index 8a94089..e3b7002 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+janest-ocaml-compiler-libs (0.12.3-1) unstable; urgency=medium
+
+ [ Stéphane Glondu ]
+ * New upstream release
+
+ [ Debian Janitor ]
+ * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+ Repository-Browse.
+
+ -- Stéphane Glondu <glondu@debian.org> Sat, 07 Nov 2020 14:03:03 +0100
+
janest-ocaml-compiler-libs (0.12.1-2) unstable; urgency=medium
* Bump debhelper compat level to 13
diff --git a/debian/rules b/debian/rules
index 1f27bd5..2d24a68 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,5 +14,3 @@ override_dh_auto_build:
override_dh_auto_install:
dune install --destdir=$(DESTDIR) --prefix=/usr --libdir=..$(OCAML_STDLIB_DIR)
rm -f $(DESTDIR)/usr/doc/ocaml-compiler-libs/LICENSE.md
-
-override_dh_dwz:
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 0000000..828c45e
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,5 @@
+---
+Bug-Database: https://github.com/janestreet/ocaml-compiler-libs/issues
+Bug-Submit: https://github.com/janestreet/ocaml-compiler-libs/issues/new
+Repository: https://github.com/janestreet/ocaml-compiler-libs.git
+Repository-Browse: https://github.com/janestreet/ocaml-compiler-libs
diff --git a/debian/watch b/debian/watch
index 705f6e8..157a325 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,2 +1,2 @@
version=3
-https://github.com/janestreet/ocaml-compiler-libs/releases .*/archive/v?(.*)\.tar\.gz
+https://github.com/janestreet/ocaml-compiler-libs/releases .*-v?([0-9.]+)\.tbz
diff --git a/dune-project b/dune-project
index fcc1be8..1c2482d 100644
--- a/dune-project
+++ b/dune-project
@@ -1,2 +1,3 @@
(lang dune 1.0)
(name ocaml-compiler-libs)
+(version v0.12.3)
diff --git a/ocaml-compiler-libs.opam b/ocaml-compiler-libs.opam
index 5e5fee7..e9b3bf5 100644
--- a/ocaml-compiler-libs.opam
+++ b/ocaml-compiler-libs.opam
@@ -1,4 +1,5 @@
-opam-version: "1.2"
+version: "v0.12.3"
+opam-version: "2.0"
maintainer: "opensource@janestreet.com"
authors: ["Jane Street Group, LLC <opensource@janestreet.com>"]
homepage: "https://github.com/janestreet/ocaml-compiler-libs"
@@ -9,12 +10,12 @@ build: [
["dune" "build" "-p" name "-j" jobs]
]
depends: [
- "dune" {build & >= "1.0"}
+ "ocaml" {>= "4.04.1"}
+ "dune" {build & >= "1.5.1"}
]
-available: [ ocaml-version >= "4.04.1" ]
-descr: "
-OCaml compiler libraries repackaged
+synopsis: """OCaml compiler libraries repackaged"""
+description: """
This packages exposes the OCaml compiler libraries repackages under
the toplevel names Ocaml_common, Ocaml_bytecomp, Ocaml_optcomp, ...
-"
+""" \ No newline at end of file
diff --git a/src/shadow/gen/gen.ml b/src/shadow/gen/gen.ml
index e511ed4..89451e3 100644
--- a/src/shadow/gen/gen.ml
+++ b/src/shadow/gen/gen.ml
@@ -39,7 +39,17 @@ let () =
|> List.iter ~f:(fun m ->
let repl =
match Smap.find m module_to_lib with
- | lib -> Printf.sprintf ", use %s.%s instead" lib m
+ | lib ->
+ let lib =
+ let prefix = "Ocaml" in
+ let prefix_len = String.length prefix in
+ let lib_len = String.length lib in
+ if lib_len >= prefix_len && String.sub lib 0 prefix_len = prefix then
+ prefix ^ "_" ^ String.sub lib prefix_len (lib_len - prefix_len)
+ else
+ lib
+ in
+ Printf.sprintf ", use %s.%s instead" lib m
| exception Not_found -> ""
in
Printf.fprintf oc