summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2019-11-20 20:29:12 +0100
committerDidier Raboud <odyx@debian.org>2019-11-20 20:29:12 +0100
commitf288d23ab11274ae69bf18b5c83e43a207933f3c (patch)
tree57c21ed6b7535f263b49a2d1fd042a86469a6de7
parentaa0e1aceb0284183d4324c0c58370faa1d7f7641 (diff)
git-debrebase convert-from-dgit-view: drop upstream changes from breakwater
Drop upstream changes, and delete debian/patches, as part of converting to git-debrebase format. Upstream changes will appear as commits. [git-debrebase convert-from-dgit-view drop-patches]
-rw-r--r--Makefile.in2
-rwxr-xr-xautosetup/autosetup3
-rw-r--r--debian/patches/0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch27
-rw-r--r--debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch25
-rw-r--r--debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch23
-rw-r--r--debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch35
-rw-r--r--debian/patches/series4
-rw-r--r--tests/exec.test2
-rw-r--r--tests/timer.test11
9 files changed, 12 insertions, 120 deletions
diff --git a/Makefile.in b/Makefile.in
index 4eaaced..a803b07 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -203,7 +203,7 @@ zlib.so: jim-zlib.c
$(CC) $(CFLAGS) $(LDFLAGS) $(SHOBJ_LDFLAGS) -o $@ jim-zlib.o $(SH_LIBJIM) @LDLIBS_zlib@
Tcl.html: jim_tcl.txt
- @tclsh@ @srcdir@/make-index $> $^ | asciidoc -o $@ -d manpage -a footer-style=none - || cp @srcdir@/Tcl_shipped.html Tcl.html
+ @tclsh@ @srcdir@/make-index $> $^ | asciidoc -o $@ -d manpage - || cp @srcdir@/Tcl_shipped.html Tcl.html
clean:
rm -f *.o *.so *.dll *.exe lib*.a $(JIMSH) $(LIBJIM) Tcl.html _*.c
diff --git a/autosetup/autosetup b/autosetup/autosetup
index 891d834..84886c2 100755
--- a/autosetup/autosetup
+++ b/autosetup/autosetup
@@ -94,9 +94,6 @@ proc main {argv} {
quiet
timing
conf:
- # Options given by debhelper compat 11+ autoconf:
- silent-rules
- runstatedir
}
#parray ::useropts
diff --git a/debian/patches/0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch b/debian/patches/0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch
deleted file mode 100644
index ab0f0d1..0000000
--- a/debian/patches/0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From d81f26e30e0923fd9318c569f6eed324f81ede42 Mon Sep 17 00:00:00 2001
-From: Didier Raboud <odyx@debian.org>
-Date: Sun, 27 Aug 2017 17:19:02 +0200
-Subject: Let autosetup accept silent-rules and runstatedir options
-
-These are given by debhelper's dh_auto_configure in compat 11+
-
-Origin: vendor
-Last-Update: 2018-03-30
----
- autosetup/autosetup | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/autosetup/autosetup b/autosetup/autosetup
-index 84886c2..891d834 100755
---- a/autosetup/autosetup
-+++ b/autosetup/autosetup
-@@ -94,6 +94,9 @@ proc main {argv} {
- quiet
- timing
- conf:
-+ # Options given by debhelper compat 11+ autoconf:
-+ silent-rules
-+ runstatedir
- }
-
- #parray ::useropts
diff --git a/debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch b/debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch
deleted file mode 100644
index d9a4646..0000000
--- a/debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 31bd32fd65f005c5f8b63e6463da620ef363d856 Mon Sep 17 00:00:00 2001
-From: Didier Raboud <odyx@debian.org>
-Date: Sun, 27 Aug 2017 17:19:03 +0200
-Subject: In the asciidoc call, use the '-a footer-style=none' to export
-
- without the footer; as it contains the build timestamp, which makes the build
- unreproducible.
-Last-Update: 2016-02-27
----
- Makefile.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile.in b/Makefile.in
-index a803b07..4eaaced 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -203,7 +203,7 @@ zlib.so: jim-zlib.c
- $(CC) $(CFLAGS) $(LDFLAGS) $(SHOBJ_LDFLAGS) -o $@ jim-zlib.o $(SH_LIBJIM) @LDLIBS_zlib@
-
- Tcl.html: jim_tcl.txt
-- @tclsh@ @srcdir@/make-index $> $^ | asciidoc -o $@ -d manpage - || cp @srcdir@/Tcl_shipped.html Tcl.html
-+ @tclsh@ @srcdir@/make-index $> $^ | asciidoc -o $@ -d manpage -a footer-style=none - || cp @srcdir@/Tcl_shipped.html Tcl.html
-
- clean:
- rm -f *.o *.so *.dll *.exe lib*.a $(JIMSH) $(LIBJIM) Tcl.html _*.c
diff --git a/debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch b/debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch
deleted file mode 100644
index 395f611..0000000
--- a/debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 284f5512a2ce177da6fedf03ce39f38a28acc923 Mon Sep 17 00:00:00 2001
-From: Steve Bennett <steveb@workware.net.au>
-Date: Sun, 27 Aug 2017 10:13:07 +1000
-Subject: tests/exec.test: Minor fix for exec-12.1 on hurd
-
-Signed-off-by: Steve Bennett <steveb@workware.net.au>
----
- tests/exec.test | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/exec.test b/tests/exec.test
-index 8df1aa8..76a1b2d 100644
---- a/tests/exec.test
-+++ b/tests/exec.test
-@@ -349,7 +349,7 @@ test exec-12.1 {reaping background processes} -constraints unix -body {
- exec echo foo > exec.tmp1 &
- }
- exec {*}$sleepx 0.1
-- catch {exec ps | fgrep "echo foo" | fgrep -v fgrep | wc} msg
-+ catch {exec ps | fgrep "echo foo" | fgrep -v grep | wc} msg
- lindex $msg 0
- } -cleanup {
- file delete exec.tmp1
diff --git a/debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch b/debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch
deleted file mode 100644
index 23bfdfd..0000000
--- a/debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From ef7310242ab5bd0daead9497d3f143f11a6cd2fa Mon Sep 17 00:00:00 2001
-From: Steve Bennett <steveb@workware.net.au>
-Date: Sun, 27 Aug 2017 10:14:14 +1000
-Subject: tests/timer.test: Remove timer-6.5
-
-This test is essentially the same as timer-6.4 except with
-tighter timing requirements. Remove it to prevent spurious failures.
-
-Signed-off-by: Steve Bennett <steveb@workware.net.au>
----
- tests/timer.test | 11 +----------
- 1 file changed, 1 insertion(+), 10 deletions(-)
-
-diff --git a/tests/timer.test b/tests/timer.test
-index 26ffa0a..a493004 100644
---- a/tests/timer.test
-+++ b/tests/timer.test
-@@ -189,16 +189,7 @@ test timer-6.4 {Tcl_AfterCmd procedure, ms argument} {
- update
- list $y $x
- } {before after}
--test timer-6.5 {Tcl_AfterCmd procedure, ms argument} {
-- set x before
-- after 60 {set x after}
-- after 40
-- update
-- set y $x
-- after 40
-- update
-- list $y $x
--} {before after}
-+
- test timer-6.6 {Tcl_AfterCmd procedure, cancel option} {
- list [catch {after cancel} msg] $msg
- } {1 {wrong # args: should be "after cancel id|command"}}
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 6a9e656..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,4 +0,0 @@
-0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch
-0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch
-0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch
-0004-tests-timer.test-Remove-timer-6.5.patch
diff --git a/tests/exec.test b/tests/exec.test
index 76a1b2d..8df1aa8 100644
--- a/tests/exec.test
+++ b/tests/exec.test
@@ -349,7 +349,7 @@ test exec-12.1 {reaping background processes} -constraints unix -body {
exec echo foo > exec.tmp1 &
}
exec {*}$sleepx 0.1
- catch {exec ps | fgrep "echo foo" | fgrep -v grep | wc} msg
+ catch {exec ps | fgrep "echo foo" | fgrep -v fgrep | wc} msg
lindex $msg 0
} -cleanup {
file delete exec.tmp1
diff --git a/tests/timer.test b/tests/timer.test
index a493004..26ffa0a 100644
--- a/tests/timer.test
+++ b/tests/timer.test
@@ -189,7 +189,16 @@ test timer-6.4 {Tcl_AfterCmd procedure, ms argument} {
update
list $y $x
} {before after}
-
+test timer-6.5 {Tcl_AfterCmd procedure, ms argument} {
+ set x before
+ after 60 {set x after}
+ after 40
+ update
+ set y $x
+ after 40
+ update
+ list $y $x
+} {before after}
test timer-6.6 {Tcl_AfterCmd procedure, cancel option} {
list [catch {after cancel} msg] $msg
} {1 {wrong # args: should be "after cancel id|command"}}