summaryrefslogtreecommitdiff
path: root/rules
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2017-08-27 17:19:57 +0200
committerDidier Raboud <odyx@debian.org>2017-08-27 17:19:57 +0200
commit3c0cfd70a255f7a450ae91ed2b530427a1ad9f36 (patch)
tree802fa79a96cef670a97e66aa4d855540caf388dc /rules
Import jimtcl_0.77-2.debian.tar.xz
[dgit import tarball jimtcl 0.77-2 jimtcl_0.77-2.debian.tar.xz]
Diffstat (limited to 'rules')
-rwxr-xr-xrules44
1 files changed, 44 insertions, 0 deletions
diff --git a/rules b/rules
new file mode 100755
index 0000000..ba9fd58
--- /dev/null
+++ b/rules
@@ -0,0 +1,44 @@
+#!/usr/bin/make -f
+
+# That's needed for DEB_VERSION_UPSTREAM
+-include /usr/share/dpkg/pkg-info.mk
+# That's needed for DEB_HOST_MULTIARCH
+-include /usr/share/dpkg/architecture.mk
+
+export DEB_CFLAGS_MAINT_APPEND = $(shell dpkg-buildflags --get CPPFLAGS)
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# Convenience shortcuts
+MA_DESTDIR ?= debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
+MA_DEV_DESTDIR ?= debian/libjim-dev/usr/lib/$(DEB_HOST_MULTIARCH)
+
+%:
+ dh $@ --list-missing
+
+override_dh_auto_configure:
+ dh_auto_configure --builddirectory=static/
+ dh_auto_configure -- --shared
+
+override_dh_auto_build:
+ dh_auto_build --builddirectory=static/
+ dh_auto_build
+
+override_dh_auto_test:
+ dh_auto_test --builddirectory=static/
+ dh_auto_test
+
+override_dh_auto_install:
+ dh_auto_install --builddirectory=static/
+ dh_auto_install
+
+override_dh_install:
+ dh_install
+ set -e; rootdir=`pwd` ;\
+ cd ${MA_DESTDIR}; libfile=`ls *.so.*`; cd $${rootdir};\
+ cd ${MA_DEV_DESTDIR}; ln -sf $${libfile} libjim.so
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f libjim.so*
+ rm -f tests/exec.tmp1
+ rm -Rf static/