summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Beckmann <anbe@debian.org>2015-07-23 21:19:04 +0200
committerAndreas Beckmann <anbe@debian.org>2015-07-23 21:19:04 +0200
commit53db8374194e1967a6767da8a1e1a0d790594c0e (patch)
tree786c360a038ff08aeb550415959abfb91fdc8bb6
parente4d40e32703005437311399266f52bf04f03efd5 (diff)
configure: do not add -L without argument to $LIBS
-rwxr-xr-xconfigure5
-rw-r--r--configure.in5
-rw-r--r--debian/changelog1
3 files changed, 9 insertions, 2 deletions
diff --git a/configure b/configure
index 55986ea..4918c96 100755
--- a/configure
+++ b/configure
@@ -2161,7 +2161,10 @@ if test x$MINGW32 = x"yes"; then
LIBS="-lgdi32 -lwinspool -lcomdlg32 -lole32 -loleaut32 -luuid \
-lodbc32 -lversion -lcomctl32 -lwsock32 -lws2_32 $LIBS"
else
- LIBS="-L$ac_x_libraries -lX11 -lXmu -lXext $LIBS"
+ LIBS="-lX11 -lXmu -lXext $LIBS"
+ if test -n "$ac_x_libraries"; then
+ LIBS="-L$ac_x_libraries $LIBS"
+ fi
fi
CFLAGS="$CFLAGS -DUSE_OLD_MALLOC"
diff --git a/configure.in b/configure.in
index 7c258cf..d2d1f36 100644
--- a/configure.in
+++ b/configure.in
@@ -93,7 +93,10 @@ if test x$MINGW32 = x"yes"; then
LIBS="-lgdi32 -lwinspool -lcomdlg32 -lole32 -loleaut32 -luuid \
-lodbc32 -lversion -lcomctl32 -lwsock32 -lws2_32 $LIBS"
else
- LIBS="-L$ac_x_libraries -lX11 -lXmu -lXext $LIBS"
+ LIBS="-lX11 -lXmu -lXext $LIBS"
+ if test -n "$ac_x_libraries"; then
+ LIBS="-L$ac_x_libraries $LIBS"
+ fi
fi
CFLAGS="$CFLAGS -DUSE_OLD_MALLOC"
diff --git a/debian/changelog b/debian/changelog
index 615d788..f94507d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ kic (2.4a-2) UNRELEASED; urgency=medium
* QA upload.
* Set Maintainer to Debian QA Group. (See: #691834)
+ * configure: Do not add -L without argument to $LIBS. (Closes: #793367)
-- Andreas Beckmann <anbe@debian.org> Thu, 23 Jul 2015 20:45:19 +0200