summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2015-12-07 23:45:54 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2015-12-14 02:28:01 +0000
commite38afbf0bf819bb5b487a9404bcbf51e8ea82f8e (patch)
tree7c7a0c869491badb2bfb520ae6e4de47be5c3992
parent5cbf0047df2e01e7389f83f0a2f21e2b797e4770 (diff)
Depend on newer version of pydoctor that supports SOURCE_DATE_EPOCH, drop custom specification of --buildtime to pydoctor.
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/05_pydoctor_build_time.diff25
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
-rw-r--r--doc/Makefile2
6 files changed, 11 insertions, 31 deletions
diff --git a/debian/changelog b/debian/changelog
index 95fe257..e425531 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+kiwi (1.9.22-4) UNRELEASED; urgency=medium
+
+ * Depend on newer version of pydoctor that supports SOURCE_DATE_EPOCH,
+ drop custom specification of --buildtime to pydoctor.
+ * Team upload.
+
+ -- Jelmer Vernooij <jelmer@debian.org> Mon, 07 Dec 2015 23:44:36 +0000
+
kiwi (1.9.22-3) unstable; urgency=medium
[ Jakub Wilk ]
diff --git a/debian/control b/debian/control
index 5442f6a..3fe007b 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Goedson Teixeira Paixao <goedson@debian.org>
Uploaders: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Build-Depends: cdbs (>= 0.4.90~), debhelper (>= 5.0.37.2), python, python-setuptools (>= 0.6b3), dh-python
-Build-Depends-Indep: python-all (>= 2.6.6-3), python-glade2 (>= 2.8.6), python-gtk2 (>= 2.8.2-3.1), python-epydoc (>= 2.1-11), python-twisted-core (>= 2.4.0), xvfb, xfonts-base, python-pydoctor (>= 0.5+git20150410)
+Build-Depends-Indep: python-all (>= 2.6.6-3), python-glade2 (>= 2.8.6), python-gtk2 (>= 2.8.2-3.1), python-epydoc (>= 2.1-11), python-twisted-core (>= 2.4.0), xvfb, xfonts-base, python-pydoctor (>= 0.5+git20151204-1)
Homepage: http://www.async.com.br/projects/kiwi/
Vcs-Git: git://anonscm.debian.org/python-modules/packages/kiwi.git
Vcs-Browser: https://anonscm.debian.org/cgit/python-modules/packages/kiwi.git
diff --git a/debian/patches/05_pydoctor_build_time.diff b/debian/patches/05_pydoctor_build_time.diff
deleted file mode 100644
index 80310f5..0000000
--- a/debian/patches/05_pydoctor_build_time.diff
+++ /dev/null
@@ -1,25 +0,0 @@
-From 919605930e763122dd7dd792b9b86305b32239e8 Mon Sep 17 00:00:00 2001
-From: Jelmer Vernoij <jelmer@debian.org>
-Date: Thu, 8 Oct 2015 09:28:28 -0700
-Subject: Allow passing in extra options to pydoctor
-
-Status: not forwarded upstream
-
-Patch-Name: 05_pydoctor_build_time.diff
----
- doc/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/doc/Makefile b/doc/Makefile
-index 73687f9..3684d0f 100644
---- a/doc/Makefile
-+++ b/doc/Makefile
-@@ -46,7 +46,7 @@ howto: howto.tex
-
- api:
- @echo Creating API documentation
-- @cd .. && pydoctor --project-name="Kiwi" --add-package=kiwi --make-html
-+ @cd .. && pydoctor $(PYDOCTOR_OPTIONS) --project-name="Kiwi" --add-package=kiwi --make-html
- @mv ../apidocs api
-
- clean:
diff --git a/debian/patches/series b/debian/patches/series
index 7aa7e61..aa2e827 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,4 +2,3 @@
01_avoid_building_howto.diff
02_avoid_version_checking.diff
04_avoid_building_helper_module.diff
-05_pydoctor_build_time.diff
diff --git a/debian/rules b/debian/rules
index f5ca3ba..b9426d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,10 +4,8 @@ include /usr/share/cdbs/1/rules/buildcore.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
-BUILD_DATE = $(shell dpkg-parsechangelog -S Date)
-
build/python-kiwi::
- cd doc && $(MAKE) api PYDOCTOR_OPTIONS="--buildtime=$(shell date -u +'%Y-%m-%d\\ %H:%M:%S' --date='$(BUILD_DATE)')"
+ cd doc && $(MAKE) api
install/python-kiwi::
mv debian/python-kiwi/usr/share/doc/kiwi/api debian/python-kiwi/usr/share/doc/python-kiwi/api
diff --git a/doc/Makefile b/doc/Makefile
index 3684d0f..73687f9 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -46,7 +46,7 @@ howto: howto.tex
api:
@echo Creating API documentation
- @cd .. && pydoctor $(PYDOCTOR_OPTIONS) --project-name="Kiwi" --add-package=kiwi --make-html
+ @cd .. && pydoctor --project-name="Kiwi" --add-package=kiwi --make-html
@mv ../apidocs api
clean: