summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2017-01-31 23:20:38 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2017-01-31 23:20:38 +0000
commitc9551acbb9d2926e023c305ad7505b0595ef06a8 (patch)
tree415bfa705480415ed511915378ace459343b0729
parent5b51653cf4a7534907731827ed767cdefcb8cc86 (diff)
Add uwsgi example ini files.
-rw-r--r--debian/changelog1
-rw-r--r--debian/klaus.examples2
-rw-r--r--debian/uwsgi-autoreload.ini20
-rw-r--r--debian/uwsgi.ini20
4 files changed, 43 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b7faf8d..77f64ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ klaus (1.0.1+git20170126-2) UNRELEASED; urgency=medium
python3-klaus/python-klaus packages for those using klaus as a library.
* Install upstream changelog.
* Install README.rst.
+ * Add uwsgi example ini files.
-- Jelmer Vernooij <jelmer@debian.org> Sun, 29 Jan 2017 23:14:52 +0000
diff --git a/debian/klaus.examples b/debian/klaus.examples
new file mode 100644
index 0000000..e97bf36
--- /dev/null
+++ b/debian/klaus.examples
@@ -0,0 +1,2 @@
+debian/uwsgi.ini
+debian/uwsgi-autoreload.ini
diff --git a/debian/uwsgi-autoreload.ini b/debian/uwsgi-autoreload.ini
new file mode 100644
index 0000000..9406112
--- /dev/null
+++ b/debian/uwsgi-autoreload.ini
@@ -0,0 +1,20 @@
+# Example klaus configuration that loads all Git repositories in a specific
+# directory.
+[uwsgi]
+socket = 127.0.0.1:8005
+uid = klaus
+gid = klaus
+master = true
+# Run between 2 and 4 processes, depending on load.
+cheaper = 2
+processes = 4
+module = klaus.contrib.wsgi_autoreload
+plugin = python3
+env = KLAUS_SITE_NAME=A site
+env = KLAUS_REPOS_ROOT=/path/to/git/repositories
+# Uncomment to enable the Git smart http server
+# env = KLAUS_USE_SMARTHTTP=1
+# Uncomment to disable pushing over the smart server
+# env = KLAUS_DISABLE_PUSH=1
+# Uncomment to allow unauthenticated pushes
+# env = KLAUS_UNAUTHENTICATED_PUSH=1
diff --git a/debian/uwsgi.ini b/debian/uwsgi.ini
new file mode 100644
index 0000000..3fc7c72
--- /dev/null
+++ b/debian/uwsgi.ini
@@ -0,0 +1,20 @@
+# Example klaus configuration that loads a specific set of repositories.
+[uwsgi]
+socket = 127.0.0.1:8005
+uid = klaus
+gid = klaus
+master = true
+# Run between 2 and 4 processes, depending on load.
+cheaper = 2
+processes = 4
+module = klaus.contrib.wsgi
+plugin = python3
+env = KLAUS_SITE_NAME=A site
+# Which repositories to load
+env = KLAUS_REPOS=/path/to/git/repo1:/path/to/git/repo2
+# Uncomment to enable the Git smart http server
+# env = KLAUS_USE_SMARTHTTP=1
+# Uncomment to disable pushing over the smart server
+# env = KLAUS_DISABLE_PUSH=1
+# Uncomment to allow unauthenticated pushes
+# env = KLAUS_UNAUTHENTICATED_PUSH=1