summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorposativ <info@posativ.org>2012-04-23 13:41:23 +0200
committerposativ <info@posativ.org>2012-04-23 13:41:23 +0200
commit230e8a4a43cfae976f6e9652dff0c89c44e85cce (patch)
treedf095fa2f2fff7e9044348adab0597c4c52a78d4 /README.rst
parente40945269ae558e3f4324ff5f8d9d99af4cb22c4 (diff)
add setup.py, klaus is now PyPi ready
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst16
1 files changed, 13 insertions, 3 deletions
diff --git a/README.rst b/README.rst
index d5881e5..2efd863 100644
--- a/README.rst
+++ b/README.rst
@@ -17,6 +17,7 @@ Demo at http://klausdemo.lophus.org
Requirements
------------
+
* Python 2.6 (2.5 should work, too)
* Werkzeug_
* Jinja2_
@@ -31,7 +32,14 @@ Requirements
Installation
------------
-*The same procedure as every year, James.* ::
+
+If you just want to test it with a simple WSGI server, type::
+
+ pip install klaus
+
+You can optionally install `bjoern <https://github.com/jonashaag/bjoern>`_ and
+klaus automatically use this backend. To use klaus with a custom WSGI server,
+it's *the same procedure as every year, James.* ::
virtualenv your-env
source your-env/bin/activate
@@ -43,8 +51,9 @@ Installation
Usage
-----
+
Using the ``klaus`` script
-..................................
+^^^^^^^^^^^^^^^^^^^^^^^^^^
::
@@ -61,7 +70,8 @@ This will make klaus serve the *klaus* and *bjoern* repos at
.. _wsgiref: http://docs.python.org/library/wsgiref.html
.. _bjoern: https://github.com/jonashaag/bjoern
-Using a real server ...................
+Using a real server
+^^^^^^^^^^^^^^^^^^^
The ``klaus/__init__.py`` module contains a WSGI ``make_app`` function which
returns the app. The repo list is read from the ``KLAUS_REPOS`` environment