summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 3 insertions, 13 deletions
diff --git a/debian/rules b/debian/rules
index 6c33a8e..b3e5de1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,17 +1,7 @@
#!/usr/bin/make -f
# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2005 Doug Rintoul <doug_rintoul@sil.org>
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/autoreconf.mk
-
-DPKG_EXPORT_BUILDFLAGS = 1
-include /usr/share/dpkg/buildflags.mk
-
-DEB_SHLIBDEPS_INCLUDE := debian/libkmflcomp/usr/lib/
-DEB_DH_INSTALL_SOURCEDIR := debian/tmp
-
-install/libkmflcomp-dev::
- sed -i "/dependency_libs/ s/'.*'/''/" `find debian/ -name '*.la'`
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+%:
+ dh $@ --with autoreconf