summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2019-04-14 12:49:36 -0400
committerFelipe Sateler <fsateler@debian.org>2019-04-14 12:55:23 -0400
commite4984270383ab2f1190e5554c9eccfb41f5cd335 (patch)
tree10f4274e9aaa52a22035c841daaceb2458f06de3
parenta80d50194722abaf2ffb1f396afa99b4c2c1ec6c (diff)
Modernize debian packaging
- Use short-form dh - Bump compat level to 12 - Add Rules-Require-Root: no annotation, as we don't need root
-rw-r--r--debian/compat1
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules17
3 files changed, 17 insertions, 5 deletions
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index f599e28..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-10
diff --git a/debian/control b/debian/control
index 5b06e18..6925066 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,7 @@ Section: sound
Priority: optional
Maintainer: Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Build-Depends:
- cdbs,
- debhelper (>= 10)
+ debhelper-compat (= 12)
Standards-Version: 3.9.8
Uploaders:
Felipe Sateler <fsateler@debian.org>,
@@ -12,6 +11,7 @@ Uploaders:
Vcs-Git: https://salsa.debian.org/multimedia-team/ladspa-sdk.git
Vcs-Browser: https://salsa.debian.org/multimedia-team/ladspa-sdk
Homepage: http://www.ladspa.org/
+Rules-Requires-Root: no
Package: ladspa-sdk
Architecture: any
diff --git a/debian/rules b/debian/rules
index 0078081..27b66f0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,21 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-include /usr/share/cdbs/1/class/makefile.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
+%:
+ dh $@ --sourcedirectory=src
+
+override_dh_auto_build:
+ mkdir -p plugins bin
+ dh_auto_build -- targets
+
+override_dh_auto_install:
+ dh_auto_install -- DESTDIR=$(CURDIR)/debian/ladspa-sdk \
+ INSTALL_PLUGINS_DIR=$(CURDIR)/debian/ladspa-sdk/usr/lib/ladspa/ \
+ INSTALL_INCLUDE_DIR=$(CURDIR)/debian/ladspa-sdk/usr/include/ \
+ INSTALL_BINARY_DIR=$(CURDIR)/debian/ladspa-sdk/usr/bin/
+
+# Tests require humans
+override_dh_auto_test:
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1