summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@gmail.com>2009-06-05 14:27:17 +1000
committerFelipe Sateler <fsateler@gmail.com>2009-06-05 14:27:17 +1000
commit53b9912fa19a223c9b2d0c88c8a7d8af455b1c47 (patch)
tree38b96b5ad7fea8a6077c9bda76a3551d946b8315 /debian/rules
parentd7f4179cb3d128a93a18689fd81df505fa6df6f6 (diff)
Switch to debhelper compat level 7
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules72
1 files changed, 9 insertions, 63 deletions
diff --git a/debian/rules b/debian/rules
index ddeab80..6607404 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,77 +1,23 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-include /usr/share/quilt/quilt.make
+%:
+ dh --with quilt $@
-# This is the debhelper compatability version to use.
-export DH_COMPAT=3
-configure: configure-stamp
-configure-stamp: $(QUILT_STAMPFN)
- dh_testdir
- # Add here commands to configure the package.
- touch configure-stamp
+override_dh_auto_build:
+ $(MAKE) -C src targets
-build: configure-stamp build-stamp
-build-stamp:
- dh_testdir
+override_dh_auto_clean:
+ dh_auto_clean
+ $(MAKE) -C src clean
- # Add here commands to compile the package.
- cd src; $(MAKE) targets
-
- touch build-stamp
-
-clean: unpatch
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- cd src; $(MAKE) clean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/ladspa-sdk.
-
- cd src; $(MAKE) install DESTDIR=$(CURDIR)/debian/ladspa-sdk \
+override_dh_auto_install:
+ $(MAKE) -C src install DESTDIR=$(CURDIR)/debian/ladspa-sdk \
INSTALL_PLUGINS_DIR=$(CURDIR)/debian/ladspa-sdk/usr/lib/ladspa/ \
INSTALL_INCLUDE_DIR=$(CURDIR)/debian/ladspa-sdk/usr/include/ \
INSTALL_BINARY_DIR=$(CURDIR)/debian/ladspa-sdk/usr/bin/
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installexamples
- dh_installmenu
- dh_installman debian/analyseplugin.1 debian/applyplugin.1 debian/listplugins.1
- dh_installchangelogs
- dh_link usr/include/ladspa.h usr/share/doc/ladspa-sdk/ladspa.h.txt
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure