summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2018-10-04 15:53:38 +0200
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2018-10-04 15:54:07 +0200
commit60248efef8a9f868e880e535121911efdb41d996 (patch)
tree3d3c3cbc72e020abe60744cc5dfd9f645997f0de
parent6303e37f259d7185109655921734cd5db35300c4 (diff)
No longer ship real landslide binary, install a wrapper for darkslide instead
-rw-r--r--debian/control2
-rw-r--r--debian/install1
-rwxr-xr-xdebian/landslide13
-rw-r--r--debian/landslide.179
-rw-r--r--debian/python-landslide.examples1
-rwxr-xr-xdebian/rules7
6 files changed, 21 insertions, 82 deletions
diff --git a/debian/control b/debian/control
index 0da7068..99c61a7 100644
--- a/debian/control
+++ b/debian/control
@@ -19,7 +19,7 @@ Vcs-Browser: https://salsa.debian.org/debian/landslide
Package: python-landslide
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}, python-pkg-resources
+Depends: ${misc:Depends}, ${python:Depends}, python-pkg-resources, darkslide
Provides: ${python:Provides}
Description: Lightweight markup language-based html5 slideshow generator
Landside is a tool which can generates an HTML5 slideshow using lightweight
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..dba4623
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+debian/landslide usr/bin
diff --git a/debian/landslide b/debian/landslide
new file mode 100755
index 0000000..1022571
--- /dev/null
+++ b/debian/landslide
@@ -0,0 +1,13 @@
+#!/usr/bin/python3
+import re
+import sys
+from pkg_resources import load_entry_point
+
+if __name__ == '__main__':
+ print(
+"""Warning: landslide binary has been deprecated and will be removed in future.
+Please change your scripts to use darkslide instead.
+""", file=sys.stderr)
+ sys.exit(
+ load_entry_point('darkslide', 'console_scripts', 'darkslide')()
+ )
diff --git a/debian/landslide.1 b/debian/landslide.1
index 43a2994..38e8991 100644
--- a/debian/landslide.1
+++ b/debian/landslide.1
@@ -1,78 +1 @@
-.TH LANDSLIDE 1 "March 2011" "Landslide" "User Commands"
-.SH NAME
-landslide \- html5 slideshow generator
-.SH SYNOPSIS
-.B landslide
-[\fIoptions\fR] \fIinput.md \fR...
-.SH DESCRIPTION
-Landside is a tool which can generates an HTML5 slideshow using lightweight
-markup as input.
-.PP
-You can write your slide contents easily using two syntaxes:
-.TP
-.B Markdown
-.TP
-.B ReStructuredText
-.PP
-This tool support CSS/JS theming, PDF export (using PrinceXML Python library),
-embed images with Base64 (for stand-alone document) and fancy transitions.
-.PP
-Sample presentation is visible here : <http://slides.html5rocks.com/>.
-.SH OPTIONS
-.TP
-\fB\-h\fR, \fB\-\-help\fR
-show help message and exit
-.TP
-\fB\-b\fR, \fB\-\-debug\fR
-Will display any exception trace to stdin
-.TP
-\fB\-d\fR \fIFILE\fR, \fB\-\-destination\fR=\fIFILE\fR
-The path to the to the destination file: .html or .pdf
-extensions allowed (default: presentation.html)
-.TP
-\fB\-e\fR \fIENCODING\fR, \fB\-\-encoding\fR=\fIENCODING\fR
-The encoding of your files (defaults to utf8)
-.TP
-\fB\-i\fR, \fB\-\-embed\fR
-Embed stylesheet and javascript contents,
-base64\-encoded images in presentation to make a
-standalone document
-.TP
-\fB\-l\fR \fILINENOS\fR, \fB\-\-linenos\fR=\fILINENOS\fR
-How to output linenos in source code. Three options are
-available: no (no line numbers); inline (inside <pre>
-tag); table (lines numbers in another cell, copy-paste
-friendly)
-.TP
-\fB\-m\fR, \fB\-\-math-output\fR
-Enable mathematical output using mathjax
-.TP
-\fB\-o\fR, \fB\-\-direct\-output\fR
-Prints the generated HTML code to stdin; won't work
-with PDF export
-.TP
-\fB\-q\fR, \fB\-\-quiet\fR
-Won't write anything to stdin (silent mode)
-.TP
-\fB\-r\fR, \fB\-\-relative\fR
-Make your presentation asset links relative to current
-pwd; This may be useful if you intend to publish your
-html presentation online.
-.TP
-\fB\-t\fR \fITHEME\fR, \fB\-\-theme\fR=\fITHEME\fR
-A theme name, or path to a landslide theme directory
-.TP
-\fB\-v\fR, \fB\-\-verbose\fR
-Write informational messages to stdin (enabled by
-default)
-.TP
-\fB\-w\fR, \fB\-\-watch\fR
-Watch the source directory for changes and
-auto-regenerate the presentation
-.TP
-\fB\-x\fR \fIEXTENSIONS\fR, \fB\-\-extensions\fR=\fIEXTENSIONS\fR
-Comma-separated list of extensions for Markdown
-.SH DIAGNOSTICS
-Note: PDF export requires the `prince` program: http://princexml.com/
-.SH AUTHOR
-Damien Raude-Morvan <drazzib@debian.org>
+.so man1/darkslide.1
diff --git a/debian/python-landslide.examples b/debian/python-landslide.examples
deleted file mode 100644
index e39721e..0000000
--- a/debian/python-landslide.examples
+++ /dev/null
@@ -1 +0,0 @@
-examples/*
diff --git a/debian/rules b/debian/rules
index 3aa0338..d7fcbb5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,13 @@
#!/usr/bin/make -f
-export PYBUILD_BEFORE_TEST := ln -s $(CURDIR)/src/landslide/test-data {build_dir}/landslide
-export PYBUILD_AFTER_TEST := rm {build_dir}/landslide/test-data
+export PYBUILD_DISABLE_python2=test
%:
dh $@ --with python2 --buildsystem=pybuild
+override_dh_auto_install:
+ dh_auto_install
+ rm debian/*/usr/bin/landslide
+
get-orig-source:
uscan --force-download --rename