summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2017-12-29 13:28:29 -0800
committerRuss Allbery <eagle@eyrie.org>2017-12-29 13:50:35 -0800
commit0def6ac619c467329ee90ee4fc99fec358bab48e (patch)
treec6ae07dbdefe8be762e283d36a3b5d2761fc3583
parent6dce94b7507ee4e487159c799bb91f2527af2c52 (diff)
Drop NO_START support, use defaults-disabled
* Remove support for NO_START in the init script. There was already logic in place to disable the init script when upgrading from older versions that supported NO_START. * Use update-rc.d defaults-disabled when upgrading from older versions.
-rw-r--r--debian/changelog4
-rw-r--r--debian/control1
-rwxr-xr-xdebian/init4
-rwxr-xr-xdebian/postinst2
4 files changed, 6 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 8eafd85..0b82e7a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,10 @@ lbcd (3.5.2-3) UNRELEASED; urgency=medium
- Remove now-unnecessary dh-autoreconf and dh-systemd dependencies.
- Remove explicit configuration of autoreconf and systemd sequences.
* Update standards version to 4.1.3.
+ - Remove support for NO_START in the init script. There was already
+ logic in place to disable the init script when upgrading from older
+ versions that supported NO_START.
+ - Use update-rc.d defaults-disabled when upgrading from older versions.
- Use https URLs in debian/copyright.
- Remove upstart configuration.
* Set Rules-Requires-Root: no.
diff --git a/debian/control b/debian/control
index fc3e03c..b8e1df8 100644
--- a/debian/control
+++ b/debian/control
@@ -6,6 +6,7 @@ Uploaders:
Guido Guenther <agx@sigxcpu.org>,
Build-Depends:
debhelper (>= 11),
+ init-system-helpers (>= 1.50),
libsystemd-dev [linux-any],
libtest-minimumversion-perl,
libtest-pod-perl,
diff --git a/debian/init b/debian/init
index 267d420..0ea1934 100755
--- a/debian/init
+++ b/debian/init
@@ -71,10 +71,6 @@ do_stop()
case "$1" in
start)
- if [ "$NO_START" = 1 ] ; then
- log_warning_msg "Not starting $NAME (see /etc/default/$NAME)"
- exit 0
- fi
[ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"
do_start
case "$?" in
diff --git a/debian/postinst b/debian/postinst
index 8d3a0fb..c2c16fd 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -16,7 +16,7 @@ if [ "$1" = 'configure' ] && [ -f /etc/default/lbcd ] ; then
if [ -n "$2" ] && dpkg --compare-versions "$2" lt 3.5.0 ; then
. /etc/default/lbcd
if [ "$NO_START" = 1 ] ; then
- update-rc.d lbcd disable >/dev/null 2>&1
+ update-rc.d lbcd defaults-disabled >/dev/null 2>&1
fi
fi
fi