summaryrefslogtreecommitdiff
path: root/debian/autodeps.py
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@debian.org>2010-10-20 15:22:13 +0200
committerJelmer Vernooij <jelmer@debian.org>2010-10-20 15:22:13 +0200
commit8db34fd70ac0c0b5846c271e4934f66a8a71e4a1 (patch)
tree389e08ce4adf61e1aaf9da11eebec2a5008ea7e4 /debian/autodeps.py
parent85785f134f0cb81867087b657b81c9eee3101678 (diff)
Avoid dependency on python-debian.
Diffstat (limited to 'debian/autodeps.py')
-rwxr-xr-xdebian/autodeps.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/autodeps.py b/debian/autodeps.py
index 999bd47..f4c28e2 100755
--- a/debian/autodeps.py
+++ b/debian/autodeps.py
@@ -4,7 +4,6 @@
# Licensed under the GNU GPL, version 2 or later.
import ConfigParser
-from debian.deb822 import Deb822, PkgRelation
import optparse
import os
import sys
@@ -22,8 +21,8 @@ if len(args) != 1:
else:
parser.print_usage()
sys.exit(1)
-
-tree = args[0]
+else:
+ tree = args[0]
def update_relation(line, pkg, kind, version):
"""Update a relation in a control field.
@@ -90,6 +89,7 @@ def find_version(path):
def update_control():
"""Update the debian control file.
"""
+ from debian.deb822 import Deb822, PkgRelation
f = open('debian/control', 'r')
iter = Deb822.iter_paragraphs(f)
source = iter.next()