summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@debian.org>2011-02-12 04:48:14 +0100
committerJelmer Vernooij <jelmer@debian.org>2011-02-12 04:48:14 +0100
commitb676ffabc83d15a38e4a49f185740431c7ade416 (patch)
treebf2d67147f5101507adc4a2b7ef252e6c075ce9e /debian
parentc8ce272285dbfbd8d40596bf52fdec57ef2ba291 (diff)
parent5160325afa1121860388cbe6a540992ffc015ce6 (diff)
Merge 0.9.22 changelog.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/build-orig.sh9
-rw-r--r--debian/changelog11
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
4 files changed, 18 insertions, 8 deletions
diff --git a/debian/build-orig.sh b/debian/build-orig.sh
index a4f576c..f3d41f8 100755
--- a/debian/build-orig.sh
+++ b/debian/build-orig.sh
@@ -5,11 +5,10 @@ if [ -z "$SAMBA_GIT_URL" ]; then
fi
LDBTMP=`mktemp -d`
-git clone --depth 1 $SAMBA_GIT_URL $LDBTMP
-if [ ! -z "$REFSPEC" ]; then
- pushd $LDBTMP
- git checkout $REFSPEC
- popd
+if [ -d $SAMBA_GIT_URL/.bzr ]; then
+ bzr co --lightweight $SAMBA_GIT_URL $LDBTMP
+else
+ git clone --depth 1 $SAMBA_GIT_URL $LDBTMP
fi
pushd $LDBTMP/source4/lib/ldb
./autogen.sh
diff --git a/debian/changelog b/debian/changelog
index ab87e19..1c7666d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,6 +15,17 @@ ldb (1:0.9.24-1) experimental; urgency=low
-- Jelmer Vernooij <jelmer@debian.org> Sat, 23 Oct 2010 20:00:40 +0200
+ldb (1:0.9.22-1) unstable; urgency=low
+
+ * New upstream release.
+ + Add python-ldb-dev package.
+ + Uses version symbols.
+ * Switch to python-support.
+ * Link with --as-needed.
+ * Run test suite during build.
+
+ -- Jelmer Vernooij <jelmer@debian.org> Wed, 22 Dec 2010 00:05:26 +0100
+
ldb (1:0.9.16~git20101019-1) unstable; urgency=low
* New upstream snapshot.
diff --git a/debian/control b/debian/control
index 5822fb9..7b1c462 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: ldb
Section: devel
Priority: optional
Maintainer: Jelmer Vernooij <jelmer@debian.org>
-Build-Depends: debhelper (>> 6.0.7~), libtdb-dev (>= 1.2.9~), libtalloc-dev (>= 2.0.5~), libtevent-dev (>= 0.9.10~), pkg-config, libpopt-dev, docbook-xsl, docbook-xml, xsltproc, python-dev, python-central (>= 0.5.6), python-tdb (>= 1.2.9~), libldap2-dev, python-talloc-dev (>= 2.0.5~)
+Build-Depends: debhelper (>> 6.0.7~), libtdb-dev (>= 1.2.9~), libtalloc-dev (>= 2.0.5~), libtevent-dev (>= 0.9.10~), pkg-config, libpopt-dev, docbook-xsl, docbook-xml, xsltproc, python-dev, python-support, python-tdb (>= 1.2.9~), libldap2-dev, python-talloc-dev (>= 2.0.5~)
Homepage: http://ldb.samba.org/
Standards-Version: 3.9.1
Vcs-Bzr: http://bzr.debian.org/pkg-samba/ldb/unstable
diff --git a/debian/rules b/debian/rules
index 3588e85..f8b5275 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,7 +28,7 @@ get-orig-source:
clean:
dh_testdir
dh_testroot
- rm -f configure-stamp
+ rm -f build-stamp configure-stamp
-$(WAF) clean
rm -rf buildtools/bin/.waf-*
rm -f buildtools/wafsamba/*.pyc
@@ -64,7 +64,7 @@ binary-arch: build install
dh_compress
dh_fixperms
dh_makeshlibs -- -c4
- dh_pycentral
+ dh_pysupport
dh_installdeb
dh_shlibdeps
dh_gencontrol