summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/build-orig.sh8
-rw-r--r--debian/changelog17
-rw-r--r--debian/control5
-rw-r--r--debian/libldb1.lintian-overrides1
-rw-r--r--debian/libldb1.symbols8
-rw-r--r--debian/python-ldb.lintian-overrides1
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/watch2
8 files changed, 36 insertions, 12 deletions
diff --git a/debian/build-orig.sh b/debian/build-orig.sh
index f3d41f8..523b172 100755
--- a/debian/build-orig.sh
+++ b/debian/build-orig.sh
@@ -1,5 +1,11 @@
#!/bin/bash -e
+version=$( dpkg-parsechangelog -l`dirname $0`/changelog | sed -n 's/^Version: \(.*:\|\)//p' | sed 's/-[0-9.]\+$//' )
+if echo $version | grep -v git >/dev/null; then
+ # Not a snapshot, use watch
+ exit 1
+fi
+
if [ -z "$SAMBA_GIT_URL" ]; then
SAMBA_GIT_URL=git://git.samba.org/samba.git
fi
@@ -11,10 +17,8 @@ else
git clone --depth 1 $SAMBA_GIT_URL $LDBTMP
fi
pushd $LDBTMP/source4/lib/ldb
-./autogen.sh
./configure
make dist
popd
-version=$( dpkg-parsechangelog -l`dirname $0`/changelog | sed -n 's/^Version: \(.*:\|\)//p' | sed 's/-[0-9.]\+$//' )
mv $LDBTMP/source4/lib/ldb/ldb-*.tar.gz ldb_$version.orig.tar.gz
rm -rf $LDBTMP
diff --git a/debian/changelog b/debian/changelog
index 4a76fbf..b608155 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,15 @@
-ldb (1:1.0.2-3) UNRELEASED; urgency=low
+ldb (1:1.1.0-1) UNRELEASED; urgency=low
+ * New upstream release.
+
+ -- Jelmer Vernooij <jelmer@debian.org> Fri, 22 Apr 2011 02:58:49 +0200
+
+ldb (1:1.0.2+git20110403-1) experimental; urgency=low
+
+ * New upstream snapshot.
* Switch to dh_python2. Closes: #616857
- -- Jelmer Vernooij <jelmer@debian.org> Mon, 07 Mar 2011 03:32:30 +0100
+ -- Jelmer Vernooij <jelmer@debian.org> Sun, 03 Apr 2011 21:51:32 +0200
ldb (1:1.0.2-2) unstable; urgency=low
@@ -16,6 +23,12 @@ ldb (1:1.0.2-1) unstable; urgency=low
-- Jelmer Vernooij <jelmer@debian.org> Sun, 27 Feb 2011 14:29:46 +0100
+ldb (1:1.0.1~git20120220-1) experimental; urgency=low
+
+ * New upstream snapshot.
+
+ -- Jelmer Vernooij <jelmer@debian.org> Sun, 20 Feb 2011 14:42:57 +0100
+
ldb (1:1.0.0-2) unstable; urgency=low
* Add breaks/conflicts for libldb0.
diff --git a/debian/control b/debian/control
index e76bcd6..f0f36ba 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends: debhelper (>> 6.0.7~),
libpopt-dev,
libtalloc-dev (>= 2.0.5~),
libtdb-dev (>= 1.2.9~),
- libtevent-dev (>= 0.9.10~),
+ libtevent-dev (>= 0.9.11~),
pkg-config,
python-dev (>= 2.6.6-3),
python-talloc-dev (>= 2.0.5~),
@@ -18,7 +18,7 @@ Build-Depends: debhelper (>> 6.0.7~),
Homepage: http://ldb.samba.org/
Standards-Version: 3.9.1
Vcs-Bzr: http://bzr.debian.org/pkg-samba/ldb/unstable
-X-Python-Version: >= 2.4
+X-Python-Version: 2.7
Package: libldb1
Architecture: any
@@ -77,6 +77,7 @@ Depends: libldb1 (= ${binary:Version}),
${python:Depends},
${shlibs:Depends}
Provides: ${python:Provides}
+Breaks: ${python:Breaks}
Description: Python bindings for LDB
ldb is a LDAP-like embedded database built on top of TDB.
.
diff --git a/debian/libldb1.lintian-overrides b/debian/libldb1.lintian-overrides
new file mode 100644
index 0000000..16bc4e8
--- /dev/null
+++ b/debian/libldb1.lintian-overrides
@@ -0,0 +1 @@
+libldb1 binary: breaks-without-version libldb0
diff --git a/debian/libldb1.symbols b/debian/libldb1.symbols
index 673f01d..b390a21 100644
--- a/debian/libldb1.symbols
+++ b/debian/libldb1.symbols
@@ -6,12 +6,16 @@ libldb.so.1 #PACKAGE# #MINVER#
LDB_0.9.17@LDB_0.9.17 0.9.21
LDB_0.9.18@LDB_0.9.18 0.9.21
LDB_0.9.19@LDB_0.9.19 0.9.21
+ LDB_0.9.20@LDB_0.9.20 0.9.21
LDB_0.9.22@LDB_0.9.22 0.9.22
LDB_0.9.23@LDB_0.9.23 0.9.23
LDB_0.9.24@LDB_0.9.24 0.9.24
- LDB_1.0.2@LDB_1.0.2 1.0.2
+ LDB_1.0.0@LDB_1.0.0 1.0.2~
+ LDB_1.0.1@LDB_1.0.1 1.0.1~
+ LDB_1.0.2@LDB_1.0.2 1.0.2~
ldb_check_critical_controls@LDB_0.9.22 0.9.22
ldb_controls_except_specified@LDB_0.9.22 0.9.22
+ ldb_control_to_string@LDB_1.0.2 1.0.2~git20110403
ldb_add@LDB_0.9.10 0.9.21
ldb_any_comparison@LDB_0.9.10 0.9.21
ldb_asprintf_errstring@LDB_0.9.10 0.9.21
@@ -193,7 +197,7 @@ libldb.so.1 #PACKAGE# #MINVER#
ldb_next_start_trans@LDB_0.9.10 0.9.21
ldb_op_default_callback@LDB_0.9.10 0.9.21
ldb_options_find@LDB_0.9.17 0.9.21
- ldb_parse_control_from_string@LDB_1.0.2 1.0.2
+ ldb_parse_control_from_string@LDB_1.0.2 1.0.2~git20110403
ldb_parse_control_strings@LDB_0.9.10 0.9.21
ldb_parse_tree@LDB_0.9.10 0.9.21
ldb_parse_tree_attr_replace@LDB_0.9.10 0.9.21
diff --git a/debian/python-ldb.lintian-overrides b/debian/python-ldb.lintian-overrides
index d27414d..b37b5d1 100644
--- a/debian/python-ldb.lintian-overrides
+++ b/debian/python-ldb.lintian-overrides
@@ -1 +1,2 @@
python-ldb binary: binary-or-shlib-defines-rpath * /usr/lib/ldb
+python-ldb binary: package-name-doesnt-match-sonames libpyldb-util1
diff --git a/debian/rules b/debian/rules
index 074dcee..f12d30e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -50,14 +50,14 @@ install: build
ar cr $(DESTDIR)/usr/lib/libldb.a bin/default/common/*.o
dh_install --fail-missing --list-missing --sourcedir=$(DESTDIR)
-binary-indep:
+binary-indep:
binary-arch: build install
dh_testdir
dh_testroot
- dh_installdocs
+ dh_installdocs
dh_installman
dh_installexamples
- dh_installchangelogs
+ dh_installchangelogs
dh_lintian
dh_link
dh_strip
diff --git a/debian/watch b/debian/watch
index c953798..728c43c 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,2 +1,2 @@
version=3
-ftp://ftp.samba.org/pub/ldb/ldb-(.+).tar.gz
+http://ftp.samba.org/pub/ldb/ldb-(.+).tar.gz