summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 1 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index d709009e2..cd66ed7e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,13 +9,6 @@ include /usr/share/dpkg/buildtools.mk
dh $@
execute_after_dh_auto_build:
- # compile host architecture version to be included in ldraw-mklist package
- $(CC) -o mklist $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -I./include mklist.c
- # compile build architecture version to run during the build
- # this is only needed to support cross-compilation
- # in the native case, this is identical to the above
- $(CC_FOR_BUILD) -o mklist-native $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -I./include mklist.c
- ./mklist-native -i parts -d
# make sure that d/copyright is up-to-date
python3 debian/gencopyright.py | cmp - debian/copyright
@@ -24,5 +17,5 @@ execute_after_dh_auto_install:
cp -r LDCfgalt.ldr LDConfig.ldr LDConfig_TLG.ldr parts models p debian/tmp/usr/share/ldraw/
execute_after_dh_auto_clean:
- rm -f mklist mklist-native parts.lst
+ rm -f parts.lst
[ -e debian/copyright ] || python3 debian/gencopyright.py > debian/copyright