summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 13 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index a4cacde..61d4335 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,20 +30,23 @@ H2MANPAGES=ambix-info.1 ambix-interleave.1 ambix-deinterleave.1 ambix-jplay.1 am
override_dh_install:
dh_install -X "*.la"
-override_dh_installman: $(H2MANPAGES)
- dh_installman
+execute_before_dh_installman: $(H2MANPAGES)
-override_dh_fixperms:
- dh_fixperms
+execute_after_dh_fixperms:
find debian/*/usr/ -name "*.pd_linux" -exec chmod -x {} +
-override_dh_clean:
- dh_clean
+execute_after_dh_clean:
rm -f $(H2MANPAGES)
find samples/pd -xtype l -delete
%.1: utils/%
- help2man \
- -l --no-discard-stderr -N \
- -n "AMBIsonics eXchange utility" \
- -h -h -v -V $^ > $@
+ cp debian/manpages/$@ $@
+ -help2man \
+ --libtool \
+ --no-discard-stderr \
+ --no-info \
+ --name "AMBIsonics eXchange utility" \
+ --help-option=-h \
+ --version-string=-V \
+ --output $@ \
+ $^