summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cddb_lookup.c4
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/copyright2
-rw-r--r--debian/patches/implicit-function-declaration.patch22
-rw-r--r--debian/patches/series1
6 files changed, 37 insertions, 2 deletions
diff --git a/cddb_lookup.c b/cddb_lookup.c
index b569bd2..4911a76 100644
--- a/cddb_lookup.c
+++ b/cddb_lookup.c
@@ -21,6 +21,10 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#include "cdaudio.h"
#include "cddb_lookup.h"
#include "stdio.h"
+#include <stdlib.h>
+#include <string.h>
+#include <sys/socket.h>
+#include <signal.h>
#define PACKAGE "Audio::CD"
diff --git a/debian/changelog b/debian/changelog
index 1c51486..b3b9e40 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libaudio-cd-perl (0.05-13) unstable; urgency=medium
+
+ * Add patch to add missing #includes. (Closes: #1065762)
+ * Update years of packaging copyright.
+ * Declare compliance with Debian Policy 4.6.2.
+
+ -- gregor herrmann <gregoa@debian.org> Sun, 10 Mar 2024 13:18:16 +0100
+
libaudio-cd-perl (0.05-12) unstable; urgency=medium
[ gregor herrmann ]
diff --git a/debian/control b/debian/control
index 27fcd6e..8e4c595 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Build-Depends: debhelper-compat (= 13),
libcdaudio-dev,
perl-xs-dev,
perl:native
-Standards-Version: 4.6.1
+Standards-Version: 4.6.2
Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libaudio-cd-perl
Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libaudio-cd-perl.git
Homepage: https://www.vanhemert.co.uk/disc-cover-1_5_6/
diff --git a/debian/copyright b/debian/copyright
index f465237..3af7101 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -90,7 +90,7 @@ Copyright: 2002, Bart Warmerdam <bartw@debian.org>
2003, Bart Warmerdam <bartw@xs4all.nl>
2005, 2006, Jereme Corrado <jereme@zoion.net>
2005, Andrew Pollock <apollock@debian.org>
- 2008-2022, gregor herrmann <gregoa@debian.org>
+ 2008-2024, gregor herrmann <gregoa@debian.org>
License: GPL-1+ or Artistic
License: Artistic
diff --git a/debian/patches/implicit-function-declaration.patch b/debian/patches/implicit-function-declaration.patch
new file mode 100644
index 0000000..621828b
--- /dev/null
+++ b/debian/patches/implicit-function-declaration.patch
@@ -0,0 +1,22 @@
+Description: add more #includes
+ for building with -Werror=implicit-function-declaration
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/1065762
+Author: gregor herrmann <gregoa@debian.org>
+Last-Update: 2024-03-10
+Forwarded: https://rt.cpan.org/Ticket/Display.html?id=152236
+Bug: https://rt.cpan.org/Ticket/Display.html?id=152236
+
+--- a/cddb_lookup.c
++++ b/cddb_lookup.c
+@@ -21,6 +21,10 @@
+ #include "cdaudio.h"
+ #include "cddb_lookup.h"
+ #include "stdio.h"
++#include <stdlib.h>
++#include <string.h>
++#include <sys/socket.h>
++#include <signal.h>
+
+ #define PACKAGE "Audio::CD"
+
diff --git a/debian/patches/series b/debian/patches/series
index d482304..fbd6e68 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
fix_pod
+implicit-function-declaration.patch