summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Kanashiro <kanashiro.duarte@gmail.com>2015-12-09 23:04:43 -0200
committerLucas Kanashiro <kanashiro.duarte@gmail.com>2015-12-09 23:04:43 -0200
commit7bc914d14ee47f8a0f7904d7ef76549027ee7976 (patch)
tree0956ec00bb47815a7d2d5faadc853218132ad47d
parent81c3c729afd243263fb6d04f83e3316b40c1bdab (diff)
parentd4cbab6f7f72b411aff847e710b7b6475a5f4bca (diff)
Merge tag 'upstream/0.26'
Upstream version 0.26 # gpg: Signature made Wed 09 Dec 2015 11:04:34 PM BRST using RSA key ID 9883C97C # gpg: Good signature from "Lucas Kanashiro <kanashiro.duarte@gmail.com>" # gpg: WARNING: This key is not certified with a trusted signature! # gpg: There is no indication that the signature belongs to the owner. # Primary key fingerprint: 8ED6 C3F8 BAC9 DB7F C130 A870 F823 A272 9883 C97C
-rw-r--r--Changes4
-rw-r--r--META.json2
-rw-r--r--META.yml2
-rw-r--r--TacacsPlus.pm2
-rw-r--r--tacpluslib/Makefile.PL3
5 files changed, 9 insertions, 4 deletions
diff --git a/Changes b/Changes
index 4f928c1..30b1af7 100644
--- a/Changes
+++ b/Changes
@@ -61,3 +61,7 @@ Revision history for Perl extension Authen::TacacsPlus.
0.24 Fri Mar 22, 2013 Mike McCauley
- Updated author and distribution location details to airspayce.com
+
+0.26 2015-12-08 Mike McCauley
+ - pass CFLAGS and CPPFLAGS explicitly in the subdirectory to get all
+ hardening flags, Patch from Florian Schlichting.
diff --git a/META.json b/META.json
index bdbbe8b..5c5cf13 100644
--- a/META.json
+++ b/META.json
@@ -35,5 +35,5 @@
}
},
"release_status" : "stable",
- "version" : "0.25"
+ "version" : "0.26"
}
diff --git a/META.yml b/META.yml
index ae8e343..73a964f 100644
--- a/META.yml
+++ b/META.yml
@@ -18,4 +18,4 @@ no_index:
- t
- inc
requires: {}
-version: '0.25'
+version: '0.26'
diff --git a/TacacsPlus.pm b/TacacsPlus.pm
index bd03468..29a8c3c 100644
--- a/TacacsPlus.pm
+++ b/TacacsPlus.pm
@@ -17,7 +17,7 @@ require DynaLoader;
@EXPORT_OK = qw(
TACPLUS_CLIENT
);
-$VERSION = '0.25';
+$VERSION = '0.26';
sub new
{
diff --git a/tacpluslib/Makefile.PL b/tacpluslib/Makefile.PL
index 790d251..45d3c96 100644
--- a/tacpluslib/Makefile.PL
+++ b/tacpluslib/Makefile.PL
@@ -19,7 +19,8 @@ WriteMakefile(
NAME => 'Authen::TacacsPlus::tacplus',
DEFINE => $defines{$osname},
SKIP => [qw(static dynamic)],
- clean => {'FILES' => 'libtacplus$(LIB_EXT)'},
+ clean => {'FILES' => 'libtacplus$(LIB_EXT)'},
+ CCFLAGS => "$ENV{'CFLAGS'} $ENV{'CPPFLAGS'}",
);
sub MY::top_targets {