summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-09-22 15:09:02 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-09-22 15:10:38 +0200
commitd164cdc4321c6a9741b2d228b23ef4b09aa95bbc (patch)
treeaa8028dec6c9eab8b4120b94fbc73454c708bbcc
parentc28b4c76454edef8888be391dd7bb81be7b609b4 (diff)
Added autopkgtest and prepare new version
-rw-r--r--debian/changelog13
-rw-r--r--debian/compat2
-rw-r--r--debian/control4
-rwxr-xr-xdebian/tests/can-link25
-rw-r--r--debian/tests/control2
5 files changed, 43 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index fc1f716..81d8a8a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+libbtbb (2018.08.R1-1) UNRELEASED; urgency=medium
+
+ * New upstream release
+ * debian/compat: level 11
+ * debian/control:
+ - debhelper >= 11
+ - New standards version 4.2.1 - no changes
+ * debian/tests:
+ - Added autopkgtest to verify that it is possible to link with the library.
+ * debian/upstream/metadata: added metadata file
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Sat, 22 Sep 2018 15:08:16 +0200
+
libbtbb (2018.06.R1-1) unstable; urgency=medium
* New upstream release
diff --git a/debian/compat b/debian/compat
index ec63514..b4de394 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+11
diff --git a/debian/control b/debian/control
index 9c59c14..d6d16c6 100644
--- a/debian/control
+++ b/debian/control
@@ -2,11 +2,11 @@ Source: libbtbb
Section: libs
Priority: optional
Maintainer: Ruben Undheim <ruben.undheim@gmail.com>
-Build-Depends: debhelper (>= 9),
+Build-Depends: debhelper (>= 11),
libpcap-dev,
cmake
Build-Depends-Indep: python-all-dev
-Standards-Version: 4.1.5
+Standards-Version: 4.2.1
Vcs-Git: https://github.com/rubund/debian-libbtbb.git
Vcs-Browser: https://github.com/rubund/debian-libbtbb/tree/master
Homepage: http://libbtbb.sourceforge.net/
diff --git a/debian/tests/can-link b/debian/tests/can-link
new file mode 100755
index 0000000..25108f0
--- /dev/null
+++ b/debian/tests/can-link
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+set -e
+
+WORKDIR=$(mktemp -d)
+trap "rm -rf $WORKDIR" 0 INT QUIT ABRT PIPE TERM
+cd $WORKDIR
+cat <<EOF > btbbtest.c
+#include <btbb.h>
+
+int main()
+{
+ return 0;
+}
+EOF
+
+pkg-config --cflags --libs libbtbb
+
+gcc -o btbbtest btbbtest.c `pkg-config --cflags --libs libbtbb`
+echo "build: OK"
+[ -x btbbtest ]
+# > /dev/null because it writes this: full talloc report on 'sccp' (total 1 bytes in 1 blocks)
+./btbbtest
+echo "run: OK"
+
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..9f7fae5
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,2 @@
+Tests: can-link
+Depends: libbtbb-dev