summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2018-07-28 18:15:53 +0100
committerAndrej Shadura <andrewsh@debian.org>2018-07-28 18:15:53 +0100
commit5a2111ed85cee3d65f07430bdd32efcce3eb9498 (patch)
tree8f9aaba84f7a5865420d57bf5075671ec83aca8b
Import original source of Convert-Color-XTerm 0.05
-rw-r--r--Build.PL20
-rw-r--r--Changes18
-rw-r--r--LICENSE377
-rw-r--r--MANIFEST12
-rw-r--r--META.yml23
-rw-r--r--Makefile.PL15
-rw-r--r--README50
-rw-r--r--examples/html-sample.pl76
-rw-r--r--lib/Convert/Color/XTerm.pm199
-rw-r--r--t/00use.t5
-rw-r--r--t/01color.t26
-rw-r--r--t/99pod.t8
12 files changed, 829 insertions, 0 deletions
diff --git a/Build.PL b/Build.PL
new file mode 100644
index 0000000..59029b9
--- /dev/null
+++ b/Build.PL
@@ -0,0 +1,20 @@
+use strict;
+use warnings;
+
+use Module::Build;
+
+my $build = Module::Build->new(
+ module_name => 'Convert::Color::XTerm',
+ requires => {
+ 'Convert::Color' => '0.06',
+ },
+ build_requires => {
+ 'Test::More' => 0,
+ },
+ license => 'perl',
+ create_makefile_pl => 'traditional',
+ create_license => 1,
+ create_readme => 1,
+);
+
+$build->create_build_script;
diff --git a/Changes b/Changes
new file mode 100644
index 0000000..371f545
--- /dev/null
+++ b/Changes
@@ -0,0 +1,18 @@
+Revision history for Convert-Color-XTerm
+
+0.05 CHANGES:
+ * Updated for Convert::Color 0.06 - allows palette search
+
+0.04 CHANGES:
+ * Added HTML example
+ * Various small updates to keep CPANTS happy
+
+0.03 CHANGES:
+ * Remember index of XTerm color, added accessor for it
+
+0.02 BUGFIXES:
+ * Try other locations for the X11 rgb.txt file, to account for
+ various other systems
+
+0.01 First version, released on an unsuspecting world.
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..bed175a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,377 @@
+This software is copyright (c) 2010 by Paul Evans <leonerd@leonerd.org.uk>.
+
+This is free software; you can redistribute it and/or modify it under
+the same terms as the Perl 5 programming language system itself.
+
+Terms of the Perl programming language system itself
+
+a) the GNU General Public License as published by the Free
+ Software Foundation; either version 1, or (at your option) any
+ later version, or
+b) the "Artistic License"
+
+--- The GNU General Public License, Version 1, February 1989 ---
+
+This software is Copyright (c) 2010 by Paul Evans <leonerd@leonerd.org.uk>.
+
+This is free software, licensed under:
+
+ The GNU General Public License, Version 1, February 1989
+
+ GNU GENERAL PUBLIC LICENSE
+ Version 1, February 1989
+
+ Copyright (C) 1989 Free Software Foundation, Inc.
+ 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA
+ Everyone is permitted to copy and distribute verbatim copies
+ of this license document, but changing it is not allowed.
+
+ Preamble
+
+ The license agreements of most software companies try to keep users
+at the mercy of those companies. By contrast, our General Public
+License is intended to guarantee your freedom to share and change free
+software--to make sure the software is free for all its users. The
+General Public License applies to the Free Software Foundation's
+software and to any other program whose authors commit to using it.
+You can use it for your programs, too.
+
+ When we speak of free software, we are referring to freedom, not
+price. Specifically, the General Public License is designed to make
+sure that you have the freedom to give away or sell copies of free
+software, that you receive source code or can get it if you want it,
+that you can change the software or use pieces of it in new free
+programs; and that you know you can do these things.
+
+ To protect your rights, we need to make restrictions that forbid
+anyone to deny you these rights or to ask you to surrender the rights.
+These restrictions translate to certain responsibilities for you if you
+distribute copies of the software, or if you modify it.
+
+ For example, if you distribute copies of a such a program, whether
+gratis or for a fee, you must give the recipients all the rights that
+you have. You must make sure that they, too, receive or can get the
+source code. And you must tell them their rights.
+
+ We protect your rights with two steps: (1) copyright the software, and
+(2) offer you this license which gives you legal permission to copy,
+distribute and/or modify the software.
+
+ Also, for each author's protection and ours, we want to make certain
+that everyone understands that there is no warranty for this free
+software. If the software is modified by someone else and passed on, we
+want its recipients to know that what they have is not the original, so
+that any problems introduced by others will not reflect on the original
+authors' reputations.
+
+ The precise terms and conditions for copying, distribution and
+modification follow.
+
+ GNU GENERAL PUBLIC LICENSE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+ 0. This License Agreement applies to any program or other work which
+contains a notice placed by the copyright holder saying it may be
+distributed under the terms of this General Public License. The
+"Program", below, refers to any such program or work, and a "work based
+on the Program" means either the Program or any work containing the
+Program or a portion of it, either verbatim or with modifications. Each
+licensee is addressed as "you".
+
+ 1. You may copy and distribute verbatim copies of the Program's source
+code as you receive it, in any medium, provided that you conspicuously and
+appropriately publish on each copy an appropriate copyright notice and
+disclaimer of warranty; keep intact all the notices that refer to this
+General Public License and to the absence of any warranty; and give any
+other recipients of the Program a copy of this General Public License
+along with the Program. You may charge a fee for the physical act of
+transferring a copy.
+
+ 2. You may modify your copy or copies of the Program or any portion of
+it, and copy and distribute such modifications under the terms of Paragraph
+1 above, provided that you also do the following:
+
+ a) cause the modified files to carry prominent notices stating that
+ you changed the files and the date of any change; and
+
+ b) cause the whole of any work that you distribute or publish, that
+ in whole or in part contains the Program or any part thereof, either
+ with or without modifications, to be licensed at no charge to all
+ third parties under the terms of this General Public License (except
+ that you may choose to grant warranty protection to some or all
+ third parties, at your option).
+
+ c) If the modified program normally reads commands interactively when
+ run, you must cause it, when started running for such interactive use
+ in the simplest and most usual way, to print or display an
+ announcement including an appropriate copyright notice and a notice
+ that there is no warranty (or else, saying that you provide a
+ warranty) and that users may redistribute the program under these
+ conditions, and telling the user how to view a copy of this General
+ Public License.
+
+ d) You may charge a fee for the physical act of transferring a
+ copy, and you may at your option offer warranty protection in
+ exchange for a fee.
+
+Mere aggregation of another independent work with the Program (or its
+derivative) on a volume of a storage or distribution medium does not bring
+the other work under the scope of these terms.
+
+ 3. You may copy and distribute the Program (or a portion or derivative of
+it, under Paragraph 2) in object code or executable form under the terms of
+Paragraphs 1 and 2 above provided that you also do one of the following:
+
+ a) accompany it with the complete corresponding machine-readable
+ source code, which must be distributed under the terms of
+ Paragraphs 1 and 2 above; or,
+
+ b) accompany it with a written offer, valid for at least three
+ years, to give any third party free (except for a nominal charge
+ for the cost of distribution) a complete machine-readable copy of the
+ corresponding source code, to be distributed under the terms of
+ Paragraphs 1 and 2 above; or,
+
+ c) accompany it with the information you received as to where the
+ corresponding source code may be obtained. (This alternative is
+ allowed only for noncommercial distribution and only if you
+ received the program in object code or executable form alone.)
+
+Source code for a work means the preferred form of the work for making
+modifications to it. For an executable file, complete source code means
+all the source code for all modules it contains; but, as a special
+exception, it need not include source code for modules which are standard
+libraries that accompany the operating system on which the executable
+file runs, or for standard header files or definitions files that
+accompany that operating system.
+
+ 4. You may not copy, modify, sublicense, distribute or transfer the
+Program except as expressly provided under this General Public License.
+Any attempt otherwise to copy, modify, sublicense, distribute or transfer
+the Program is void, and will automatically terminate your rights to use
+the Program under this License. However, parties who have received
+copies, or rights to use copies, from you under this General Public
+License will not have their licenses terminated so long as such parties
+remain in full compliance.
+
+ 5. By copying, distributing or modifying the Program (or any work based
+on the Program) you indicate your acceptance of this license to do so,
+and all its terms and conditions.
+
+ 6. Each time you redistribute the Program (or any work based on the
+Program), the recipient automatically receives a license from the original
+licensor to copy, distribute or modify the Program subject to these
+terms and conditions. You may not impose any further restrictions on the
+recipients' exercise of the rights granted herein.
+
+ 7. The Free Software Foundation may publish revised and/or new versions
+of the General Public License from time to time. Such new versions will
+be similar in spirit to the present version, but may differ in detail to
+address new problems or concerns.
+
+Each version is given a distinguishing version number. If the Program
+specifies a version number of the license which applies to it and "any
+later version", you have the option of following the terms and conditions
+either of that version or of any later version published by the Free
+Software Foundation. If the Program does not specify a version number of
+the license, you may choose any version ever published by the Free Software
+Foundation.
+
+ 8. If you wish to incorporate parts of the Program into other free
+programs whose distribution conditions are different, write to the author
+to ask for permission. For software which is copyrighted by the Free
+Software Foundation, write to the Free Software Foundation; we sometimes
+make exceptions for this. Our decision will be guided by the two goals
+of preserving the free status of all derivatives of our free software and
+of promoting the sharing and reuse of software generally.
+
+ NO WARRANTY
+
+ 9. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
+FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
+OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
+PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
+OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
+TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
+PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
+REPAIR OR CORRECTION.
+
+ 10. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
+WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR
+REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
+INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING
+OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED
+TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
+YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER
+PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGES.
+
+ END OF TERMS AND CONDITIONS
+
+ Appendix: How to Apply These Terms to Your New Programs
+
+ If you develop a new program, and you want it to be of the greatest
+possible use to humanity, the best way to achieve this is to make it
+free software which everyone can redistribute and change under these
+terms.
+
+ To do so, attach the following notices to the program. It is safest to
+attach them to the start of each source file to most effectively convey
+the exclusion of warranty; and each file should have at least the
+"copyright" line and a pointer to where the full notice is found.
+
+ <one line to give the program's name and a brief idea of what it does.>
+ Copyright (C) 19yy <name of author>
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 1, or (at your option)
+ any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+
+Also add information on how to contact you by electronic and paper mail.
+
+If the program is interactive, make it output a short notice like this
+when it starts in an interactive mode:
+
+ Gnomovision version 69, Copyright (C) 19xx name of author
+ Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
+ This is free software, and you are welcome to redistribute it
+ under certain conditions; type `show c' for details.
+
+The hypothetical commands `show w' and `show c' should show the
+appropriate parts of the General Public License. Of course, the
+commands you use may be called something other than `show w' and `show
+c'; they could even be mouse-clicks or menu items--whatever suits your
+program.
+
+You should also get your employer (if you work as a programmer) or your
+school, if any, to sign a "copyright disclaimer" for the program, if
+necessary. Here a sample; alter the names:
+
+ Yoyodyne, Inc., hereby disclaims all copyright interest in the
+ program `Gnomovision' (a program to direct compilers to make passes
+ at assemblers) written by James Hacker.
+
+ <signature of Ty Coon>, 1 April 1989
+ Ty Coon, President of Vice
+
+That's all there is to it!
+
+
+--- The Artistic License 1.0 ---
+
+This software is Copyright (c) 2010 by Paul Evans <leonerd@leonerd.org.uk>.
+
+This is free software, licensed under:
+
+ The Artistic License 1.0
+
+The Artistic License
+
+Preamble
+
+The intent of this document is to state the conditions under which a Package
+may be copied, such that the Copyright Holder maintains some semblance of
+artistic control over the development of the package, while giving the users of
+the package the right to use and distribute the Package in a more-or-less
+customary fashion, plus the right to make reasonable modifications.
+
+Definitions:
+
+ - "Package" refers to the collection of files distributed by the Copyright
+ Holder, and derivatives of that collection of files created through
+ textual modification.
+ - "Standard Version" refers to such a Package if it has not been modified,
+ or has been modified in accordance with the wishes of the Copyright
+ Holder.
+ - "Copyright Holder" is whoever is named in the copyright or copyrights for
+ the package.
+ - "You" is you, if you're thinking about copying or distributing this Package.
+ - "Reasonable copying fee" is whatever you can justify on the basis of media
+ cost, duplication charges, time of people involved, and so on. (You will
+ not be required to justify it to the Copyright Holder, but only to the
+ computing community at large as a market that must bear the fee.)
+ - "Freely Available" means that no fee is charged for the item itself, though
+ there may be fees involved in handling the item. It also means that
+ recipients of the item may redistribute it under the same conditions they
+ received it.
+
+1. You may make and give away verbatim copies of the source form of the
+Standard Version of this Package without restriction, provided that you
+duplicate all of the original copyright notices and associated disclaimers.
+
+2. You may apply bug fixes, portability fixes and other modifications derived
+from the Public Domain or from the Copyright Holder. A Package modified in such
+a way shall still be considered the Standard Version.
+
+3. You may otherwise modify your copy of this Package in any way, provided that
+you insert a prominent notice in each changed file stating how and when you
+changed that file, and provided that you do at least ONE of the following:
+
+ a) place your modifications in the Public Domain or otherwise make them
+ Freely Available, such as by posting said modifications to Usenet or an
+ equivalent medium, or placing the modifications on a major archive site
+ such as ftp.uu.net, or by allowing the Copyright Holder to include your
+ modifications in the Standard Version of the Package.
+
+ b) use the modified Package only within your corporation or organization.
+
+ c) rename any non-standard executables so the names do not conflict with
+ standard executables, which must also be provided, and provide a separate
+ manual page for each non-standard executable that clearly documents how it
+ differs from the Standard Version.
+
+ d) make other distribution arrangements with the Copyright Holder.
+
+4. You may distribute the programs of this Package in object code or executable
+form, provided that you do at least ONE of the following:
+
+ a) distribute a Standard Version of the executables and library files,
+ together with instructions (in the manual page or equivalent) on where to
+ get the Standard Version.
+
+ b) accompany the distribution with the machine-readable source of the Package
+ with your modifications.
+
+ c) accompany any non-standard executables with their corresponding Standard
+ Version executables, giving the non-standard executables non-standard
+ names, and clearly documenting the differences in manual pages (or
+ equivalent), together with instructions on where to get the Standard
+ Version.
+
+ d) make other distribution arrangements with the Copyright Holder.
+
+5. You may charge a reasonable copying fee for any distribution of this
+Package. You may charge any fee you choose for support of this Package. You
+may not charge a fee for this Package itself. However, you may distribute this
+Package in aggregate with other (possibly commercial) programs as part of a
+larger (possibly commercial) software distribution provided that you do not
+advertise this Package as a product of your own.
+
+6. The scripts and library files supplied as input to or produced as output
+from the programs of this Package do not automatically fall under the copyright
+of this Package, but belong to whomever generated them, and may be sold
+commercially, and may be aggregated with this Package.
+
+7. C or perl subroutines supplied by you and linked into this Package shall not
+be considered part of this Package.
+
+8. The name of the Copyright Holder may not be used to endorse or promote
+products derived from this software without specific prior written permission.
+
+9. THIS PACKAGE IS PROVIDED "AS IS" AND WITHOUT ANY EXPRESS OR IMPLIED
+WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF
+MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE.
+
+The End
+
diff --git a/MANIFEST b/MANIFEST
new file mode 100644
index 0000000..552ca88
--- /dev/null
+++ b/MANIFEST
@@ -0,0 +1,12 @@
+Build.PL
+Changes
+examples/html-sample.pl
+lib/Convert/Color/XTerm.pm
+LICENSE
+Makefile.PL
+MANIFEST This list of files
+META.yml
+README
+t/00use.t
+t/01color.t
+t/99pod.t
diff --git a/META.yml b/META.yml
new file mode 100644
index 0000000..e01779d
--- /dev/null
+++ b/META.yml
@@ -0,0 +1,23 @@
+---
+abstract: 'indexed colors used by XTerm'
+author:
+ - 'Paul Evans <leonerd@leonerd.org.uk>'
+build_requires:
+ Test::More: 0
+configure_requires:
+ Module::Build: 0.36
+generated_by: 'Module::Build version 0.3607'
+license: perl
+meta-spec:
+ url: http://module-build.sourceforge.net/META-spec-v1.4.html
+ version: 1.4
+name: Convert-Color-XTerm
+provides:
+ Convert::Color::XTerm:
+ file: lib/Convert/Color/XTerm.pm
+ version: 0.05
+requires:
+ Convert::Color: 0.06
+resources:
+ license: http://dev.perl.org/licenses/
+version: 0.05
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..5cebd55
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,15 @@
+# Note: this file was auto-generated by Module::Build::Compat version 0.3607
+use ExtUtils::MakeMaker;
+WriteMakefile
+(
+ 'NAME' => 'Convert::Color::XTerm',
+ 'VERSION_FROM' => 'lib/Convert/Color/XTerm.pm',
+ 'PREREQ_PM' => {
+ 'Convert::Color' => '0.06',
+ 'Test::More' => 0
+ },
+ 'INSTALLDIRS' => 'site',
+ 'EXE_FILES' => [],
+ 'PL_FILES' => {}
+ )
+;
diff --git a/README b/README
new file mode 100644
index 0000000..f027e41
--- /dev/null
+++ b/README
@@ -0,0 +1,50 @@
+NAME
+ "Convert::Color::XTerm" - indexed colors used by XTerm
+
+SYNOPSIS
+ Directly:
+
+ use Convert::Color::XTerm;
+
+ my $red = Convert::Color::XTerm->new( 1 );
+
+ Via Convert::Color:
+
+ use Convert::Color;
+
+ my $cyan = Convert::Color->new( 'xterm:14' );
+
+DESCRIPTION
+ This subclass of Convert::Color::RGB8 provides lookup of the colors that
+ xterm uses by default. Note that the module is not intelligent enough to
+ actually parse the XTerm configuration on a machine, nor to query a
+ running terminal for its actual colors. It simply implements the colors
+ that are present as defaults in the XTerm source code.
+
+ It implements the complete 256-color model in XTerm. This range consists
+ of:
+
+ * 0-7: The basic VGA colors, dark intensity. 7 is a "dark" white, i.e.
+ a light grey.
+
+ * 8-15: The basic VGA colors, light intensity. 8 represents a "light"
+ black, i.e. a dark grey.
+
+ * 16-231: A 6x6x6 RGB color cube.
+
+ * 232-255: 24 greyscale ramp.
+
+CONSTRUCTOR
+ $color = Convert::Color::XTerm->new( $index )
+ Returns a new object to represent the color at that index.
+
+METHODS
+ $index = $color->index
+ The index of the XTerm color.
+
+SEE ALSO
+ * Convert::Color - color space conversions
+
+AUTHOR
+ Paul Evans <leonerd@leonerd.org.uk>
+
diff --git a/examples/html-sample.pl b/examples/html-sample.pl
new file mode 100644
index 0000000..0ed90d7
--- /dev/null
+++ b/examples/html-sample.pl
@@ -0,0 +1,76 @@
+#!/usr/bin/perl
+
+use strict;
+
+use Convert::Color;
+use Getopt::Long;
+
+print <<EOF;
+<html>
+ <body>
+ <table border=1>
+ <tr><th colspan=2>Name</th><th>RGB</th><th>XTerm</th></tr>
+EOF
+
+my @COL;
+
+sub span
+{
+ my ( $text, $col ) = @_;
+
+ my $hex = $col->as_rgb8->hex;
+
+ if( $col->as_hsl->lightness < 0.5 ) {
+ return qq{<span style="background-color: #$hex; color: white">$text</span>};
+ }
+ else {
+ return qq{<span style="background-color: #$hex">$text</span>};
+ }
+}
+
+my $SORT = 0;
+
+GetOptions(
+ 's|sort+' => \$SORT,
+) or exit(1);
+
+my @XTerm = map { Convert::Color->new( "xterm:$_" ) } 0 .. 255;
+
+while( my $colname = shift @ARGV ) {
+ if( $colname eq "x11:*" ) {
+ require Convert::Color::X11;
+ unshift @ARGV, map { "x11:$_" } sort Convert::Color::X11->colors;
+ next;
+ }
+
+ my $col = Convert::Color->new( $colname );
+
+ my $c_rgb8 = $col->as_rgb8;
+ my $rgb8_hex = $c_rgb8->hex;
+
+ my ( $r, $g, $b ) = $c_rgb8->rgb8;
+ my $rgb = join ",",
+ span( sprintf('%03d',$r), Convert::Color::RGB8->new( $r, 0, 0 ) ),
+ span( sprintf('%03d',$g), Convert::Color::RGB8->new( 0, $g, 0 ) ),
+ span( sprintf('%03d',$b), Convert::Color::RGB8->new( 0, 0, $b ) );
+
+ my $best_xterm = $c_rgb8->as_xterm;
+ my $xterm = span( $best_xterm->index, $best_xterm );
+
+ push @COL, [ $best_xterm->index, <<"EOF" ];
+ <tr><td>$colname</td><td bgcolor="#$rgb8_hex">&nbsp;&nbsp;&nbsp;</td><td>$rgb</td><td>$xterm</td></tr>
+EOF
+
+}
+
+if( $SORT ) {
+ @COL = sort { $a->[0] <=> $b->[0] } @COL;
+}
+
+print map { $_->[1] } @COL;
+
+print <<EOF;
+ </table>
+ </body>
+</html>
+EOF
diff --git a/lib/Convert/Color/XTerm.pm b/lib/Convert/Color/XTerm.pm
new file mode 100644
index 0000000..9ab0b10
--- /dev/null
+++ b/lib/Convert/Color/XTerm.pm
@@ -0,0 +1,199 @@
+# You may distribute under the terms of either the GNU General Public License
+# or the Artistic License (the same terms as Perl itself)
+#
+# (C) Paul Evans, 2009,2010 -- leonerd@leonerd.org.uk
+
+package Convert::Color::XTerm;
+
+use strict;
+use warnings;
+use base qw( Convert::Color::RGB8 );
+
+__PACKAGE__->register_color_space( 'xterm' );
+
+use Carp;
+
+our $VERSION = '0.05';
+
+=head1 NAME
+
+C<Convert::Color::XTerm> - indexed colors used by XTerm
+
+=head1 SYNOPSIS
+
+Directly:
+
+ use Convert::Color::XTerm;
+
+ my $red = Convert::Color::XTerm->new( 1 );
+
+Via L<Convert::Color>:
+
+ use Convert::Color;
+
+ my $cyan = Convert::Color->new( 'xterm:14' );
+
+=head1 DESCRIPTION
+
+This subclass of L<Convert::Color::RGB8> provides lookup of the colors that
+F<xterm> uses by default. Note that the module is not intelligent enough to
+actually parse the XTerm configuration on a machine, nor to query a running
+terminal for its actual colors. It simply implements the colors that are
+present as defaults in the XTerm source code.
+
+It implements the complete 256-color model in XTerm. This range consists of:
+
+=over 4
+
+=item *
+
+0-7: The basic VGA colors, dark intensity. 7 is a "dark" white, i.e. a light
+grey.
+
+=item *
+
+8-15: The basic VGA colors, light intensity. 8 represents a "light" black,
+i.e. a dark grey.
+
+=item *
+
+16-231: A 6x6x6 RGB color cube.
+
+=item *
+
+232-255: 24 greyscale ramp.
+
+=back
+
+=cut
+
+my @color;
+
+sub _init_colors
+{
+ # The first 16 colors are dark and light versions of the basic 8 VGA colors.
+ # XTerm itself pulls these from the X11 database, except for light blue.
+ # These color names from xterm's charproc.c
+
+ my @colnames;
+
+ if( eval { require Convert::Color::X11; Convert::Color::X11->colors } ) {
+ @colnames = (qw(
+ x11:black x11:red3 x11:green3 x11:yellow3
+ x11:blue2 x11:magenta3 x11:cyan3 x11:gray90
+ x11:gray50 x11:red x11:green x11:yellow
+ rgb8:5C5CFF x11:magenta x11:cyan x11:white
+ ));
+ }
+ else {
+ @colnames = (qw(
+ rgb8:000000 rgb8:cd0000 rgb8:00cd00 rgb8:cdcd00
+ rgb8:0000ee rgb8:cd00cd rgb8:00cdcd rgb8:e5e5e5
+ rgb8:7f7f7f rgb8:ff0000 rgb8:00ff00 rgb8:ffff00
+ rgb8:5c5cff rgb8:ff00ff rgb8:00ffff rgb8:ffffff
+ ));
+ }
+
+ foreach my $index ( 0 .. $#colnames )
+ {
+ my $c_tmp = Convert::Color->new( $colnames[$index] );
+ $color[$index] = __PACKAGE__->SUPER::new( $c_tmp->as_rgb8->rgb8 );
+ $color[$index]->[3] = $index;
+ }
+
+ # These descriptions and formulae from xterm's 256colres.pl
+
+ # Next is a 6x6x6 color cube, with an attempt at a gamma correction
+ foreach my $red ( 0 .. 5 ) {
+ foreach my $green ( 0 .. 5 ) {
+ foreach my $blue ( 0 .. 5 ) {
+ my $index = 16 + ($red*36) + ($green*6) + $blue;
+
+ $color[$index] = __PACKAGE__->SUPER::new(
+ map { $_ ? $_*40 + 55 : 0 } ( $red, $green, $blue )
+ );
+ $color[$index]->[3] = $index;
+ }
+ }
+ }
+
+ # Finally a 24-level greyscale ramp
+ foreach my $grey ( 0 .. 23 ) {
+ my $index = 232 + $grey;
+ my $whiteness = $grey*10 + 8;
+
+ $color[$index] = __PACKAGE__->SUPER::new( $whiteness, $whiteness, $whiteness );
+ $color[$index]->[3] = $index;
+ }
+}
+
+__PACKAGE__->register_palette(
+ enumerate_once => sub {
+ @color or _init_colors;
+ @color
+ },
+);
+
+=head1 CONSTRUCTOR
+
+=cut
+
+=head2 $color = Convert::Color::XTerm->new( $index )
+
+Returns a new object to represent the color at that index.
+
+=cut
+
+sub new
+{
+ my $class = shift;
+
+ if( @_ == 1 ) {
+ my $index = $_[0];
+
+ @color or _init_colors;
+
+ $index >= 0 and $index < 256 or
+ croak "No such XTerm color at index '$index'";
+
+ return $color[$index];
+ }
+ else {
+ croak "usage: Convert::Color::XTerm->new( INDEX )";
+ }
+}
+
+=head1 METHODS
+
+=cut
+
+=head2 $index = $color->index
+
+The index of the XTerm color.
+
+=cut
+
+sub index
+{
+ my $self = shift;
+ return $self->[3];
+}
+
+# Keep perl happy; keep Britain tidy
+1;
+
+__END__
+
+=head1 SEE ALSO
+
+=over 4
+
+=item *
+
+L<Convert::Color> - color space conversions
+
+=back
+
+=head1 AUTHOR
+
+Paul Evans <leonerd@leonerd.org.uk>
diff --git a/t/00use.t b/t/00use.t
new file mode 100644
index 0000000..342c592
--- /dev/null
+++ b/t/00use.t
@@ -0,0 +1,5 @@
+#!/usr/bin/perl
+
+use Test::More tests => 1;
+
+use_ok( 'Convert::Color::XTerm' );
diff --git a/t/01color.t b/t/01color.t
new file mode 100644
index 0000000..0c471cd
--- /dev/null
+++ b/t/01color.t
@@ -0,0 +1,26 @@
+#!/usr/bin/perl
+
+use Convert::Color::XTerm;
+use Convert::Color::RGB;
+
+use Test::More tests => 9;
+
+my $black = Convert::Color::XTerm->new( 0 );
+
+is( $black->red, 0, 'black red' );
+is( $black->green, 0, 'black green' );
+is( $black->blue, 0, 'black blue' );
+
+is( $black->index, 0, 'black index' );
+
+my $green = Convert::Color::XTerm->new( 2 );
+
+is( $green->red, 0, 'green red' );
+is( $green->green, 205, 'green green' );
+is( $green->blue, 0, 'green blue' );
+
+is( $green->index, 2, 'green index' );
+
+my $white = Convert::Color::RGB->new( 1.0, 1.0, 1.0 )->as_xterm;
+
+is( $white->index, 15, 'white index' );
diff --git a/t/99pod.t b/t/99pod.t
new file mode 100644
index 0000000..339b17d
--- /dev/null
+++ b/t/99pod.t
@@ -0,0 +1,8 @@
+#!/usr/bin/perl -w
+
+use Test::More;
+
+eval "use Test::Pod 1.00";
+plan skip_all => "Test::Pod 1.00 required for testing POD" if $@;
+
+all_pod_files_ok();