summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Miko <karel.miko@gmail.com>2022-01-07 21:47:48 +0100
committerKarel Miko <karel.miko@gmail.com>2022-01-07 21:47:48 +0100
commit2dd0bffc6644436990c3f3246d6a2704b437bf1d (patch)
treea3ffd6cdcd3a1d9b655e435f32c147775cd3c3fe
parentaa945769970a514412138c363d4d3d336a04e183 (diff)
do not use --exclude-libs hack on solaris
-rw-r--r--Makefile.PL4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 47365dbc..35d78720 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -64,8 +64,10 @@ else {
);
#FIX: https://github.com/DCIT/perl-CryptX/pull/79
+ # not needed on MS Windows
# does not work on macos - Apple LLVM 12.0.5 (clang-1205.0.22.9) ld: unknown option: --exclude-libs
- if ($^O ne 'MSWin32' && $^O ne 'darwin' && ($Config{ld} =~ /gcc|g\+\+/ || $Config{gccversion})) {
+ # does not work on solaris - gcc 9.3.0 - ld: fatal: unrecognized option '--exclude-libs'
+ if ($^O !~ /^(MSWin32|darwin|solaris)$/ && ($Config{ld} =~ /gcc|g\+\+/ || $Config{gccversion})) {
push @EUMM_INC_LIB, (LDDLFLAGS => "$Config{lddlflags} -Wl,--exclude-libs,ALL");
}
}