summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorKarel Miko <karel.miko@gmail.com>2017-11-23 10:41:59 +0100
committerKarel Miko <karel.miko@gmail.com>2017-11-23 10:41:59 +0100
commit6661048f45cea58d5d3b0b9396d6b1094979f4fc (patch)
tree9ffe8aa7c515aa2f8f4e6f832b72c6cef3c29b26 /Makefile.PL
parenta6949d16891883090207ba373f2533f90d4ba813 (diff)
tuning openssl tests
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 0fe8e376..17103b58 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -100,8 +100,12 @@ versiondecdev:
$(NOECHO) perl _generators/version_patch.pl decdev
gencode:
$(NOECHO) perl _generators/gen.pl gencode
-gentest:
+gentest: all
$(NOECHO) perl _generators/gen.pl gentest
+openssltest: all
+ $(NOECHO) perl -Mblib t/openssl/dsa-test.pl
+ $(NOECHO) perl -Mblib t/openssl/ecc-test.pl
+ $(NOECHO) perl -Mblib t/openssl/rsa-test.pl
};
return "$myextlib\n$version_patch";