summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamyan Ivanov <dmn@debian.org>2017-12-01 21:32:33 +0000
committerDamyan Ivanov <dmn@debian.org>2017-12-01 21:32:33 +0000
commitcc2c4a8849635126a5d9a98d8908d5fc6ed10c73 (patch)
treedfd5480984916dca73dfc11983133ef118404247
parentbb4abef8a27aa65ac82c4f719fbb6a120fbfbf72 (diff)
add 000-check-dependencies.t
information could be useful when reading cpantesters reports
-rw-r--r--Makefile.PL3
-rw-r--r--t/000-check-dependencies.t8
2 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index af8cbda..eeff930 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -242,6 +242,9 @@ qq(*.xsi *.old t/*.old *~ t/*~ trace.txt t/trace.txt lib/DBD/Firebird/*~ lib/DBD
'Test::More' => 0.4,
'Time::HiRes' => 0,
},
+ TEST_REQUIRES => {
+ 'Test::CheckDeps' => 0.007,
+ },
LICENSE => 'perl',
MIN_PERL_VERSION => '5.008001',
META_MERGE => {
diff --git a/t/000-check-dependencies.t b/t/000-check-dependencies.t
new file mode 100644
index 0000000..dfb1d78
--- /dev/null
+++ b/t/000-check-dependencies.t
@@ -0,0 +1,8 @@
+use Test::More 0.94;
+eval { use Test::CheckDeps 0.007 }
+ or plan skip_all => "Test::CheckDeps 0.007 required";
+
+check_dependencies();
+
+done_testing();
+