summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-07-07 09:06:23 +0100
committerColin Watson <cjwatson@debian.org>2018-07-07 09:07:06 +0100
commit1911d7403ab68c79d3806bd8dfde4bce992c1491 (patch)
tree95b067dbcc72bf686ce25f5aaa70ee4ed1e766e5
parentccd362b953c8e09cf54b415e436cd51de88daca2 (diff)
parent4559deefdfc34d0b031e1bd0342dcc8f48d7d64b (diff)
New upstream release (1.1010)
-rw-r--r--CHANGES6
-rw-r--r--Makefile.PL26
-rw-r--r--debian/.git-dpm14
-rw-r--r--debian/changelog6
-rw-r--r--lib/Getargs/Long.pm2
5 files changed, 46 insertions, 8 deletions
diff --git a/CHANGES b/CHANGES
index 2a8807f..454fef4 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,9 @@
+Version 1.1010:
+- Trying once again to fix the compile test on windows
+
+Version 1.1009:
+- Check in standard tests, including one that skips the compile check on Windows
+
Version 1.1008:
- Prevent CPAN from indexing private-lib
- Add standard tests
diff --git a/Makefile.PL b/Makefile.PL
index a03c1df..91572c8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -35,6 +35,32 @@ no_index 'directory' => 'private-lib';
enable_verbose_cpan_testing();
+# ---- Workaround for broken module ----
+# https://rt.cpan.org/Ticket/Display.html?id=125772
+{
+ package Module::Install::StandardTests;
+
+ sub write_standard_test_compile {
+ my $self = shift;
+ $self->write_test_file('000_standard__compile.t', q/
+ BEGIN {
+ if ($^O eq 'MSWin32') {
+ require Test::More;
+ Test::More->import(skip_all =>
+ "Test::Compile doesn't work properly on Windows");
+ } else {
+ require Test::More;
+ Test::More->import();
+ eval "use Test::Compile";
+ Test::More->builder->BAIL_OUT(
+ "Test::Compile required for testing compilation") if $@;
+ all_pm_files_ok();
+ }
+ }
+ /);
+ }
+}
+
use_standard_tests;
WriteAll();
diff --git a/debian/.git-dpm b/debian/.git-dpm
index c64d9ce..a6d9d6f 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,8 +1,8 @@
# see git-dpm(1) from git-dpm package
-e649fdd7c58e61fe8f515bd61575119ac51ee53d
-e649fdd7c58e61fe8f515bd61575119ac51ee53d
-e649fdd7c58e61fe8f515bd61575119ac51ee53d
-e649fdd7c58e61fe8f515bd61575119ac51ee53d
-libgetargs-long-perl_1.1008.orig.tar.gz
-4ab789ce6b38ef20b27d3f603f71e4afd69a3822
-42686
+4559deefdfc34d0b031e1bd0342dcc8f48d7d64b
+4559deefdfc34d0b031e1bd0342dcc8f48d7d64b
+4559deefdfc34d0b031e1bd0342dcc8f48d7d64b
+4559deefdfc34d0b031e1bd0342dcc8f48d7d64b
+libgetargs-long-perl_1.1010.orig.tar.gz
+48922634d91e464b28889d4147cb60ae19f4176b
+42993
diff --git a/debian/changelog b/debian/changelog
index c8c3081..f3589b6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+libgetargs-long-perl (1.1010-1) UNRELEASED; urgency=medium
+
+ * New upstream release.
+
+ -- Colin Watson <cjwatson@debian.org> Sat, 07 Jul 2018 09:06:29 +0100
+
libgetargs-long-perl (1.1008-1) unstable; urgency=medium
* New upstream release.
diff --git a/lib/Getargs/Long.pm b/lib/Getargs/Long.pm
index 65fb74f..48b55cb 100644
--- a/lib/Getargs/Long.pm
+++ b/lib/Getargs/Long.pm
@@ -6,7 +6,7 @@ use 5.005;
package Getargs::Long;
use vars qw($VERSION @ISA @EXPORT);
-$VERSION = sprintf "%d.%02d%02d", q/1.10.8/ =~ /(\d+)/g;
+$VERSION = sprintf "%d.%02d%02d", q/1.10.10/ =~ /(\d+)/g;
BEGIN
{