summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominic Hargreaves <dom@earth.li>2021-02-10 22:50:05 +0100
committerDominic Hargreaves <dom@earth.li>2021-02-10 22:50:05 +0100
commit0c46a532abaf8bd1c2ea93bf43c4bb3c190b69a8 (patch)
treec8307236667b22fc45d5f4d98820f78d6aaf232e
parent54cd3dd37271b3e5b35ffb70ce024f7a92c73094 (diff)
parent6718536aa2022ec18167149cccf4a080572d65ab (diff)
Record libgnupg-interface-perl (1.01-2) in archive suite sid
-rw-r--r--.gitignore1
-rw-r--r--debian/changelog7
-rw-r--r--debian/control3
-rw-r--r--debian/patches/auto-gitignore15
-rw-r--r--debian/patches/hardcode-path31
-rw-r--r--debian/patches/series2
-rw-r--r--lib/GnuPG/Interface.pm7
7 files changed, 44 insertions, 22 deletions
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 845ca06..0000000
--- a/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-.pc
diff --git a/debian/changelog b/debian/changelog
index b66dadf..d144493 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libgnupg-interface-perl (1.01-2) unstable; urgency=high
+
+ * Explicitly specify path to gpg to avoid taint mode problems
+ (Closes: #981647)
+
+ -- Dominic Hargreaves <dom@earth.li> Wed, 10 Feb 2021 21:50:05 +0000
+
libgnupg-interface-perl (1.01-1) unstable; urgency=medium
* Team upload.
diff --git a/debian/control b/debian/control
index 0987bd8..3b30263 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,8 @@ Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Uploaders: Damyan Ivanov <dmn@debian.org>,
intrigeri <intrigeri@debian.org>,
Salvatore Bonaccorso <carnil@debian.org>,
- Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+ Daniel Kahn Gillmor <dkg@fifthhorseman.net>,
+ Dominic Hargreaves <dom@earth.li>,
Section: perl
Testsuite: autopkgtest-pkg-perl
Priority: optional
diff --git a/debian/patches/auto-gitignore b/debian/patches/auto-gitignore
deleted file mode 100644
index 2ce6a16..0000000
--- a/debian/patches/auto-gitignore
+++ /dev/null
@@ -1,15 +0,0 @@
-Subject: Update .gitignore from Debian packaging branch
-
-The Debian packaging git branch contains these updates to the upstream
-.gitignore file(s). This patch is autogenerated, to provide these
-updates to users of the official Debian archive view of the package.
-
-[dgit (9.12) update-gitignore]
----
-diff --git a/.gitignore b/.gitignore
-new file mode 100644
-index 0000000..845ca06
---- /dev/null
-+++ b/.gitignore
-@@ -0,0 +1 @@
-+.pc
diff --git a/debian/patches/hardcode-path b/debian/patches/hardcode-path
new file mode 100644
index 0000000..1c6d8bc
--- /dev/null
+++ b/debian/patches/hardcode-path
@@ -0,0 +1,31 @@
+Description: Hardcode path to /usr/bin/gpg
+Author: Dominic Hargreaves
+Last-Update: 2021-02-10
+Forwarded: Not-Needed
+Bug-Debian: https://bugs.debian.org/981647
+
+diff --git a/lib/GnuPG/Interface.pm b/lib/GnuPG/Interface.pm
+index 13b313e..84312e2 100644
+--- a/lib/GnuPG/Interface.pm
++++ b/lib/GnuPG/Interface.pm
+@@ -76,7 +76,7 @@ sub gnupg_call { shift->call(@_); }
+
+ sub BUILD {
+ my ( $self, $args ) = @_;
+- $self->hash_init( call => 'gpg', %$args );
++ $self->hash_init( call => '/usr/bin/gpg', %$args );
+ }
+
+ struct(
+@@ -1190,9 +1190,8 @@ keys to list in a key-listing.
+
+ =item call
+
+-This defines the call made to invoke GnuPG. Defaults to 'gpg'; this
+-should be changed if 'gpg' is not in your path, or there is a different
+-name for the binary on your system.
++This defines the call made to invoke GnuPG. Defaults to '/usr/bin/gpg'; this
++should be changed if there is a different name for the binary on your system.
+
+ =item passphrase
+
diff --git a/debian/patches/series b/debian/patches/series
index 5138037..19ecc7a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,4 +3,4 @@ test-gnupg1
test-allow-interface-to-fail
test-dummy-binaries
detect-taint-mode
-auto-gitignore
+hardcode-path
diff --git a/lib/GnuPG/Interface.pm b/lib/GnuPG/Interface.pm
index 13b313e..84312e2 100644
--- a/lib/GnuPG/Interface.pm
+++ b/lib/GnuPG/Interface.pm
@@ -76,7 +76,7 @@ sub gnupg_call { shift->call(@_); }
sub BUILD {
my ( $self, $args ) = @_;
- $self->hash_init( call => 'gpg', %$args );
+ $self->hash_init( call => '/usr/bin/gpg', %$args );
}
struct(
@@ -1190,9 +1190,8 @@ keys to list in a key-listing.
=item call
-This defines the call made to invoke GnuPG. Defaults to 'gpg'; this
-should be changed if 'gpg' is not in your path, or there is a different
-name for the binary on your system.
+This defines the call made to invoke GnuPG. Defaults to '/usr/bin/gpg'; this
+should be changed if there is a different name for the binary on your system.
=item passphrase