summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control3
-rw-r--r--debian/patches/hardcode-path29
-rw-r--r--debian/patches/series1
4 files changed, 39 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b66dadf..9469820 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libgnupg-interface-perl (1.01-2) UNRELEASED; urgency=medium
+
+ * Explicitly specify path to gpg to avoid taint mode problems
+ (Closes: #981647)
+
+ -- Dominic Hargreaves <dom@earth.li> Sun, 07 Feb 2021 19:33:56 +0000
+
libgnupg-interface-perl (1.01-1) unstable; urgency=medium
* Team upload.
diff --git a/debian/control b/debian/control
index 0987bd8..3b30263 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,8 @@ Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Uploaders: Damyan Ivanov <dmn@debian.org>,
intrigeri <intrigeri@debian.org>,
Salvatore Bonaccorso <carnil@debian.org>,
- Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+ Daniel Kahn Gillmor <dkg@fifthhorseman.net>,
+ Dominic Hargreaves <dom@earth.li>,
Section: perl
Testsuite: autopkgtest-pkg-perl
Priority: optional
diff --git a/debian/patches/hardcode-path b/debian/patches/hardcode-path
new file mode 100644
index 0000000..8f046ae
--- /dev/null
+++ b/debian/patches/hardcode-path
@@ -0,0 +1,29 @@
+Description: Test that Taint mode works
+Author: Dominic Hargreaves
+Last-Update: 2021-02-07
+
+diff --git a/lib/GnuPG/Interface.pm b/lib/GnuPG/Interface.pm
+index 13b313e..84312e2 100644
+--- a/lib/GnuPG/Interface.pm
++++ b/lib/GnuPG/Interface.pm
+@@ -76,7 +76,7 @@ sub gnupg_call { shift->call(@_); }
+
+ sub BUILD {
+ my ( $self, $args ) = @_;
+- $self->hash_init( call => 'gpg', %$args );
++ $self->hash_init( call => '/usr/bin/gpg', %$args );
+ }
+
+ struct(
+@@ -1190,9 +1190,8 @@ keys to list in a key-listing.
+
+ =item call
+
+-This defines the call made to invoke GnuPG. Defaults to 'gpg'; this
+-should be changed if 'gpg' is not in your path, or there is a different
+-name for the binary on your system.
++This defines the call made to invoke GnuPG. Defaults to '/usr/bin/gpg'; this
++should be changed if there is a different name for the binary on your system.
+
+ =item passphrase
+
diff --git a/debian/patches/series b/debian/patches/series
index c6ec5e7..19ecc7a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@ test-gnupg1
test-allow-interface-to-fail
test-dummy-binaries
detect-taint-mode
+hardcode-path