summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2019-01-08 18:27:08 +0100
committerAndrej Shadura <andrewsh@debian.org>2019-01-08 18:41:01 +0100
commit0a8a93b9a06da7477cc764176ffd6115d1d9ccbe (patch)
tree3c6ab4eec8dc68708010e72a05a84c0f110c3acc /debian/rules
parent45e9513b245be6a7437794fe193e786652812be2 (diff)
Disable the build script on: mips mipsel powerpc powerpcspeHEADdebian/1.2-4archive/debian/1.2-4master
I was going to say: — Fsck it, I’m not going to fix build on those broken architectures. But then I found https://bugs.debian.org/897086. Seems it can be worked around by disabling version scripts on just those architectures. --- checking whether the C compiler works... yes checking for C compiler default output file name... a.out checking for suffix of executables... checking whether we are cross compiling... configure: error: in `/<<PKGBUILDDIR>>': configure: error: cannot run C compiled programs. If you meant to cross compile, use `--host'. See `config.log' for more details --- configure:2772: checking whether we are cross compiling configure:2780: gcc -o conftest -g -O2 -fdebug-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -Wl,-z,relro -Wl,--version-script=/<<PKGBUILDDIR>>/debian/version-script conftest.c >&5 configure:2784: $? = 0 configure:2791: ./conftest ./configure: line 2793: 26989 Segmentation fault ./conftest$ac_cv_exeext configure:2795: $? = 139 configure:2802: error: in `/<<PKGBUILDDIR>>': configure:2804: error: cannot run C compiled programs. If you meant to cross compile, use `--host'. ---
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 755fc58..d5d21d8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,12 @@
#!/usr/bin/make -f
+include /usr/share/dpkg/architecture.mk
+
export CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
export CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
+ifeq ($(filter $(DEB_HOST_ARCH),mips mipsel powerpc powerpcspe),)
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,--version-script=$(CURDIR)/debian/version-script
+endif
export ACLOCAL := aclocal -I m4