summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2014-06-21 14:20:53 +0200
committerAndrew Shadura <andrew@shadura.me>2014-06-21 14:20:53 +0200
commit04a5b2f0abf3ac30ea0c294eac027bf610bfd171 (patch)
tree27db540e33ddc7285be4fb2de4da10e5310a1412 /debian/rules
parent01331f8ef91978230a44e9307cd66007261eb417 (diff)
Update to the latest upstream snapshot
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 15 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 887215c..eef6fc0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,15 @@ export ACLOCAL := aclocal -I m4
%:
dh $@ --with=autoreconf
+override_dh_auto_configure:
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ dh_auto_configure -- SHELL=/bin/sh
+
override_dh_auto_build:
gosh src/libguess/guess.scm src/libguess/guess_tab.c
dh_auto_build
@@ -25,4 +34,9 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
LD_LIBRARY_PATH=$(LD_LIBRARY_PATH):$(CURDIR)/src/libguess make -C src/tests/testbench --no-print-directory run
endif
-.PHONY: override_dh_auto_build override_dh_compress override_dh_auto_clean override_dh_auto_test
+get-orig-source:
+ @d=$$(readlink -e $(MAKEFILE_LIST)); \
+ cd $${d%/*}/..; \
+ debian/get-orig-source.sh $(CURDIR)
+
+.PHONY: override_dh_auto_clean override_dh_auto_configure override_dh_auto_build override_dh_compress override_dh_auto_test get-orig-source