summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrew O. Shadoura <bugzilla@tut.by>2011-04-02 13:28:15 +0300
committerAndrew O. Shadoura <bugzilla@tut.by>2011-04-02 13:28:15 +0300
commit0e1d04e8b990a9a103284eac6b3223fc69e08a61 (patch)
treeac1311b8e927706c80f4c24c9243b4d4b6f90a6a /debian/rules
parent60bbe3cc6e9d6094ac7d7b240b51b0ccd0c0ae26 (diff)
populate CFLAGS and LDFLAGS using dpkg-buildflags
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7e34f63..2eefeed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,7 @@
#!/usr/bin/make -f
-export LDFLAGS = -Wl,--version-script=$(PWD)/debian/version-script
+export CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
+export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,--version-script=$(PWD)/debian/version-script
%:
dh $@ --with=autotools-dev