summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrew O. Shadoura <bugzilla@tut.by>2011-03-29 01:40:26 +0300
committerAndrew O. Shadoura <bugzilla@tut.by>2011-03-29 01:40:26 +0300
commitbc471ddc8e8f31e60b9a2fda2c4846404c1353c9 (patch)
tree8eb2056eb5075dffa182ed6b82e88314438aadff /debian/rules
parent94a7f96026bd15a38bfee953798f161c98c8884b (diff)
make sure we can load the just compiled library
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 01c8f45..af0cee1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,8 +5,11 @@
override_dh_auto_build:
gosh src/libguess/guess.scm src/libguess/guess_tab.c
dh_auto_build
+
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- make -C src/tests/testbench --no-print-directory run
+override_dh_auto_install:
+ dh_auto_install
+ LD_LIBRARY_PATH=$(LD_LIBRARY_PATH):$(PWD)/debian/tmp/usr/lib make -C src/tests/testbench --no-print-directory run
endif
override_dh_auto_clean: