summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2014-06-21 14:12:36 +0200
committerAndrew Shadura <andrew@shadura.me>2014-06-21 14:12:36 +0200
commit4c07c56dac0dacecd32e71c3267732781ec47667 (patch)
tree81cd1de5084eea6d8c2ddd48cf47b9b0cc118005 /debian
parent01331f8ef91978230a44e9307cd66007261eb417 (diff)
Update config.sub and config.guess on build.
Build-depend on autotools-dev to have fresh config.* files. Update Standards-Version.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/clean1
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules10
4 files changed, 21 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index a586d1c..95b6b3b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libguess (1.1-4) unstable; urgency=low
+
+ * Update config.sub and config.guess on build.
+ * Build-depend on autotools-dev to have fresh config.* files.
+ * Update Standards-Version.
+
+ -- Andrew Shadura <andrewsh@debian.org> Mon, 27 Jan 2014 19:52:50 +0100
+
libguess (1.1-3) unstable; urgency=low
* Remove myself from Uploaders.
diff --git a/debian/clean b/debian/clean
index f1e469b..7cd7a12 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1 +1,2 @@
.deps src/.deps src/*/.deps src/libguess/guess_tab.c buildsys.mk config.log config.status extra.mk libguess.pc src/libguess/autoconf.h src/libguess/libguess.so.1
+config.sub config.guess
diff --git a/debian/control b/debian/control
index e81e6a8..64cc8f3 100644
--- a/debian/control
+++ b/debian/control
@@ -1,8 +1,8 @@
Source: libguess
Priority: optional
Maintainer: Andrew Shadura <andrewsh@debian.org>
-Build-Depends: debhelper (>= 9), dh-autoreconf, libmowgli-dev (>= 0.7.0), pkg-config, gauche
-Standards-Version: 3.9.4
+Build-Depends: debhelper (>= 9), dh-autoreconf, libmowgli-dev (>= 0.7.0), pkg-config, gauche, autotools-dev
+Standards-Version: 3.9.5
Section: libs
Homepage: http://www.atheme.org/project/libguess
Vcs-hg: http://hg.debian.org/hg/collab-maint/libguess
diff --git a/debian/rules b/debian/rules
index 887215c..7598ec8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,15 @@ export ACLOCAL := aclocal -I m4
%:
dh $@ --with=autoreconf
+override_dh_auto_configure:
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ dh_auto_configure -- SHELL=/bin/sh
+
override_dh_auto_build:
gosh src/libguess/guess.scm src/libguess/guess_tab.c
dh_auto_build
@@ -26,3 +35,4 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
endif
.PHONY: override_dh_auto_build override_dh_compress override_dh_auto_clean override_dh_auto_test
+.PHONY: override_dh_auto_clean override_dh_auto_configure override_dh_auto_build override_dh_compress override_dh_auto_test