summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schlichting <fschlich@zedat.fu-berlin.de>2011-11-15 20:31:00 +0000
committerFlorian Schlichting <fschlich@zedat.fu-berlin.de>2011-11-15 20:34:50 +0000
commit3fabc752ef39a4209464f5a37d22fab885bbc9d8 (patch)
tree827da540883ffcd678c84bc4e131a710d41d79c3
parent8aa66b51eab5f8d69a916cb16b59f6737b53aecc (diff)
ship demo/* as examples and fix perms manually (lintian warning)
-rw-r--r--debian/changelog7
-rw-r--r--debian/libinline-files-perl.docs1
-rw-r--r--debian/libinline-files-perl.examples1
-rwxr-xr-xdebian/rules7
4 files changed, 10 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 398046b..9652ae6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,5 @@
-libinline-files-perl (0.68-1) UNRELEASED; urgency=low
-
- TODO:
- - question: how about `rm d/<pkg>.docs' and `echo demo/* > d/<pkg>.examples'?
+libinline-files-perl (0.68-1) unstable; urgency=low
* Initial Release. (Closes: #648770)
- -- Florian Schlichting <fschlich@zedat.fu-berlin.de> Tue, 15 Nov 2011 13:45:22 +0000
+ -- Florian Schlichting <fschlich@zedat.fu-berlin.de> Tue, 15 Nov 2011 20:34:43 +0000
diff --git a/debian/libinline-files-perl.docs b/debian/libinline-files-perl.docs
deleted file mode 100644
index 1549b67..0000000
--- a/debian/libinline-files-perl.docs
+++ /dev/null
@@ -1 +0,0 @@
-demo
diff --git a/debian/libinline-files-perl.examples b/debian/libinline-files-perl.examples
new file mode 100644
index 0000000..c173414
--- /dev/null
+++ b/debian/libinline-files-perl.examples
@@ -0,0 +1 @@
+demo/*
diff --git a/debian/rules b/debian/rules
index 2d33f6a..d5f1f08 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,11 @@
#!/usr/bin/make -f
+PACKAGE = $(shell dh_listpackages)
+TMP = $(CURDIR)/debian/$(PACKAGE)
+
%:
dh $@
+
+override_dh_fixperms:
+ dh_fixperms
+ chmod -x $(TMP)/usr/share/doc/$(PACKAGE)/examples/*