summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2021-11-12 17:25:27 +0100
committergregor herrmann <gregoa@debian.org>2021-11-12 17:29:09 +0100
commit60c9027741c71660beb2bbdb1798523104ef8e28 (patch)
tree5b7064bf33692960f3caac9ceb64c944194bcde3
parent94450b6ee71790c5ae992486859cc8a6cac4ed8c (diff)
Update lists of test to run/skip during build and autopkgtest.
- Skip t/70future-io.t (needs not-yet-packaged libfuture-io-perl). - Run t/50resolver.t (doesn't need a resolver anymore).
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/tests/pkg-perl/smoke-skip2
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 26140b7..8bc6f6f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,8 @@ PACKAGE = $(shell dh_listpackages)
TMP = $(CURDIR)/debian/$(PACKAGE)
EXAMPLES= $(TMP)/usr/share/doc/$(PACKAGE)/examples
-# Test needs working resolver
-TEST_FILES = $(filter-out t/50resolver.t,$(wildcard t/*.t))
+SKIP_TESTS = $(shell cat debian/tests/pkg-perl/smoke-skip)
+TEST_FILES = $(filter-out $(SKIP_TESTS), $(wildcard t/*.t))
%:
dh $@
diff --git a/debian/tests/pkg-perl/smoke-skip b/debian/tests/pkg-perl/smoke-skip
new file mode 100644
index 0000000..0cf2273
--- /dev/null
+++ b/debian/tests/pkg-perl/smoke-skip
@@ -0,0 +1,2 @@
+# needs Test::Future::IO::Impl / libfuture-io-perl
+t/70future-io.t