summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Kanashiro <kanashiro.duarte@gmail.com>2016-06-03 10:06:36 -0300
committerLucas Kanashiro <kanashiro.duarte@gmail.com>2016-06-03 10:06:36 -0300
commit2656b1c977d042b8bd03e23c5e001598d0b25e7b (patch)
treeea55014bfad320d1e70ebd96ed16064b5e13c0bd
parentfc25a0888e1e91bb0b074b6d5ad9e6ae59dac5d5 (diff)
parent52e24e85f1c8b00134f9bab7023361cfe9632813 (diff)
Merge tag 'upstream/0.26'
Upstream version 0.26 # gpg: Signature made Fri 03 Jun 2016 10:06:33 AM BRT using RSA key ID 9883C97C # gpg: Good signature from "Lucas Kanashiro <kanashiro.duarte@gmail.com>" # gpg: WARNING: This key is not certified with a trusted signature! # gpg: There is no indication that the signature belongs to the owner. # Primary key fingerprint: 8ED6 C3F8 BAC9 DB7F C130 A870 F823 A272 9883 C97C
-rw-r--r--Changes8
-rw-r--r--MANIFEST1
-rw-r--r--META.yml4
-rw-r--r--Makefile.PL2
-rw-r--r--README7
-rw-r--r--developer-manual__eng.pdfbin320114 -> 0 bytes
-rw-r--r--lib/Lingua/Translit.pm25
-rw-r--r--lib/Lingua/Translit/Tables.pm21
-rwxr-xr-xtools/substitute_tables.pl1
-rwxr-xr-xtranslit12
-rw-r--r--xml/translit.dtd5
-rwxr-xr-xxml/xml2dump.pl7
12 files changed, 52 insertions, 41 deletions
diff --git a/Changes b/Changes
index a7e19dd..7c88242 100644
--- a/Changes
+++ b/Changes
@@ -1,3 +1,11 @@
+0.26 -- 2016-05-23
+
+ * Spelling corrections in man page - thanks to Lucas Kanashiro for
+ providing a patch!
+ * Maintainership passed from Lingua-Systems to Netzum Sorglos.
+ * developer-manual__eng.pdf: removed - the documentation is now available
+ online (see link in Lingua::Translit's man page).
+
0.25 -- 2016-04-05
* Changed license terms from GPL v2/Artistic to Perl's license terms.
diff --git a/MANIFEST b/MANIFEST
index 06dc43e..0cc020a 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -1,5 +1,4 @@
Changes
-developer-manual__eng.pdf
lib/Lingua/Translit.pm
lib/Lingua/Translit/Tables.pm
Makefile.PL
diff --git a/META.yml b/META.yml
index 0c7db5e..16dd796 100644
--- a/META.yml
+++ b/META.yml
@@ -1,9 +1,9 @@
--- #YAML:1.0
name: Lingua-Translit
-version: 0.25
+version: 0.26
abstract: transliterates text between writing systems
author:
- - Alex Linke <alinke@lingua-systems.com>
+ - Alex Linke <alinke@netzum-sorglos.de>
license: perl
distribution_type: module
configure_requires:
diff --git a/Makefile.PL b/Makefile.PL
index 944a520..d127d75 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -11,7 +11,7 @@ WriteMakefile(
LICENSE => "perl",
VERSION_FROM => "lib/Lingua/Translit.pm",
ABSTRACT_FROM => "lib/Lingua/Translit.pm",
- AUTHOR => 'Alex Linke <alinke@lingua-systems.com>',
+ AUTHOR => 'Alex Linke <alinke@netzum-sorglos.de>',
EXE_FILES => [ qw/translit/ ],
PL_FILES => {
'tools/substitute_tables.pl' => 'blib/lib/Lingua/Translit/Tables.pm'
diff --git a/README b/README
index 1719899..8fdc9c6 100644
--- a/README
+++ b/README
@@ -26,16 +26,11 @@ To test and install Lingua::Translit, untar the archive and execute
make install
-CONTACT
-
-You are welcome to contact the authors at perl@lingua-systems.com
-if you have any suggestions and contributions.
-
-
COPYRIGHT AND LICENSE
Copyright (C) 2007-2008 Alex Linke and Rona Linke
Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
This module is free software; you can redistribute it and/or modify it under
the same terms as Perl itself.
diff --git a/developer-manual__eng.pdf b/developer-manual__eng.pdf
deleted file mode 100644
index f4e34b0..0000000
--- a/developer-manual__eng.pdf
+++ /dev/null
Binary files differ
diff --git a/lib/Lingua/Translit.pm b/lib/Lingua/Translit.pm
index b20ce75..606fff5 100644
--- a/lib/Lingua/Translit.pm
+++ b/lib/Lingua/Translit.pm
@@ -5,6 +5,7 @@ package Lingua::Translit;
# Alex Linke <alinke@lingua-systems.com>
# Rona Linke <rlinke@lingua-systems.com>
# Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+# Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
#
use strict;
@@ -17,7 +18,7 @@ use Encode qw/encode decode/;
use Lingua::Translit::Tables;
-our $VERSION = '0.25';
+our $VERSION = '0.26';
=pod
@@ -50,7 +51,7 @@ writing system or alphabet to another one.
The conversion is ideally unique, mapping one character to exactly one
character, so the original spelling can be reconstructed.
Practically this is not always the case and one single letter of the
-original alpabet can be transcribed as two, three or even more letters.
+original alphabet can be transcribed as two, three or even more letters.
Furthermore there is more than one transliteration scheme for one writing
system.
@@ -60,11 +61,11 @@ reconstruct the original data.
Reconstruction is a problem though for non-unique transliterations, if no
language specific knowledge is available as the resulting clusters of
-letters may be ambigous.
+letters may be ambiguous.
For example, the Greek character "PSI" maps to "ps", but "ps" could also
result from the sequence "PI", "SIGMA" since "PI" maps to "p" and "SIGMA"
maps to s.
-If a transliteration table leads to ambigous conversions, the provided
+If a transliteration table leads to ambiguous conversions, the provided
table cannot be used reverse.
Otherwise the table can be used in both directions, if appreciated.
@@ -340,10 +341,8 @@ I<Devanagari IAST>, not reversible, Devanāgarī to IAST Romanization
=head1 ADDING NEW TRANSLITERATIONS
In case you want to add your own transliteration tables to
-L<Lingua::Translit>, have a look at the developer manual included in the
-distribution.
-An online version is available at
-L<http://www.lingua-systems.com/translit/downloads/>.
+L<Lingua::Translit>, have a look at the developer documentation at
+L<http://www.netzum-sorglos.de/software/lingua-translit/developer-documentation.html>.
A template of a transliteration table is provided as well
(F<xml/template.xml>) so you can easily start developing.
@@ -364,7 +363,8 @@ converted internally.
None known.
-Please report bugs to perl@lingua-systems.com.
+Please report bugs using CPAN's request tracker at
+L<https://rt.cpan.org/Public/Dist/Display.html?Name=Lingua-Translit>.
=head1 SEE ALSO
@@ -372,7 +372,7 @@ L<Lingua::Translit::Tables>, L<Encode>, L<perlunicode>
C<translit>'s manpage
-L<http://www.lingua-systems.com/translit/>
+L<http://www.netzum-sorglos.de/software/lingua-translit/>
=head1 CREDITS
@@ -395,9 +395,9 @@ IAST" transliteration tables.
=head1 AUTHORS
-Alex Linke <alinke@lingua-systems.com>
+Alex Linke <alinke@netzum-sorglos.de>
-Rona Linke <rlinke@lingua-systems.com>
+Rona Linke <rlinke@netzum-sorglos.de>
=head1 LICENSE AND COPYRIGHT
@@ -405,6 +405,7 @@ Copyright (C) 2007-2008 Alex Linke and Rona Linke
Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
This module is free software; you can redistribute it and/or modify it under
the same terms as Perl itself.
diff --git a/lib/Lingua/Translit/Tables.pm b/lib/Lingua/Translit/Tables.pm
index d9daae1..982dd32 100644
--- a/lib/Lingua/Translit/Tables.pm
+++ b/lib/Lingua/Translit/Tables.pm
@@ -5,6 +5,7 @@ package Lingua::Translit::Tables;
# Alex Linke <alinke@lingua-systems.com>
# Rona Linke <rlinke@lingua-systems.com>
# Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+# Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
#
use strict;
@@ -13,7 +14,7 @@ use utf8;
require 5.008;
-our $VERSION = '0.25';
+our $VERSION = '0.26';
use Carp;
@@ -248,26 +249,24 @@ I<Devanagari IAST>, not reversible, Devanāgarī to IAST Romanization
=head1 ADDING NEW TRANSLITERATIONS
In case you want to add your own transliteration tables to
-L<Lingua::Translit>, have a look at the developer manual included in the
-distribution.
-An online version is available at
-L<http://www.lingua-systems.com/translit/downloads/>.
+L<Lingua::Translit>, have a look at the developer documentation at
+L<http://www.netzum-sorglos.de/software/lingua-translit/developer-documentation.html>.
A template of a transliteration table is provided as well
(F<xml/template.xml>) so you can easily start developing.
-
=head1 BUGS
None known.
-Please report bugs to perl@lingua-systems.com.
+Please report bugs using CPAN's request tracker at
+L<https://rt.cpan.org/Public/Dist/Display.html?Name=Lingua-Translit>.
=head1 SEE ALSO
L<Lingua::Translit>
-L<http://www.lingua-systems.com/translit/>
+L<http://www.netzum-sorglos.de/software/lingua-translit/>
=head1 CREDITS
@@ -291,9 +290,9 @@ IAST" transliteration tables.
=head1 AUTHORS
-Alex Linke <alinke@lingua-systems.com>
+Alex Linke <alinke@netzum-sorglos.de>
-Rona Linke <rlinke@lingua-systems.com>
+Rona Linke <rlinke@netzum-sorglos.de>
=head1 LICENSE AND COPYRIGHT
@@ -301,6 +300,8 @@ Copyright (C) 2007-2008 Alex Linke and Rona Linke
Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
+
This module is free software; you can redistribute it and/or modify it under
the same terms as Perl itself.
diff --git a/tools/substitute_tables.pl b/tools/substitute_tables.pl
index 03011d8..a40f6ac 100755
--- a/tools/substitute_tables.pl
+++ b/tools/substitute_tables.pl
@@ -3,6 +3,7 @@
#
# Copyright (C) 2007-2008 Alex Linke <alinke@lingua-systems.com>
# Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+# Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
#
use strict;
diff --git a/translit b/translit
index d6e9aa9..15ddcc8 100755
--- a/translit
+++ b/translit
@@ -5,6 +5,7 @@
# Alex Linke <alinke@lingua-systems.com>
# Rona Linke <rlinke@lingua-systems.com>
# Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+# Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
#
use strict;
@@ -15,7 +16,7 @@ require 5.008;
use Lingua::Translit;
use Lingua::Translit::Tables qw/:all/;
-my $VERSION = '0.4';
+my $VERSION = '0.5';
=pod
@@ -217,7 +218,8 @@ The input has to be UTF-8 encoded.
None known.
-Please report bugs to perl@lingua-systems.com.
+Please report bugs using CPAN's request tracker at
+L<https://rt.cpan.org/Public/Dist/Display.html?Name=Lingua-Translit>.
=head1 SEE ALSO
@@ -225,9 +227,9 @@ L<Lingua::Translit>, L<Lingua::Translit::Tables>
=head1 AUTHORS
-Alex Linke <alinke@lingua-systems.com>
+Alex Linke <alinke@netzum-sorglos.de>
-Rona Linke <rlinke@lingua-systems.com>
+Rona Linke <rlinke@netzum-sorglos.de>
=head1 LICENSE AND COPYRIGHT
@@ -235,6 +237,8 @@ Copyright (C) 2007-2008 Alex Linke and Rona Linke
Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
+
This module is free software; you can redistribute it and/or modify it under
the same terms as Perl itself.
diff --git a/xml/translit.dtd b/xml/translit.dtd
index 7fb50cd..565c99f 100644
--- a/xml/translit.dtd
+++ b/xml/translit.dtd
@@ -6,7 +6,8 @@
Basic document type definition for transliteration tables.
Copyright (C) 2007-2008 Alex Linke <alinke@lingua-systems.com>
- Copyright (C) 2009-2014 Lingua-Systems Software GmbH
+ Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+ Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
-->
@@ -24,4 +25,4 @@
<!ELEMENT after (#PCDATA)>
-<!-- vim: set sts=4 ts=4 sw=4 ai et: -->
+<!-- vim: set ft=dtd sts=4 ts=4 sw=4 ai et: -->
diff --git a/xml/xml2dump.pl b/xml/xml2dump.pl
index 7bcb474..fb2ed5f 100755
--- a/xml/xml2dump.pl
+++ b/xml/xml2dump.pl
@@ -2,7 +2,8 @@
#
# Copyright (C) 2007-2008 Alex Linke <alinke@lingua-systems.com>
-# Copyright (C) 2009-2014 Lingua-Systems Software GmbH
+# Copyright (C) 2009-2016 Lingua-Systems Software GmbH
+# Copyright (C) 2016 Netzum Sorglos, Lingua-Systems Software GmbH
#
use strict;
@@ -14,7 +15,7 @@ use XML::LibXML;
use Data::Dumper;
use Getopt::Long;
-my $VERSION = '0.5';
+my $VERSION = '0.6';
my %tables;
@@ -168,4 +169,4 @@ sub show_help {
exit($retval);
}
-# vim: sw=4 sts=4 ts=4 ai et
+# vim: set ft=perl sw=4 sts=4 ts=4 ai et: