summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Changes5
-rw-r--r--META.json46
-rw-r--r--META.yml46
-rw-r--r--Makefile.PL46
-rw-r--r--README.md2
-rw-r--r--lib/MCE.pm18
-rw-r--r--lib/MCE.pod2
-rw-r--r--lib/MCE/Candy.pm4
-rw-r--r--lib/MCE/Core.pod2
-rw-r--r--lib/MCE/Core/Input/Generator.pm2
-rw-r--r--lib/MCE/Core/Input/Handle.pm2
-rw-r--r--lib/MCE/Core/Input/Iterator.pm2
-rw-r--r--lib/MCE/Core/Input/Request.pm2
-rw-r--r--lib/MCE/Core/Input/Sequence.pm2
-rw-r--r--lib/MCE/Core/Manager.pm2
-rw-r--r--lib/MCE/Core/Validation.pm2
-rw-r--r--lib/MCE/Core/Worker.pm2
-rw-r--r--lib/MCE/Examples.pod2
-rw-r--r--lib/MCE/Flow.pm8
-rw-r--r--lib/MCE/Grep.pm8
-rw-r--r--lib/MCE/Loop.pm8
-rw-r--r--lib/MCE/Map.pm8
-rw-r--r--lib/MCE/Mutex.pm4
-rw-r--r--lib/MCE/Queue.pm4
-rw-r--r--lib/MCE/Relay.pm4
-rw-r--r--lib/MCE/Signal.pm4
-rw-r--r--lib/MCE/Step.pm14
-rw-r--r--lib/MCE/Stream.pm14
-rw-r--r--lib/MCE/Subs.pm4
-rw-r--r--lib/MCE/Util.pm4
30 files changed, 134 insertions, 139 deletions
diff --git a/Changes b/Changes
index f4084ee..bcedeaf 100644
--- a/Changes
+++ b/Changes
@@ -1,6 +1,11 @@
Revision history for Perl module MCE.
+1.808 Sat Nov 01 02:00:00 EST 2016
+
+ * Workers persist unless shutdown explicity while running alongside
+ the Mojolicious framework.
+
1.807 Tue Nov 01 16:00:00 EST 2016
* Enhanced relay capabilities. Added Mandelbrot example to MCE::Example.
diff --git a/META.json b/META.json
index b3e2093..fe10e3b 100644
--- a/META.json
+++ b/META.json
@@ -60,91 +60,91 @@
"provides" : {
"MCE" : {
"file" : "lib/MCE.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Candy" : {
"file" : "lib/MCE/Candy.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Core::Input::Generator" : {
"file" : "lib/MCE/Core/Input/Generator.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Core::Input::Handle" : {
"file" : "lib/MCE/Core/Input/Handle.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Core::Input::Iterator" : {
"file" : "lib/MCE/Core/Input/Iterator.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Core::Input::Request" : {
"file" : "lib/MCE/Core/Input/Request.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Core::Input::Sequence" : {
"file" : "lib/MCE/Core/Input/Sequence.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Core::Manager" : {
"file" : "lib/MCE/Core/Manager.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Core::Validation" : {
"file" : "lib/MCE/Core/Validation.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Core::Worker" : {
"file" : "lib/MCE/Core/Worker.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Flow" : {
"file" : "lib/MCE/Flow.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Grep" : {
"file" : "lib/MCE/Grep.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Loop" : {
"file" : "lib/MCE/Loop.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Map" : {
"file" : "lib/MCE/Map.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Mutex" : {
"file" : "lib/MCE/Mutex.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Queue" : {
"file" : "lib/MCE/Queue.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Relay" : {
"file" : "lib/MCE/Relay.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Signal" : {
"file" : "lib/MCE/Signal.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Step" : {
"file" : "lib/MCE/Step.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Stream" : {
"file" : "lib/MCE/Stream.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Subs" : {
"file" : "lib/MCE/Subs.pm",
- "version" : "1.807"
+ "version" : "1.808"
},
"MCE::Util" : {
"file" : "lib/MCE/Util.pm",
- "version" : "1.807"
+ "version" : "1.808"
}
},
"release_status" : "stable",
@@ -160,5 +160,5 @@
"url" : "https://github.com/marioroy/mce-perl.git"
}
},
- "version" : "1.807"
+ "version" : "1.808"
}
diff --git a/META.yml b/META.yml
index 818a3af..6259ef6 100644
--- a/META.yml
+++ b/META.yml
@@ -25,70 +25,70 @@ no_index:
provides:
MCE:
file: lib/MCE.pm
- version: '1.807'
+ version: '1.808'
MCE::Candy:
file: lib/MCE/Candy.pm
- version: '1.807'
+ version: '1.808'
MCE::Core::Input::Generator:
file: lib/MCE/Core/Input/Generator.pm
- version: '1.807'
+ version: '1.808'
MCE::Core::Input::Handle:
file: lib/MCE/Core/Input/Handle.pm
- version: '1.807'
+ version: '1.808'
MCE::Core::Input::Iterator:
file: lib/MCE/Core/Input/Iterator.pm
- version: '1.807'
+ version: '1.808'
MCE::Core::Input::Request:
file: lib/MCE/Core/Input/Request.pm
- version: '1.807'
+ version: '1.808'
MCE::Core::Input::Sequence:
file: lib/MCE/Core/Input/Sequence.pm
- version: '1.807'
+ version: '1.808'
MCE::Core::Manager:
file: lib/MCE/Core/Manager.pm
- version: '1.807'
+ version: '1.808'
MCE::Core::Validation:
file: lib/MCE/Core/Validation.pm
- version: '1.807'
+ version: '1.808'
MCE::Core::Worker:
file: lib/MCE/Core/Worker.pm
- version: '1.807'
+ version: '1.808'
MCE::Flow:
file: lib/MCE/Flow.pm
- version: '1.807'
+ version: '1.808'
MCE::Grep:
file: lib/MCE/Grep.pm
- version: '1.807'
+ version: '1.808'
MCE::Loop:
file: lib/MCE/Loop.pm
- version: '1.807'
+ version: '1.808'
MCE::Map:
file: lib/MCE/Map.pm
- version: '1.807'
+ version: '1.808'
MCE::Mutex:
file: lib/MCE/Mutex.pm
- version: '1.807'
+ version: '1.808'
MCE::Queue:
file: lib/MCE/Queue.pm
- version: '1.807'
+ version: '1.808'
MCE::Relay:
file: lib/MCE/Relay.pm
- version: '1.807'
+ version: '1.808'
MCE::Signal:
file: lib/MCE/Signal.pm
- version: '1.807'
+ version: '1.808'
MCE::Step:
file: lib/MCE/Step.pm
- version: '1.807'
+ version: '1.808'
MCE::Stream:
file: lib/MCE/Stream.pm
- version: '1.807'
+ version: '1.808'
MCE::Subs:
file: lib/MCE/Subs.pm
- version: '1.807'
+ version: '1.808'
MCE::Util:
file: lib/MCE/Util.pm
- version: '1.807'
+ version: '1.808'
requires:
Carp: '0'
Fcntl: '0'
@@ -111,4 +111,4 @@ resources:
homepage: https://github.com/marioroy/mce-perl
license: http://dev.perl.org/licenses/
repository: https://github.com/marioroy/mce-perl.git
-version: '1.807'
+version: '1.808'
diff --git a/Makefile.PL b/Makefile.PL
index 381712e..a31313f 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -17,7 +17,7 @@ WriteMakefile(
ABSTRACT => 'Many-Core Engine for Perl providing parallel processing capabilities',
AUTHOR => 'Mario E. Roy <marioeroy AT gmail DOT com>',
NAME => 'MCE',
- VERSION => '1.807',
+ VERSION => '1.808',
EXE_FILES => [ @exe_files ],
@@ -67,91 +67,91 @@ WriteMakefile(
'provides' => {
'MCE' => {
'file' => 'lib/MCE.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Candy' => {
'file' => 'lib/MCE/Candy.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Core::Input::Generator' => {
'file' => 'lib/MCE/Core/Input/Generator.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Core::Input::Handle' => {
'file' => 'lib/MCE/Core/Input/Handle.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Core::Input::Iterator' => {
'file' => 'lib/MCE/Core/Input/Iterator.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Core::Input::Request' => {
'file' => 'lib/MCE/Core/Input/Request.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Core::Input::Sequence' => {
'file' => 'lib/MCE/Core/Input/Sequence.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Core::Manager' => {
'file' => 'lib/MCE/Core/Manager.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Core::Validation' => {
'file' => 'lib/MCE/Core/Validation.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Core::Worker' => {
'file' => 'lib/MCE/Core/Worker.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Flow' => {
'file' => 'lib/MCE/Flow.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Grep' => {
'file' => 'lib/MCE/Grep.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Loop' => {
'file' => 'lib/MCE/Loop.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Map' => {
'file' => 'lib/MCE/Map.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Mutex' => {
'file' => 'lib/MCE/Mutex.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Queue' => {
'file' => 'lib/MCE/Queue.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Relay' => {
'file' => 'lib/MCE/Relay.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Signal' => {
'file' => 'lib/MCE/Signal.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Step' => {
'file' => 'lib/MCE/Step.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Stream' => {
'file' => 'lib/MCE/Stream.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Subs' => {
'file' => 'lib/MCE/Subs.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
},
'MCE::Util' => {
'file' => 'lib/MCE/Util.pm',
- 'version' => '1.807'
+ 'version' => '1.808'
}
}
} ) : () ),
diff --git a/README.md b/README.md
index 385785a..4eb327d 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,6 @@
## Many-Core Engine for Perl
-This document describes MCE version 1.807.
+This document describes MCE version 1.808.
Many-Core Engine (MCE) for Perl helps enable a new level of performance by
maximizing all available cores.
diff --git a/lib/MCE.pm b/lib/MCE.pm
index 289e017..66c507a 100644
--- a/lib/MCE.pm
+++ b/lib/MCE.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
## no critic (Subroutines::ProhibitSubroutinePrototypes)
@@ -1089,14 +1089,16 @@ sub run {
if ( $_auto_shutdown || $self->{_total_exited} ) {
$self->shutdown();
}
- elsif (!$INC{'Tk.pm'} && ($^S || $ENV{'PERL_IPERL_RUNNING'})) {
- # running inside eval or IPerl, check stack trace
- my $_t = Carp::longmess(); $_t =~ s/\teval [^\n]+\n$//;
+ elsif ($^S || $ENV{'PERL_IPERL_RUNNING'}) {
+ if (!$INC{'Mojo/Base.pm'} && !$INC{'Tk.pm'}) {
+ # running inside eval or IPerl, check stack trace
+ my $_t = Carp::longmess(); $_t =~ s/\teval [^\n]+\n$//;
- if ( $_t =~ /^(?:[^\n]+\n){1,7}\teval / ||
- $_t =~ /\n\teval [^\n]+\n\t(?:eval|Try)/ )
- {
- $self->shutdown();
+ if ( $_t =~ /^(?:[^\n]+\n){1,7}\teval / ||
+ $_t =~ /\n\teval [^\n]+\n\t(?:eval|Try)/ )
+ {
+ $self->shutdown();
+ }
}
}
diff --git a/lib/MCE.pod b/lib/MCE.pod
index 787c71d..efe0384 100644
--- a/lib/MCE.pod
+++ b/lib/MCE.pod
@@ -5,7 +5,7 @@ MCE - Many-Core Engine for Perl providing parallel processing capabilities
=head1 VERSION
-This document describes MCE version 1.807
+This document describes MCE version 1.808
Many-Core Engine (MCE) for Perl helps enable a new level of performance by
maximizing all available cores.
diff --git a/lib/MCE/Candy.pm b/lib/MCE/Candy.pm
index eef1dee..12e1fc3 100644
--- a/lib/MCE/Candy.pm
+++ b/lib/MCE/Candy.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
our @CARP_NOT = qw( MCE );
@@ -210,7 +210,7 @@ MCE::Candy - Sugar methods and output iterators
=head1 VERSION
-This document describes MCE::Candy version 1.807
+This document describes MCE::Candy version 1.808
=head1 DESCRIPTION
diff --git a/lib/MCE/Core.pod b/lib/MCE/Core.pod
index e8a3c7c..a9d55b8 100644
--- a/lib/MCE/Core.pod
+++ b/lib/MCE/Core.pod
@@ -5,7 +5,7 @@ MCE::Core - Documentation describing the core MCE API
=head1 VERSION
-This document describes MCE::Core version 1.807
+This document describes MCE::Core version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Core/Input/Generator.pm b/lib/MCE/Core/Input/Generator.pm
index c08c90b..7d82fa3 100644
--- a/lib/MCE/Core/Input/Generator.pm
+++ b/lib/MCE/Core/Input/Generator.pm
@@ -15,7 +15,7 @@ package MCE::Core::Input::Generator;
use strict;
use warnings;
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## Items below are folded into MCE.
diff --git a/lib/MCE/Core/Input/Handle.pm b/lib/MCE/Core/Input/Handle.pm
index 2d277cb..7212b7b 100644
--- a/lib/MCE/Core/Input/Handle.pm
+++ b/lib/MCE/Core/Input/Handle.pm
@@ -14,7 +14,7 @@ package MCE::Core::Input::Handle;
use strict;
use warnings;
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## Items below are folded into MCE.
diff --git a/lib/MCE/Core/Input/Iterator.pm b/lib/MCE/Core/Input/Iterator.pm
index 32c7be1..a32dd22 100644
--- a/lib/MCE/Core/Input/Iterator.pm
+++ b/lib/MCE/Core/Input/Iterator.pm
@@ -14,7 +14,7 @@ package MCE::Core::Input::Iterator;
use strict;
use warnings;
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## Items below are folded into MCE.
diff --git a/lib/MCE/Core/Input/Request.pm b/lib/MCE/Core/Input/Request.pm
index 4280eb5..998b069 100644
--- a/lib/MCE/Core/Input/Request.pm
+++ b/lib/MCE/Core/Input/Request.pm
@@ -14,7 +14,7 @@ package MCE::Core::Input::Request;
use strict;
use warnings;
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## Items below are folded into MCE.
diff --git a/lib/MCE/Core/Input/Sequence.pm b/lib/MCE/Core/Input/Sequence.pm
index 727b9b8..fc7d4bc 100644
--- a/lib/MCE/Core/Input/Sequence.pm
+++ b/lib/MCE/Core/Input/Sequence.pm
@@ -14,7 +14,7 @@ package MCE::Core::Input::Sequence;
use strict;
use warnings;
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## Items below are folded into MCE.
diff --git a/lib/MCE/Core/Manager.pm b/lib/MCE/Core/Manager.pm
index 5b43592..7d72daa 100644
--- a/lib/MCE/Core/Manager.pm
+++ b/lib/MCE/Core/Manager.pm
@@ -14,7 +14,7 @@ package MCE::Core::Manager;
use strict;
use warnings;
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
## no critic (TestingAndDebugging::ProhibitNoStrict)
diff --git a/lib/MCE/Core/Validation.pm b/lib/MCE/Core/Validation.pm
index b9a4901..3194e47 100644
--- a/lib/MCE/Core/Validation.pm
+++ b/lib/MCE/Core/Validation.pm
@@ -14,7 +14,7 @@ package MCE::Core::Validation;
use strict;
use warnings;
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## Items below are folded into MCE.
diff --git a/lib/MCE/Core/Worker.pm b/lib/MCE/Core/Worker.pm
index 41cecf7..e08b4a3 100644
--- a/lib/MCE/Core/Worker.pm
+++ b/lib/MCE/Core/Worker.pm
@@ -14,7 +14,7 @@ package MCE::Core::Worker;
use strict;
use warnings;
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## Items below are folded into MCE.
diff --git a/lib/MCE/Examples.pod b/lib/MCE/Examples.pod
index 58cfe03..ede4e60 100644
--- a/lib/MCE/Examples.pod
+++ b/lib/MCE/Examples.pod
@@ -5,7 +5,7 @@ MCE::Examples - Various examples and demonstrations
=head1 VERSION
-This document describes MCE::Examples version 1.807
+This document describes MCE::Examples version 1.808
=head1 INCLUDED WITH THE DISTRIBUTION
diff --git a/lib/MCE/Flow.pm b/lib/MCE/Flow.pm
index 0e1bf33..2859dd5 100644
--- a/lib/MCE/Flow.pm
+++ b/lib/MCE/Flow.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
## no critic (Subroutines::ProhibitSubroutinePrototypes)
@@ -430,10 +430,6 @@ sub run (@) {
MCE::_restore_state();
- if (!$INC{'Tk.pm'} && ($^S || $ENV{'PERL_IPERL_RUNNING'})) {
- $_MCE->{$_pid}->shutdown(); # shutdown if in eval state
- }
-
delete $_MCE->{$_pid}{gather} if (defined $_wa);
return ((defined $_wa) ? @_a : ());
@@ -499,7 +495,7 @@ MCE::Flow - Parallel flow model for building creative applications
=head1 VERSION
-This document describes MCE::Flow version 1.807
+This document describes MCE::Flow version 1.808
=head1 DESCRIPTION
diff --git a/lib/MCE/Grep.pm b/lib/MCE/Grep.pm
index ea1a4a5..245a8ad 100644
--- a/lib/MCE/Grep.pm
+++ b/lib/MCE/Grep.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
## no critic (Subroutines::ProhibitSubroutinePrototypes)
@@ -393,10 +393,6 @@ sub run (&@) {
MCE::_restore_state();
- if (!$INC{'Tk.pm'} && ($^S || $ENV{'PERL_IPERL_RUNNING'})) {
- $_MCE->{$_pid}->shutdown(); # shutdown if in eval state
- }
-
if ($_wantarray) {
return map { @{ $_ } } delete @_tmp{ 1 .. $_total_chunks };
}
@@ -449,7 +445,7 @@ MCE::Grep - Parallel grep model similar to the native grep function
=head1 VERSION
-This document describes MCE::Grep version 1.807
+This document describes MCE::Grep version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Loop.pm b/lib/MCE/Loop.pm
index 5fe184e..680efb5 100644
--- a/lib/MCE/Loop.pm
+++ b/lib/MCE/Loop.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
## no critic (Subroutines::ProhibitSubroutinePrototypes)
@@ -318,10 +318,6 @@ sub run (&@) {
MCE::_restore_state();
- if (!$INC{'Tk.pm'} && ($^S || $ENV{'PERL_IPERL_RUNNING'})) {
- $_MCE->{$_pid}->shutdown(); # shutdown if in eval state
- }
-
delete $_MCE->{$_pid}{gather} if (defined $_wa);
return ((defined $_wa) ? @_a : ());
@@ -369,7 +365,7 @@ MCE::Loop - Parallel loop model for building creative loops
=head1 VERSION
-This document describes MCE::Loop version 1.807
+This document describes MCE::Loop version 1.808
=head1 DESCRIPTION
diff --git a/lib/MCE/Map.pm b/lib/MCE/Map.pm
index d7832ab..54bd082 100644
--- a/lib/MCE/Map.pm
+++ b/lib/MCE/Map.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
## no critic (Subroutines::ProhibitSubroutinePrototypes)
@@ -393,10 +393,6 @@ sub run (&@) {
MCE::_restore_state();
- if (!$INC{'Tk.pm'} && ($^S || $ENV{'PERL_IPERL_RUNNING'})) {
- $_MCE->{$_pid}->shutdown(); # shutdown if in eval state
- }
-
if ($_wantarray) {
return map { @{ $_ } } delete @_tmp{ 1 .. $_total_chunks };
}
@@ -449,7 +445,7 @@ MCE::Map - Parallel map model similar to the native map function
=head1 VERSION
-This document describes MCE::Map version 1.807
+This document describes MCE::Map version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Mutex.pm b/lib/MCE/Mutex.pm
index ffd6edc..1777484 100644
--- a/lib/MCE/Mutex.pm
+++ b/lib/MCE/Mutex.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
use MCE::Util qw( $LF );
@@ -111,7 +111,7 @@ MCE::Mutex - Locking for Many-Core Engine
=head1 VERSION
-This document describes MCE::Mutex version 1.807
+This document describes MCE::Mutex version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Queue.pm b/lib/MCE/Queue.pm
index 8d2822a..14d7d64 100644
--- a/lib/MCE/Queue.pm
+++ b/lib/MCE/Queue.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (Subroutines::ProhibitExplicitReturnUndef)
## no critic (TestingAndDebugging::ProhibitNoStrict)
@@ -1637,7 +1637,7 @@ MCE::Queue - Hybrid (normal and priority) queues
=head1 VERSION
-This document describes MCE::Queue version 1.807
+This document describes MCE::Queue version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Relay.pm b/lib/MCE/Relay.pm
index 3ffa186..d86a258 100644
--- a/lib/MCE/Relay.pm
+++ b/lib/MCE/Relay.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (Subroutines::ProhibitSubroutinePrototypes)
@@ -343,7 +343,7 @@ MCE::Relay - Extends Many-Core Engine with relay capabilities
=head1 VERSION
-This document describes MCE::Relay version 1.807
+This document describes MCE::Relay version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Signal.pm b/lib/MCE/Signal.pm
index 73b6ea4..5a5ed3b 100644
--- a/lib/MCE/Signal.pm
+++ b/lib/MCE/Signal.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
@@ -451,7 +451,7 @@ MCE::Signal - Temporary directory creation/cleanup and signal handling
=head1 VERSION
-This document describes MCE::Signal version 1.807
+This document describes MCE::Signal version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Step.pm b/lib/MCE/Step.pm
index d9eca59..06a0663 100644
--- a/lib/MCE/Step.pm
+++ b/lib/MCE/Step.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
## no critic (Subroutines::ProhibitSubroutinePrototypes)
@@ -620,10 +620,12 @@ sub run (@) {
MCE::_restore_state();
- if (!$INC{'Tk.pm'} && ($^S || $ENV{'PERL_IPERL_RUNNING'})) {
- $_MCE->{$_pid}->shutdown(); # shutdown if in eval state
- $_->DESTROY() for (@{ $_queue->{$_pid} });
- delete $_queue->{$_pid};
+ if ($^S || $ENV{'PERL_IPERL_RUNNING'}) {
+ if (!$INC{'Mojo/Base.pm'} && !$INC{'Tk.pm'}) {
+ $_MCE->{$_pid}->shutdown(); # shutdown if in eval state
+ $_->DESTROY() for (@{ $_queue->{$_pid} });
+ delete $_queue->{$_pid};
+ }
}
delete $_MCE->{$_pid}{gather} if (defined $_wa);
@@ -730,7 +732,7 @@ MCE::Step - Parallel step model for building creative steps
=head1 VERSION
-This document describes MCE::Step version 1.807
+This document describes MCE::Step version 1.808
=head1 DESCRIPTION
diff --git a/lib/MCE/Stream.pm b/lib/MCE/Stream.pm
index a21e6c0..90cd48e 100644
--- a/lib/MCE/Stream.pm
+++ b/lib/MCE/Stream.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
## no critic (Subroutines::ProhibitSubroutinePrototypes)
@@ -520,10 +520,12 @@ sub run (@) {
MCE::_restore_state();
- if (!$INC{'Tk.pm'} && ($^S || $ENV{'PERL_IPERL_RUNNING'})) {
- $_MCE->{$_pid}->shutdown(); # shutdown if in eval state
- $_->DESTROY() for (@{ $_queue->{$_pid} });
- delete $_queue->{$_pid};
+ if ($^S || $ENV{'PERL_IPERL_RUNNING'}) {
+ if (!$INC{'Mojo/Base.pm'} && !$INC{'Tk.pm'}) {
+ $_MCE->{$_pid}->shutdown(); # shutdown if in eval state
+ $_->DESTROY() for (@{ $_queue->{$_pid} });
+ delete $_queue->{$_pid};
+ }
}
return map { @{ $_ } } delete @_tmp{ 1 .. $_order_id - 1 }
@@ -679,7 +681,7 @@ MCE::Stream - Parallel stream model for chaining multiple maps and greps
=head1 VERSION
-This document describes MCE::Stream version 1.807
+This document describes MCE::Stream version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Subs.pm b/lib/MCE/Subs.pm
index e6fb8da..b4e91b4 100644
--- a/lib/MCE/Subs.pm
+++ b/lib/MCE/Subs.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (Subroutines::ProhibitSubroutinePrototypes)
## no critic (TestingAndDebugging::ProhibitNoStrict)
@@ -204,7 +204,7 @@ MCE::Subs - Exports functions mapped directly to MCE methods
=head1 VERSION
-This document describes MCE::Subs version 1.807
+This document describes MCE::Subs version 1.808
=head1 SYNOPSIS
diff --git a/lib/MCE/Util.pm b/lib/MCE/Util.pm
index 637775c..974054e 100644
--- a/lib/MCE/Util.pm
+++ b/lib/MCE/Util.pm
@@ -11,7 +11,7 @@ use warnings;
no warnings qw( threads recursion uninitialized );
-our $VERSION = '1.807';
+our $VERSION = '1.808';
## no critic (BuiltinFunctions::ProhibitStringyEval)
@@ -428,7 +428,7 @@ MCE::Util - Utility functions
=head1 VERSION
-This document describes MCE::Util version 1.807
+This document describes MCE::Util version 1.808
=head1 SYNOPSIS