summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2013-10-22 15:31:48 +0200
committerAndrew Shadura <andrewsh@debian.org>2013-10-22 15:31:48 +0200
commitb973573ad46b9366e3264970c7e2298ff9a99dbb (patch)
treec40652d3c5c31d1b83698fd5c6e5f354c5193a9f
parentd467ed1157696ded43c4a4e5f22e734499a6a12d (diff)
Fix arch-dependent files in -dev package (Closes: #670014).
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules12
2 files changed, 13 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 1577d3d..a829c9b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,8 +2,9 @@ libmowgli (1.0.0-2) unstable; urgency=low
* Update Standards-Version to 3.9.4 (no changes).
* Fix FTBFS with latest debhelper (Closes: #724183).
+ * Fix arch-dependent files in -dev package (Closes: #670014).
- -- Andrew Shadura <andrewsh@debian.org> Mon, 21 Oct 2013 11:17:08 +0200
+ -- Andrew Shadura <andrewsh@debian.org> Tue, 22 Oct 2013 15:30:44 +0200
libmowgli (1.0.0-1) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 009fcb2..a856fec 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,11 +6,21 @@ export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
export ACLOCAL := aclocal -I m4
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
%:
dh $@ --with=autoreconf
+override_dh_auto_install:
+ dh_auto_install
+ mkdir -p debian/libmowgli2/usr/include/$(DEB_HOST_MULTIARCH)/libmowgli
+ mv -f debian/tmp/usr/include/libmowgli/mowgli_config.h debian/libmowgli2/usr/include/$(DEB_HOST_MULTIARCH)/libmowgli/mowgli_config.h
+
override_dh_installexamples:
- sed -e 's,\(libdir = \$${prefix}/lib\)/.*$$,\1,' < buildsys.mk > buildsys.mk.new
+ sed -e 's,\(libdir = \$${prefix}/lib\)/.*$$,\1,' \
+ -e 's,CFLAGS = .*$$,CFLAGS = ,' \
+ -e 's,CPPFLAGS = .*$$,CPPFLAGS = ,' \
+ -e 's,LDFLAGS = .*$$,LDFLAGS = ,' < buildsys.mk > buildsys.mk.new
mv -f buildsys.mk.new buildsys.mk
dh_installexamples -X.dep