summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Cécile (Le_Vert) <gandalf@le-vert.net>2018-04-24 16:52:34 +0200
committerAndrej Shadura <andrewsh@debian.org>2018-04-24 16:52:34 +0200
commitfaa37905ce30a136b3dfd53f708d50c7afab5261 (patch)
tree5bd2180cf2e4de72a4679fdc7eb1d830587d83de
parent331a4905a5c83d635f9ad3b075c3593c3e31bdbb (diff)
This patch makes the examples build standalone.
Gbp-Pq: Name 002-Make-Examples-Buildable-standalone.diff
-rw-r--r--src/examples/Makefile2
-rw-r--r--src/examples/async_resolver/Makefile2
-rw-r--r--src/examples/async_resolver/async_resolver.c2
-rw-r--r--src/examples/echoserver/Makefile2
-rw-r--r--src/examples/echoserver/echoserver.c2
-rw-r--r--src/examples/formattertest/Makefile2
-rw-r--r--src/examples/formattertest/formattertest.c2
-rw-r--r--src/examples/helpertest/Makefile2
-rw-r--r--src/examples/helpertest/helpertest.c2
-rw-r--r--src/examples/jsontest/jsontest.c2
-rw-r--r--src/examples/libevent-bench/Makefile2
-rw-r--r--src/examples/libevent-bench/bench.c2
-rw-r--r--src/examples/linetest/Makefile2
-rw-r--r--src/examples/linetest/linetest.c2
-rw-r--r--src/examples/listsort/Makefile2
-rw-r--r--src/examples/listsort/listsort.c2
-rw-r--r--src/examples/memslice-bench/Makefile2
-rw-r--r--src/examples/memslice-bench/memslice-bench.c2
-rw-r--r--src/examples/patriciatest/Makefile2
-rw-r--r--src/examples/patriciatest/patriciatest.c2
-rw-r--r--src/examples/patriciatest2/Makefile2
-rw-r--r--src/examples/patriciatest2/patriciatest2.c2
-rw-r--r--src/examples/randomtest/Makefile2
-rw-r--r--src/examples/randomtest/randomtest.c2
-rw-r--r--src/examples/timertest/Makefile2
-rw-r--r--src/examples/timertest/timertest.c2
-rw-r--r--src/examples/vio-udplistener/Makefile2
-rw-r--r--src/examples/vio-udplistener/vio-udplistener.c2
28 files changed, 28 insertions, 28 deletions
diff --git a/src/examples/Makefile b/src/examples/Makefile
index 4fb1edd..f16e38b 100644
--- a/src/examples/Makefile
+++ b/src/examples/Makefile
@@ -1,2 +1,2 @@
SUBDIRS = echoserver vio-udplistener async_resolver formattertest helpertest jsontest libevent-bench linetest listsort memslice-bench patriciatest patriciatest2 randomtest timertest
-include ../../buildsys.mk
+include buildsys.mk
diff --git a/src/examples/async_resolver/Makefile b/src/examples/async_resolver/Makefile
index 2c664bc..3766fc8 100644
--- a/src/examples/async_resolver/Makefile
+++ b/src/examples/async_resolver/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = async_resolver${PROG_SUFFIX}
SRCS = async_resolver.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/async_resolver/async_resolver.c b/src/examples/async_resolver/async_resolver.c
index 8bd0b12..fc7e864 100644
--- a/src/examples/async_resolver/async_resolver.c
+++ b/src/examples/async_resolver/async_resolver.c
@@ -1,6 +1,6 @@
/* This code is in the public domain. */
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
typedef struct
{
diff --git a/src/examples/echoserver/Makefile b/src/examples/echoserver/Makefile
index c0fa0f2..b811efe 100644
--- a/src/examples/echoserver/Makefile
+++ b/src/examples/echoserver/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = echoserver${PROG_SUFFIX}
SRCS = echoserver.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/echoserver/echoserver.c b/src/examples/echoserver/echoserver.c
index 053b33b..1752fbc 100644
--- a/src/examples/echoserver/echoserver.c
+++ b/src/examples/echoserver/echoserver.c
@@ -21,7 +21,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
mowgli_eventloop_t *base_eventloop;
mowgli_eventloop_pollable_t *listener;
diff --git a/src/examples/formattertest/Makefile b/src/examples/formattertest/Makefile
index 63cf463..8a50cd4 100644
--- a/src/examples/formattertest/Makefile
+++ b/src/examples/formattertest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = formattertest${PROG_SUFFIX}
SRCS = formattertest.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/formattertest/formattertest.c b/src/examples/formattertest/formattertest.c
index f56b671..8a81e75 100644
--- a/src/examples/formattertest/formattertest.c
+++ b/src/examples/formattertest/formattertest.c
@@ -31,7 +31,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
int
main(int argc, char *argv[])
diff --git a/src/examples/helpertest/Makefile b/src/examples/helpertest/Makefile
index 2a37715..7f28a04 100644
--- a/src/examples/helpertest/Makefile
+++ b/src/examples/helpertest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = helpertest${PROG_SUFFIX}
SRCS = helpertest.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/helpertest/helpertest.c b/src/examples/helpertest/helpertest.c
index fde9b15..3c7c8e4 100644
--- a/src/examples/helpertest/helpertest.c
+++ b/src/examples/helpertest/helpertest.c
@@ -21,7 +21,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
int helper_count = 0;
diff --git a/src/examples/jsontest/jsontest.c b/src/examples/jsontest/jsontest.c
index a63dbc5..4237ed2 100644
--- a/src/examples/jsontest/jsontest.c
+++ b/src/examples/jsontest/jsontest.c
@@ -1,4 +1,4 @@
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
void
out_string(mowgli_json_output_t *out, const char *str, size_t len)
diff --git a/src/examples/libevent-bench/Makefile b/src/examples/libevent-bench/Makefile
index c420102..4d357d6 100644
--- a/src/examples/libevent-bench/Makefile
+++ b/src/examples/libevent-bench/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = bench${PROG_SUFFIX}
SRCS = bench.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/libevent-bench/bench.c b/src/examples/libevent-bench/bench.c
index 9940b45..e7ab493 100644
--- a/src/examples/libevent-bench/bench.c
+++ b/src/examples/libevent-bench/bench.c
@@ -76,7 +76,7 @@
} \
} while (0)
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
static int count, writes, fired;
static mowgli_eventloop_t *base_eventloop;
diff --git a/src/examples/linetest/Makefile b/src/examples/linetest/Makefile
index cb9b030..b7e7d1a 100644
--- a/src/examples/linetest/Makefile
+++ b/src/examples/linetest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = linetest${PROG_SUFFIX}
SRCS = linetest.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/linetest/linetest.c b/src/examples/linetest/linetest.c
index 3175b84..d790a0d 100644
--- a/src/examples/linetest/linetest.c
+++ b/src/examples/linetest/linetest.c
@@ -22,7 +22,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
mowgli_eventloop_t *base_eventloop;
char buf[512];
diff --git a/src/examples/listsort/Makefile b/src/examples/listsort/Makefile
index b3e59b4..277abb2 100644
--- a/src/examples/listsort/Makefile
+++ b/src/examples/listsort/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = listsort${PROG_SUFFIX}
SRCS = listsort.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/listsort/listsort.c b/src/examples/listsort/listsort.c
index 17768b5..0dd315f 100644
--- a/src/examples/listsort/listsort.c
+++ b/src/examples/listsort/listsort.c
@@ -31,7 +31,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
#ifdef _WIN32
# define strcasecmp _stricmp
diff --git a/src/examples/memslice-bench/Makefile b/src/examples/memslice-bench/Makefile
index 8648d93..a5cf9e7 100644
--- a/src/examples/memslice-bench/Makefile
+++ b/src/examples/memslice-bench/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = memslice-bench${PROG_SUFFIX}
SRCS = memslice-bench.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/memslice-bench/memslice-bench.c b/src/examples/memslice-bench/memslice-bench.c
index 3ed95fc..a5c3cf6 100644
--- a/src/examples/memslice-bench/memslice-bench.c
+++ b/src/examples/memslice-bench/memslice-bench.c
@@ -30,7 +30,7 @@
} \
} while (0)
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
mowgli_allocation_policy_t *memslice;
mowgli_allocation_policy_t *sysmalloc;
diff --git a/src/examples/patriciatest/Makefile b/src/examples/patriciatest/Makefile
index 5c454e2..1d7d2b0 100644
--- a/src/examples/patriciatest/Makefile
+++ b/src/examples/patriciatest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = patriciatest${PROG_SUFFIX}
SRCS = patriciatest.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/patriciatest/patriciatest.c b/src/examples/patriciatest/patriciatest.c
index 4dbb212..edfd935 100644
--- a/src/examples/patriciatest/patriciatest.c
+++ b/src/examples/patriciatest/patriciatest.c
@@ -31,7 +31,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
int errors = 0;
diff --git a/src/examples/patriciatest2/Makefile b/src/examples/patriciatest2/Makefile
index de50339..763767e 100644
--- a/src/examples/patriciatest2/Makefile
+++ b/src/examples/patriciatest2/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = patriciatest2${PROG_SUFFIX}
SRCS = patriciatest2.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/patriciatest2/patriciatest2.c b/src/examples/patriciatest2/patriciatest2.c
index 800c59e..aebb01f 100644
--- a/src/examples/patriciatest2/patriciatest2.c
+++ b/src/examples/patriciatest2/patriciatest2.c
@@ -31,7 +31,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
#define TESTSIZE 10000
diff --git a/src/examples/randomtest/Makefile b/src/examples/randomtest/Makefile
index 9b49184..98f6ed6 100644
--- a/src/examples/randomtest/Makefile
+++ b/src/examples/randomtest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = randomtest${PROG_SUFFIX}
SRCS = randomtest.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/randomtest/randomtest.c b/src/examples/randomtest/randomtest.c
index eb7ef05..959750c 100644
--- a/src/examples/randomtest/randomtest.c
+++ b/src/examples/randomtest/randomtest.c
@@ -31,7 +31,7 @@
* IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
int
main(int argc, char *argv[])
diff --git a/src/examples/timertest/Makefile b/src/examples/timertest/Makefile
index 968f2d1..b291b63 100644
--- a/src/examples/timertest/Makefile
+++ b/src/examples/timertest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = timertest${PROG_SUFFIX}
SRCS = timertest.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/timertest/timertest.c b/src/examples/timertest/timertest.c
index f99410b..81acb58 100644
--- a/src/examples/timertest/timertest.c
+++ b/src/examples/timertest/timertest.c
@@ -21,7 +21,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
mowgli_eventloop_t *eventloop;
diff --git a/src/examples/vio-udplistener/Makefile b/src/examples/vio-udplistener/Makefile
index 1be3936..7e4ccc2 100644
--- a/src/examples/vio-udplistener/Makefile
+++ b/src/examples/vio-udplistener/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = vio-udplistener${PROG_SUFFIX}
SRCS = vio-udplistener.c
-include ../../../buildsys.mk
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
diff --git a/src/examples/vio-udplistener/vio-udplistener.c b/src/examples/vio-udplistener/vio-udplistener.c
index 1e1dda1..ca0a38f 100644
--- a/src/examples/vio-udplistener/vio-udplistener.c
+++ b/src/examples/vio-udplistener/vio-udplistener.c
@@ -3,7 +3,7 @@
* This example is public domain.
*/
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
#define BUFSIZE 2048