summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2014-06-17 23:26:41 +0200
committerAndrew Shadura <andrew@shadura.me>2014-06-17 23:26:41 +0200
commit6a39c77b0c04e02cf01b549dd482919fa29691e6 (patch)
treeddb4c0030354990882bbdff5297164ec7a50b324
parent4fab5856e3892d57f1cfdba127460b34bae55b26 (diff)
Build without openssl
-rw-r--r--debian/clean2
-rw-r--r--debian/libmowgli-2-0.symbols6
-rw-r--r--debian/patches/004-No-openssl.diff15
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules2
5 files changed, 18 insertions, 8 deletions
diff --git a/debian/clean b/debian/clean
index 8c6c9f0..92d8807 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1,4 +1,4 @@
.deps src/.deps src/*/.deps src/*/*/.deps buildsys.mk config.log config.status extra.mk *.pc
src/libmowgli/*/*.dep
src/libmowgli/platform/autoconf.h
-config.sub config.guess
+config.sub config.guess configure config.rpath
diff --git a/debian/libmowgli-2-0.symbols b/debian/libmowgli-2-0.symbols
index f0cb669..e5eb23c 100644
--- a/debian/libmowgli-2-0.symbols
+++ b/debian/libmowgli-2-0.symbols
@@ -339,12 +339,6 @@ libmowgli-2.so.0 libmowgli-2-0 #MINVER#
mowgli_vio_eventloop_attach@Base 2.0.0
mowgli_vio_eventloop_detach@Base 2.0.0
mowgli_vio_init@Base 2.0.0
- mowgli_vio_openssl_default_accept@Base 2.0.0+git20140224
- mowgli_vio_openssl_default_close@Base 2.0.0+git20140224
- mowgli_vio_openssl_default_connect@Base 2.0.0+git20140224
- mowgli_vio_openssl_default_listen@Base 2.0.0+git20140224
- mowgli_vio_openssl_default_read@Base 2.0.0+git20140224
- mowgli_vio_openssl_default_write@Base 2.0.0+git20140224
mowgli_vio_openssl_getsslcontext@Base 2.0.0
mowgli_vio_openssl_getsslhandle@Base 2.0.0
mowgli_vio_openssl_setssl@Base 2.0.0
diff --git a/debian/patches/004-No-openssl.diff b/debian/patches/004-No-openssl.diff
new file mode 100644
index 0000000..1a8cf7d
--- /dev/null
+++ b/debian/patches/004-No-openssl.diff
@@ -0,0 +1,15 @@
+--- a/m4/ax_check_openssl.m4
++++ b/m4/ax_check_openssl.m4
+@@ -42,9 +42,11 @@
+ [root of the OpenSSL directory])],
+ [
+ case "$withval" in
+- "" | y | ye | yes | n | no)
++ y | ye | yes)
+ AC_MSG_ERROR([Invalid --with-openssl value])
+ ;;
++ "" | n | no) ssldirs=""
++ ;;
+ *) ssldirs="$withval"
+ ;;
+ esac
diff --git a/debian/patches/series b/debian/patches/series
index de1b8cb..7b4be3e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
001-Disable_Makefile_silent_output.diff
002-Make-Examples-Buildable-standalone.diff
003-Fix-machine.h.diff
+004-No-openssl.diff
diff --git a/debian/rules b/debian/rules
index 56ea1fe..63b011e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,7 +18,7 @@ endif
ifneq "$(wildcard /usr/share/misc/config.guess)" ""
cp -f /usr/share/misc/config.guess config.guess
endif
- dh_auto_configure -- SHELL=/bin/sh
+ dh_auto_configure -- SHELL=/bin/sh --with-openssl=no
override_dh_auto_install:
dh_auto_install