summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2014-01-28 15:45:53 +0100
committerAndrew Shadura <andrew@shadura.me>2014-01-28 15:45:53 +0100
commit9cbd7a89bde3b03611ba5dd0ea677e21aa29f67f (patch)
tree5989afd6c6a68d8e4dad6d6eb0f0102ad69ad86c
parent1c4d0bf26116716c3fc2193b45cdf60f1015406a (diff)
Refresh patches, fix hardening.
-rw-r--r--debian/changelog5
-rw-r--r--debian/clean2
-rw-r--r--debian/libmowgli-2-0.lintian-overrides2
-rw-r--r--debian/patches/001-Disable_Makefile_silent_output.diff10
-rw-r--r--debian/patches/002-Make-Examples-Buildable-standalone.diff277
-rwxr-xr-xdebian/rules6
6 files changed, 262 insertions, 40 deletions
diff --git a/debian/changelog b/debian/changelog
index 61c43d9..a8a295a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,9 @@
libmowgli-2 (2.0.0-1) unstable; urgency=low
- * New major upstream release.
+ * New major upstream release (Closes: #676964).
+ * Update copyright file.
- -- Andrew Shadura <andrewsh@debian.org> Tue, 28 Jan 2014 15:10:59 +0100
+ -- Andrew Shadura <andrewsh@debian.org> Tue, 28 Jan 2014 15:45:25 +0100
libmowgli (1.0.0-4) unstable; urgency=low
diff --git a/debian/clean b/debian/clean
index 015cda4..8c6c9f0 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1,2 +1,4 @@
.deps src/.deps src/*/.deps src/*/*/.deps buildsys.mk config.log config.status extra.mk *.pc
+src/libmowgli/*/*.dep
+src/libmowgli/platform/autoconf.h
config.sub config.guess
diff --git a/debian/libmowgli-2-0.lintian-overrides b/debian/libmowgli-2-0.lintian-overrides
index b00ac16..9ca7dde 100644
--- a/debian/libmowgli-2-0.lintian-overrides
+++ b/debian/libmowgli-2-0.lintian-overrides
@@ -1 +1 @@
-libmowgli2 binary: shlib-calls-exit usr/lib/*/libmowgli.so.2.0.0
+libmowgli-2-0 binary: shlib-calls-exit usr/lib/*/libmowgli-2.so.0.0.0
diff --git a/debian/patches/001-Disable_Makefile_silent_output.diff b/debian/patches/001-Disable_Makefile_silent_output.diff
index 4cda9c0..879d91d 100644
--- a/debian/patches/001-Disable_Makefile_silent_output.diff
+++ b/debian/patches/001-Disable_Makefile_silent_output.diff
@@ -3,12 +3,12 @@ Description: Let's show what happens...
--- a/buildsys.mk.in
+++ b/buildsys.mk.in
-@@ -89,7 +89,7 @@
- OBJS10 = ${OBJS9:.S=.o}
- OBJS += ${OBJS10:.po=.gmo}
+@@ -101,7 +101,7 @@
+
+ MO_FILES = ${LOCALES:.po=.mo}
-.SILENT:
+#.SILENT:
.SUFFIXES:
- .SUFFIXES: .beam .c .cc .cxx .d .dep .erl .gmo .m .mm .o .po .py .pyc .xpm .S
- .PHONY: all subdirs pre-depend depend install install-extra uninstall uninstall-extra clean distclean
+ .SUFFIXES: .beam .c .c.dep .cc .cc.dep .class .cxx .cxx.dep .d .erl .lib.o .java .mo .m .m.dep .mm .mm.dep .o .plugin.o .po .py .pyc .rc .S .S.dep .xpm
+ .PHONY: all subdirs pre-depend depend install install-extra uninstall uninstall-extra clean distclean locales
diff --git a/debian/patches/002-Make-Examples-Buildable-standalone.diff b/debian/patches/002-Make-Examples-Buildable-standalone.diff
index a5d381e..7eea37d 100644
--- a/debian/patches/002-Make-Examples-Buildable-standalone.diff
+++ b/debian/patches/002-Make-Examples-Buildable-standalone.diff
@@ -1,28 +1,6 @@
Author: Adam Cécile (Le_Vert) <gandalf@le-vert.net>
Description: This patch makes the examples build standalone.
---- a/src/examples/dicttest/dicttest.c
-+++ b/src/examples/dicttest/dicttest.c
-@@ -31,7 +31,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli/mowgli.h>
-
- #ifdef _WIN32
- #define strcasecmp _stricmp
---- a/src/examples/dicttest/Makefile
-+++ b/src/examples/dicttest/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = dicttest${PROG_SUFFIX}
- SRCS = dicttest.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli
--- a/src/examples/formattertest/formattertest.c
+++ b/src/examples/formattertest/formattertest.c
@@ -31,7 +31,7 @@
@@ -30,7 +8,7 @@ Description: This patch makes the examples build standalone.
*/
-#include <mowgli.h>
-+#include <libmowgli/mowgli.h>
++#include <libmowgli-2/mowgli.h>
int main(int argc, char *argv[])
{
@@ -44,7 +22,7 @@ Description: This patch makes the examples build standalone.
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
--- a/src/examples/listsort/listsort.c
+++ b/src/examples/listsort/listsort.c
@@ -31,7 +31,7 @@
@@ -52,7 +30,7 @@ Description: This patch makes the examples build standalone.
*/
-#include <mowgli.h>
-+#include <libmowgli/mowgli.h>
++#include <libmowgli-2/mowgli.h>
#ifdef _WIN32
#define strcasecmp _stricmp
@@ -66,11 +44,11 @@ Description: This patch makes the examples build standalone.
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
--- a/src/examples/Makefile
+++ b/src/examples/Makefile
@@ -1,3 +1,3 @@
- SUBDIRS = randomtest listsort formattertest dicttest patriciatest patriciatest2
+ SUBDIRS = echoserver vio-udplistener async_resolver formattertest helpertest libevent-bench linetest listsort memslice-bench patriciatest patriciatest2 randomtest timertest futuretest
-include ../../buildsys.mk
+include buildsys.mk
@@ -84,7 +62,7 @@ Description: This patch makes the examples build standalone.
+include ../buildsys.mk
CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
--- a/src/examples/randomtest/randomtest.c
+++ b/src/examples/randomtest/randomtest.c
@@ -31,7 +31,7 @@
@@ -92,7 +70,248 @@ Description: This patch makes the examples build standalone.
* POSSIBILITY OF SUCH DAMAGE.
*/
-#include <mowgli.h>
-+#include <libmowgli/mowgli.h>
++#include <libmowgli-2/mowgli.h>
int main(int argc, char *argv[])
{
+--- a/src/examples/async_resolver/async_resolver.c
++++ b/src/examples/async_resolver/async_resolver.c
+@@ -1,6 +1,6 @@
+ /* This code is in the public domain. */
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ typedef struct
+ {
+--- a/src/examples/async_resolver/Makefile
++++ b/src/examples/async_resolver/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = async_resolver${PROG_SUFFIX}
+ SRCS = async_resolver.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/echoserver/echoserver.c
++++ b/src/examples/echoserver/echoserver.c
+@@ -21,7 +21,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ mowgli_eventloop_t *base_eventloop;
+ mowgli_eventloop_pollable_t *listener;
+--- a/src/examples/echoserver/Makefile
++++ b/src/examples/echoserver/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = echoserver${PROG_SUFFIX}
+ SRCS = echoserver.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/futuretest/futuretest.c
++++ b/src/examples/futuretest/futuretest.c
+@@ -23,7 +23,7 @@
+
+ #include <string.h>
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ int main(int argc, char *argv[]) {
+ char *text = "hello world";
+--- a/src/examples/futuretest/Makefile
++++ b/src/examples/futuretest/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = futuretest${PROG_SUFFIX}
+ SRCS = futuretest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/helpertest/helpertest.c
++++ b/src/examples/helpertest/helpertest.c
+@@ -21,7 +21,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ int helper_count = 0;
+
+--- a/src/examples/helpertest/Makefile
++++ b/src/examples/helpertest/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = helpertest${PROG_SUFFIX}
+ SRCS = helpertest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/libevent-bench/bench.c
++++ b/src/examples/libevent-bench/bench.c
+@@ -73,7 +73,7 @@
+ } \
+ } while (0)
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+
+ static int count, writes, fired;
+--- a/src/examples/libevent-bench/Makefile
++++ b/src/examples/libevent-bench/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = bench${PROG_SUFFIX}
+ SRCS = bench.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/linetest/linetest.c
++++ b/src/examples/linetest/linetest.c
+@@ -22,7 +22,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ mowgli_eventloop_t *base_eventloop;
+ char buf[512];
+--- a/src/examples/linetest/Makefile
++++ b/src/examples/linetest/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = linetest${PROG_SUFFIX}
+ SRCS = linetest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/memslice-bench/Makefile
++++ b/src/examples/memslice-bench/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = memslice-bench${PROG_SUFFIX}
+ SRCS = memslice-bench.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/memslice-bench/memslice-bench.c
++++ b/src/examples/memslice-bench/memslice-bench.c
+@@ -28,7 +28,7 @@
+ } \
+ } while (0)
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ mowgli_allocation_policy_t *memslice;
+ mowgli_allocation_policy_t *sysmalloc;
+--- a/src/examples/patriciatest2/Makefile
++++ b/src/examples/patriciatest2/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = patriciatest2${PROG_SUFFIX}
+ SRCS = patriciatest2.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/patriciatest2/patriciatest2.c
++++ b/src/examples/patriciatest2/patriciatest2.c
+@@ -31,7 +31,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ #define TESTSIZE 10000
+
+--- a/src/examples/patriciatest/Makefile
++++ b/src/examples/patriciatest/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = patriciatest${PROG_SUFFIX}
+ SRCS = patriciatest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/patriciatest/patriciatest.c
++++ b/src/examples/patriciatest/patriciatest.c
+@@ -31,7 +31,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ int errors = 0;
+
+--- a/src/examples/timertest/Makefile
++++ b/src/examples/timertest/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = timertest${PROG_SUFFIX}
+ SRCS = timertest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/timertest/timertest.c
++++ b/src/examples/timertest/timertest.c
+@@ -21,7 +21,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ mowgli_eventloop_t *eventloop;
+
+--- a/src/examples/vio-udplistener/Makefile
++++ b/src/examples/vio-udplistener/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = vio-udplistener${PROG_SUFFIX}
+ SRCS = vio-udplistener.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli-2
+--- a/src/examples/vio-udplistener/vio-udplistener.c
++++ b/src/examples/vio-udplistener/vio-udplistener.c
+@@ -3,7 +3,7 @@
+ * This example is public domain.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ #define BUFSIZE 2048
+
diff --git a/debian/rules b/debian/rules
index 224fcea..56ea1fe 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,6 @@
#!/usr/bin/make -f
-export CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
+export CFLAGS := $(shell dpkg-buildflags --get CFLAGS) $(shell dpkg-buildflags --get CPPFLAGS)
export CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
@@ -22,8 +22,8 @@ endif
override_dh_auto_install:
dh_auto_install
- mkdir -p debian/libmowgli-2-0/usr/include/$(DEB_HOST_MULTIARCH)/libmowgli
- # mv -f debian/tmp/usr/include/libmowgli-2/mowgli_config.h debian/libmowgli-2-0/usr/include/$(DEB_HOST_MULTIARCH)/libmowgli/mowgli_config.h
+ # mkdir -p debian/libmowgli-2-0/usr/include/$(DEB_HOST_MULTIARCH)/libmowgli-2/platform
+ # mv -f debian/tmp/usr/include/libmowgli-2/platform/autoconf.h debian/libmowgli-2-0/usr/include/$(DEB_HOST_MULTIARCH)/libmowgli-2/platform/autoconf.h
override_dh_installexamples:
sed -e 's,\(libdir = \$${prefix}/lib\)/.*$$,\1,' \