summaryrefslogtreecommitdiff
path: root/debian/patches/002-Make-Examples-Buildable-standalone.diff
diff options
context:
space:
mode:
authorAndrew Shadura <bugzilla@tut.by>2011-11-28 15:44:01 +0200
committerAndrew Shadura <bugzilla@tut.by>2011-11-28 15:44:01 +0200
commitf9f162b5f99a18da91109f3ab7bb2f9244a888aa (patch)
treef497d3d34c32cf9c5914ce51fa70603b54316c33 /debian/patches/002-Make-Examples-Buildable-standalone.diff
parent8057cf9ae9570cd64c37ed6c00e1651d3f6b0b40 (diff)
rename patches
Diffstat (limited to 'debian/patches/002-Make-Examples-Buildable-standalone.diff')
-rw-r--r--debian/patches/002-Make-Examples-Buildable-standalone.diff98
1 files changed, 98 insertions, 0 deletions
diff --git a/debian/patches/002-Make-Examples-Buildable-standalone.diff b/debian/patches/002-Make-Examples-Buildable-standalone.diff
new file mode 100644
index 0000000..a5d381e
--- /dev/null
+++ b/debian/patches/002-Make-Examples-Buildable-standalone.diff
@@ -0,0 +1,98 @@
+Author: Adam Cécile (Le_Vert) <gandalf@le-vert.net>
+Description: This patch makes the examples build standalone.
+
+--- a/src/examples/dicttest/dicttest.c
++++ b/src/examples/dicttest/dicttest.c
+@@ -31,7 +31,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli/mowgli.h>
+
+ #ifdef _WIN32
+ #define strcasecmp _stricmp
+--- a/src/examples/dicttest/Makefile
++++ b/src/examples/dicttest/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = dicttest${PROG_SUFFIX}
+ SRCS = dicttest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli
+--- a/src/examples/formattertest/formattertest.c
++++ b/src/examples/formattertest/formattertest.c
+@@ -31,7 +31,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli/mowgli.h>
+
+ int main(int argc, char *argv[])
+ {
+--- a/src/examples/formattertest/Makefile
++++ b/src/examples/formattertest/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = formattertest${PROG_SUFFIX}
+ SRCS = formattertest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli
+--- a/src/examples/listsort/listsort.c
++++ b/src/examples/listsort/listsort.c
+@@ -31,7 +31,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli/mowgli.h>
+
+ #ifdef _WIN32
+ #define strcasecmp _stricmp
+--- a/src/examples/listsort/Makefile
++++ b/src/examples/listsort/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = listsort${PROG_SUFFIX}
+ SRCS = listsort.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli
+--- a/src/examples/Makefile
++++ b/src/examples/Makefile
+@@ -1,3 +1,3 @@
+ SUBDIRS = randomtest listsort formattertest dicttest patriciatest patriciatest2
+
+-include ../../buildsys.mk
++include buildsys.mk
+--- a/src/examples/randomtest/Makefile
++++ b/src/examples/randomtest/Makefile
+@@ -1,7 +1,7 @@
+ PROG_NOINST = randomtest${PROG_SUFFIX}
+ SRCS = randomtest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli
+--- a/src/examples/randomtest/randomtest.c
++++ b/src/examples/randomtest/randomtest.c
+@@ -31,7 +31,7 @@
+ * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+-#include <mowgli.h>
++#include <libmowgli/mowgli.h>
+
+ int main(int argc, char *argv[])
+ {