summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorAndrew Shadura <bugzilla@tut.by>2011-11-17 19:46:58 +0100
committerAndrew Shadura <bugzilla@tut.by>2011-11-17 19:46:58 +0100
commit9f47f0661ef41bb7720808c68965a4a99e458c96 (patch)
treeea08d7015948461bc2af0d0c74aee6c2ef365e7e /debian/patches
parent1de62163f0237e2fdd7d9b5ee7c29c57851ce87e (diff)
add debian directory
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/001-Disable_Makefile_silent_output.dpatch19
-rw-r--r--debian/patches/002-Make-Examples-Buildable-standalone.dpatch112
2 files changed, 131 insertions, 0 deletions
diff --git a/debian/patches/001-Disable_Makefile_silent_output.dpatch b/debian/patches/001-Disable_Makefile_silent_output.dpatch
new file mode 100644
index 0000000..01cfaf1
--- /dev/null
+++ b/debian/patches/001-Disable_Makefile_silent_output.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 001-Disable_Makefile_silent_output.dpatch
+## by Adam Cécile (Le_Vert) <gandalf@le-vert.net>
+##
+## DP: Let's show what happens...
+
+@DPATCH@
+
+--- a/buildsys.mk.in 2007-10-15 07:03:45.000000000 +0200
++++ b/buildsys.mk.in 2007-10-21 02:14:21.518788374 +0200
+@@ -73,7 +73,7 @@
+ OBJS5 = ${OBJS4:.erl=.beam}
+ OBJS += ${OBJS5:.m=.o}
+
+-.SILENT:
++#.SILENT:
+ .SUFFIXES: .beam .c .cc .cxx .d .erl .m
+ .PHONY: all subdirs pre-depend depend install install-extra uninstall uninstall-extra clean distclean
+
diff --git a/debian/patches/002-Make-Examples-Buildable-standalone.dpatch b/debian/patches/002-Make-Examples-Buildable-standalone.dpatch
new file mode 100644
index 0000000..dd2dd51
--- /dev/null
+++ b/debian/patches/002-Make-Examples-Buildable-standalone.dpatch
@@ -0,0 +1,112 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 002-Make-Examples-Buildable-standalone.dpatch
+## by Adam Cécile (Le_Vert) <gandalf@le-vert.net>
+##
+## DP: This patch makes the examples build standalone.
+
+@DPATCH@
+
+diff -ur libmowgli-patched/src/examples/dicttest/dicttest.c libmowgli/src/examples/dicttest/dicttest.c
+--- libmowgli-patched/src/examples/dicttest/dicttest.c 2007-10-21 15:49:43.019930332 +0200
++++ libmowgli/src/examples/dicttest/dicttest.c 2007-09-27 22:04:26.404664058 +0200
+@@ -31,7 +31,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli/mowgli.h>
+
+ int main(int argc, const char *argv[])
+ {
+diff -ur libmowgli-patched/src/examples/dicttest/Makefile libmowgli/src/examples/dicttest/Makefile
+--- libmowgli-patched/src/examples/dicttest/Makefile 2007-10-21 15:48:02.014174342 +0200
++++ libmowgli/src/examples/dicttest/Makefile 2007-10-10 20:37:43.653955022 +0200
+@@ -1,7 +1,7 @@
+ PROG_NOINST = dicttest${PROG_SUFFIX}
+ SRCS = dicttest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli
+diff -ur libmowgli-patched/src/examples/formattertest/formattertest.c libmowgli/src/examples/formattertest/formattertest.c
+--- libmowgli-patched/src/examples/formattertest/formattertest.c 2007-10-21 15:49:14.518306117 +0200
++++ libmowgli/src/examples/formattertest/formattertest.c 2007-09-27 22:04:26.404664058 +0200
+@@ -31,7 +31,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli/mowgli.h>
+
+ int main(int argc, char *argv[])
+ {
+diff -ur libmowgli-patched/src/examples/formattertest/Makefile libmowgli/src/examples/formattertest/Makefile
+--- libmowgli-patched/src/examples/formattertest/Makefile 2007-10-21 15:48:02.014174342 +0200
++++ libmowgli/src/examples/formattertest/Makefile 2007-10-10 20:37:44.153983517 +0200
+@@ -1,7 +1,7 @@
+ PROG_NOINST = formattertest${PROG_SUFFIX}
+ SRCS = formattertest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli
+diff -ur libmowgli-patched/src/examples/listsort/listsort.c libmowgli/src/examples/listsort/listsort.c
+--- libmowgli-patched/src/examples/listsort/listsort.c 2007-10-21 15:49:14.518306117 +0200
++++ libmowgli/src/examples/listsort/listsort.c 2007-09-27 22:04:26.404664058 +0200
+@@ -31,7 +31,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include <mowgli.h>
++#include <libmowgli/mowgli.h>
+
+ int str_comparator(mowgli_node_t *n, mowgli_node_t *n2, void *opaque)
+ {
+diff -ur libmowgli-patched/src/examples/listsort/Makefile libmowgli/src/examples/listsort/Makefile
+--- libmowgli-patched/src/examples/listsort/Makefile 2007-10-21 15:48:02.014174342 +0200
++++ libmowgli/src/examples/listsort/Makefile 2007-10-10 20:37:44.654012012 +0200
+@@ -1,7 +1,7 @@
+ PROG_NOINST = listsort${PROG_SUFFIX}
+ SRCS = listsort.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli
+diff -ur libmowgli-patched/src/examples/Makefile libmowgli/src/examples/Makefile
+--- libmowgli-patched/src/examples/Makefile 2007-10-21 15:48:02.014174342 +0200
++++ libmowgli/src/examples/Makefile 2007-10-10 20:37:43.653955022 +0200
+@@ -1,3 +1,3 @@
+ SUBDIRS = randomtest listsort formattertest dicttest
+
+-include ../../buildsys.mk
++include buildsys.mk
+diff -ur libmowgli-patched/src/examples/randomtest/Makefile libmowgli/src/examples/randomtest/Makefile
+--- libmowgli-patched/src/examples/randomtest/Makefile 2007-10-21 15:48:02.014174342 +0200
++++ libmowgli/src/examples/randomtest/Makefile 2007-10-10 20:37:44.654012012 +0200
+@@ -1,7 +1,7 @@
+ PROG_NOINST = randomtest${PROG_SUFFIX}
+ SRCS = randomtest.c
+
+-include ../../../buildsys.mk
++include ../buildsys.mk
+
+ CPPFLAGS += -I../../libmowgli
+ LIBS += -L../../libmowgli -lmowgli
+diff -ur libmowgli-patched/src/examples/randomtest/randomtest.c libmowgli/src/examples/randomtest/randomtest.c
+--- libmowgli-patched/src/examples/randomtest/randomtest.c 2007-10-21 15:49:14.518306117 +0200
++++ libmowgli/src/examples/randomtest/randomtest.c 2007-10-14 00:16:59.752080433 +0200
+@@ -31,7 +31,7 @@
+ * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+-#include <mowgli.h>
++#include <libmowgli/mowgli.h>
+
+ int main(int argc, char *argv[])
+ {