summaryrefslogtreecommitdiff
path: root/src/libmowgli/core/Makefile
diff options
context:
space:
mode:
authorAndrew Shadura <andrew.shadura@collabora.co.uk>2018-04-24 17:03:28 +0200
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2018-04-24 17:04:29 +0200
commit8c40d331df0d2c438f4de8d0f06f8a5d4a9c7bb2 (patch)
treee1bfcf498ff897d426f0adfc892a89b950a6dfca /src/libmowgli/core/Makefile
parente5e906c214990dbed7a1c4c614c1d25e67caf800 (diff)
parentdada70f0e58c0dd7d856589d2da2618701a2ff76 (diff)
Reimport the upstream source
Diffstat (limited to 'src/libmowgli/core/Makefile')
-rw-r--r--src/libmowgli/core/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/libmowgli/core/Makefile b/src/libmowgli/core/Makefile
new file mode 100644
index 0000000..08a5306
--- /dev/null
+++ b/src/libmowgli/core/Makefile
@@ -0,0 +1,32 @@
+include ../../../extra.mk
+
+STATIC_PIC_LIB_NOINST = ${LIBMOWGLI_SHARED_CORE}
+STATIC_LIB_NOINST = ${LIBMOWGLI_STATIC_CORE}
+
+SRCS = bootstrap.c \
+ alloc.c \
+ allocation_policy.c \
+ allocator.c \
+ heap.c \
+ logger.c \
+ mowgli_string.c \
+ process.c
+
+INCLUDES = bootstrap.h \
+ alloc.h \
+ allocation_policy.h \
+ allocator.h \
+ assert.h \
+ heap.h \
+ iterator.h \
+ logger.h \
+ mowgli_string.h \
+ stdinc.h \
+ process.h
+
+include ../../../buildsys.mk
+
+includesubdir = $(PACKAGE_NAME)/core
+
+CPPFLAGS += -I. -I.. -I../../.. -DMOWGLI_CORE
+