summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/clean1
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules6
3 files changed, 8 insertions, 1 deletions
diff --git a/debian/clean b/debian/clean
index 6ea5e4e..5a96336 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1 +1,2 @@
.deps src/.deps src/*/.deps src/*/*/.deps buildsys.mk config.log config.status extra.mk libmowgli.pc
+config.sub config.guess
diff --git a/debian/control b/debian/control
index b6203c1..3205d3d 100644
--- a/debian/control
+++ b/debian/control
@@ -1,7 +1,7 @@
Source: libmowgli
Priority: optional
Maintainer: Andrew Shadura <andrewsh@debian.org>
-Build-Depends: debhelper (>= 9), dh-autoreconf
+Build-Depends: debhelper (>= 9), dh-autoreconf, autotools-dev
Standards-Version: 3.9.4
Homepage: http://www.atheme.org/projects/mowgli
Vcs-Hg: http://anonscm.debian.org/hg/collab-maint/libmowgli
diff --git a/debian/rules b/debian/rules
index 142bd1b..a13f709 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,12 @@ export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
dh $@ --with=autoreconf
override_dh_auto_configure:
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
dh_auto_configure -- SHELL=/bin/sh
override_dh_auto_install: