summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/001-Disable_Makefile_silent_output.diff4
-rw-r--r--debian/patches/002-Make-Examples-Buildable-standalone.diff65
-rw-r--r--debian/patches/003-Fix-machine.h.diff24
3 files changed, 39 insertions, 54 deletions
diff --git a/debian/patches/001-Disable_Makefile_silent_output.diff b/debian/patches/001-Disable_Makefile_silent_output.diff
index 879d91d..7189358 100644
--- a/debian/patches/001-Disable_Makefile_silent_output.diff
+++ b/debian/patches/001-Disable_Makefile_silent_output.diff
@@ -3,7 +3,7 @@ Description: Let's show what happens...
--- a/buildsys.mk.in
+++ b/buildsys.mk.in
-@@ -101,7 +101,7 @@
+@@ -102,7 +102,7 @@
MO_FILES = ${LOCALES:.po=.mo}
@@ -11,4 +11,4 @@ Description: Let's show what happens...
+#.SILENT:
.SUFFIXES:
.SUFFIXES: .beam .c .c.dep .cc .cc.dep .class .cxx .cxx.dep .d .erl .lib.o .java .mo .m .m.dep .mm .mm.dep .o .plugin.o .po .py .pyc .rc .S .S.dep .xpm
- .PHONY: all subdirs pre-depend depend install install-extra uninstall uninstall-extra clean distclean locales
+ .PHONY: all subdirs ${SUBDIRS} pre-depend depend install install-extra uninstall uninstall-extra clean distclean locales
diff --git a/debian/patches/002-Make-Examples-Buildable-standalone.diff b/debian/patches/002-Make-Examples-Buildable-standalone.diff
index 7eea37d..180f9b9 100644
--- a/debian/patches/002-Make-Examples-Buildable-standalone.diff
+++ b/debian/patches/002-Make-Examples-Buildable-standalone.diff
@@ -10,8 +10,8 @@ Description: This patch makes the examples build standalone.
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
- int main(int argc, char *argv[])
- {
+ int
+ main(int argc, char *argv[])
--- a/src/examples/formattertest/Makefile
+++ b/src/examples/formattertest/Makefile
@@ -1,7 +1,7 @@
@@ -33,7 +33,7 @@ Description: This patch makes the examples build standalone.
+#include <libmowgli-2/mowgli.h>
#ifdef _WIN32
- #define strcasecmp _stricmp
+ # define strcasecmp _stricmp
--- a/src/examples/listsort/Makefile
+++ b/src/examples/listsort/Makefile
@@ -1,7 +1,7 @@
@@ -45,13 +45,6 @@ Description: This patch makes the examples build standalone.
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/Makefile
-+++ b/src/examples/Makefile
-@@ -1,3 +1,3 @@
- SUBDIRS = echoserver vio-udplistener async_resolver formattertest helpertest libevent-bench linetest listsort memslice-bench patriciatest patriciatest2 randomtest timertest futuretest
-
--include ../../buildsys.mk
-+include buildsys.mk
--- a/src/examples/randomtest/Makefile
+++ b/src/examples/randomtest/Makefile
@@ -1,7 +1,7 @@
@@ -72,8 +65,8 @@ Description: This patch makes the examples build standalone.
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
- int main(int argc, char *argv[])
- {
+ int
+ main(int argc, char *argv[])
--- a/src/examples/async_resolver/async_resolver.c
+++ b/src/examples/async_resolver/async_resolver.c
@@ -1,6 +1,6 @@
@@ -117,28 +110,6 @@ Description: This patch makes the examples build standalone.
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/futuretest/futuretest.c
-+++ b/src/examples/futuretest/futuretest.c
-@@ -23,7 +23,7 @@
-
- #include <string.h>
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- int main(int argc, char *argv[]) {
- char *text = "hello world";
---- a/src/examples/futuretest/Makefile
-+++ b/src/examples/futuretest/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = futuretest${PROG_SUFFIX}
- SRCS = futuretest.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
--- a/src/examples/helpertest/helpertest.c
+++ b/src/examples/helpertest/helpertest.c
@@ -21,7 +21,7 @@
@@ -163,15 +134,15 @@ Description: This patch makes the examples build standalone.
LIBS += -L../../libmowgli -lmowgli-2
--- a/src/examples/libevent-bench/bench.c
+++ b/src/examples/libevent-bench/bench.c
-@@ -73,7 +73,7 @@
- } \
+@@ -76,7 +76,7 @@
+ } \
} while (0)
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
-
static int count, writes, fired;
+ static mowgli_eventloop_t *base_eventloop;
--- a/src/examples/libevent-bench/Makefile
+++ b/src/examples/libevent-bench/Makefile
@@ -1,7 +1,7 @@
@@ -218,9 +189,9 @@ Description: This patch makes the examples build standalone.
LIBS += -L../../libmowgli -lmowgli-2
--- a/src/examples/memslice-bench/memslice-bench.c
+++ b/src/examples/memslice-bench/memslice-bench.c
-@@ -28,7 +28,7 @@
- } \
- } while (0)
+@@ -30,7 +30,7 @@
+ } \
+ } while (0)
-#include <mowgli.h>
+#include <libmowgli-2/mowgli.h>
@@ -315,3 +286,17 @@ Description: This patch makes the examples build standalone.
#define BUFSIZE 2048
+--- a/src/examples/Makefile
++++ b/src/examples/Makefile
+@@ -1,2 +1,2 @@
+ SUBDIRS = echoserver vio-udplistener async_resolver formattertest helpertest jsontest libevent-bench linetest listsort memslice-bench patriciatest patriciatest2 randomtest timertest
+-include ../../buildsys.mk
++include buildsys.mk
+--- a/src/examples/jsontest/jsontest.c
++++ b/src/examples/jsontest/jsontest.c
+@@ -1,4 +1,4 @@
+-#include <mowgli.h>
++#include <libmowgli-2/mowgli.h>
+
+ void
+ out_string(mowgli_json_output_t *out, const char *str, size_t len)
diff --git a/debian/patches/003-Fix-machine.h.diff b/debian/patches/003-Fix-machine.h.diff
index a9f8773..1a7d42b 100644
--- a/debian/patches/003-Fix-machine.h.diff
+++ b/debian/patches/003-Fix-machine.h.diff
@@ -1,18 +1,18 @@
--- a/src/libmowgli/platform/machine.h
+++ b/src/libmowgli/platform/machine.h
-@@ -180,13 +180,13 @@
- #if defined _LP64 || defined __LP64
- #define MOWGLI_CPU_BITS 64
- #define MOWGLI_CPU_BITS_64
--#elif
-+#else
- #define MOWGLI_CPU_BITS 32
- #define MOWGLI_CPU_BITS_32
- #endif
+@@ -186,13 +186,13 @@
+ # if defined _LP64 || defined __LP64
+ # define MOWGLI_CPU_BITS 64
+ # define MOWGLI_CPU_BITS_64
+-# elif
++# else
+ # define MOWGLI_CPU_BITS 32
+ # define MOWGLI_CPU_BITS_32
+ # endif
#endif
-#if defined __linux || defined __linux__
+#if defined __linux || defined __linux__ || defined __FreeBSD_kernel__
- #define MOWGLI_OS_LINUX
- #define MOWGLI_OS linux
- #define MOWGLI_OS_THREADS_POSIX
+ # define MOWGLI_OS_LINUX
+ # define MOWGLI_OS linux
+ # define MOWGLI_OS_THREADS_POSIX