summaryrefslogtreecommitdiff
path: root/debian/patches/002-Make-Examples-Buildable-standalone.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/002-Make-Examples-Buildable-standalone.dpatch')
-rw-r--r--debian/patches/002-Make-Examples-Buildable-standalone.dpatch64
1 files changed, 25 insertions, 39 deletions
diff --git a/debian/patches/002-Make-Examples-Buildable-standalone.dpatch b/debian/patches/002-Make-Examples-Buildable-standalone.dpatch
index dd2dd51..a5d381e 100644
--- a/debian/patches/002-Make-Examples-Buildable-standalone.dpatch
+++ b/debian/patches/002-Make-Examples-Buildable-standalone.dpatch
@@ -1,14 +1,8 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 002-Make-Examples-Buildable-standalone.dpatch
-## by Adam Cécile (Le_Vert) <gandalf@le-vert.net>
-##
-## DP: This patch makes the examples build standalone.
+Author: Adam Cécile (Le_Vert) <gandalf@le-vert.net>
+Description: This patch makes the examples build standalone.
-@DPATCH@
-
-diff -ur libmowgli-patched/src/examples/dicttest/dicttest.c libmowgli/src/examples/dicttest/dicttest.c
---- libmowgli-patched/src/examples/dicttest/dicttest.c 2007-10-21 15:49:43.019930332 +0200
-+++ libmowgli/src/examples/dicttest/dicttest.c 2007-09-27 22:04:26.404664058 +0200
+--- a/src/examples/dicttest/dicttest.c
++++ b/src/examples/dicttest/dicttest.c
@@ -31,7 +31,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
@@ -16,11 +10,10 @@ diff -ur libmowgli-patched/src/examples/dicttest/dicttest.c libmowgli/src/exampl
-#include <mowgli.h>
+#include <libmowgli/mowgli.h>
- int main(int argc, const char *argv[])
- {
-diff -ur libmowgli-patched/src/examples/dicttest/Makefile libmowgli/src/examples/dicttest/Makefile
---- libmowgli-patched/src/examples/dicttest/Makefile 2007-10-21 15:48:02.014174342 +0200
-+++ libmowgli/src/examples/dicttest/Makefile 2007-10-10 20:37:43.653955022 +0200
+ #ifdef _WIN32
+ #define strcasecmp _stricmp
+--- a/src/examples/dicttest/Makefile
++++ b/src/examples/dicttest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = dicttest${PROG_SUFFIX}
SRCS = dicttest.c
@@ -30,9 +23,8 @@ diff -ur libmowgli-patched/src/examples/dicttest/Makefile libmowgli/src/examples
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli
-diff -ur libmowgli-patched/src/examples/formattertest/formattertest.c libmowgli/src/examples/formattertest/formattertest.c
---- libmowgli-patched/src/examples/formattertest/formattertest.c 2007-10-21 15:49:14.518306117 +0200
-+++ libmowgli/src/examples/formattertest/formattertest.c 2007-09-27 22:04:26.404664058 +0200
+--- a/src/examples/formattertest/formattertest.c
++++ b/src/examples/formattertest/formattertest.c
@@ -31,7 +31,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
@@ -42,9 +34,8 @@ diff -ur libmowgli-patched/src/examples/formattertest/formattertest.c libmowgli/
int main(int argc, char *argv[])
{
-diff -ur libmowgli-patched/src/examples/formattertest/Makefile libmowgli/src/examples/formattertest/Makefile
---- libmowgli-patched/src/examples/formattertest/Makefile 2007-10-21 15:48:02.014174342 +0200
-+++ libmowgli/src/examples/formattertest/Makefile 2007-10-10 20:37:44.153983517 +0200
+--- a/src/examples/formattertest/Makefile
++++ b/src/examples/formattertest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = formattertest${PROG_SUFFIX}
SRCS = formattertest.c
@@ -54,9 +45,8 @@ diff -ur libmowgli-patched/src/examples/formattertest/Makefile libmowgli/src/exa
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli
-diff -ur libmowgli-patched/src/examples/listsort/listsort.c libmowgli/src/examples/listsort/listsort.c
---- libmowgli-patched/src/examples/listsort/listsort.c 2007-10-21 15:49:14.518306117 +0200
-+++ libmowgli/src/examples/listsort/listsort.c 2007-09-27 22:04:26.404664058 +0200
+--- a/src/examples/listsort/listsort.c
++++ b/src/examples/listsort/listsort.c
@@ -31,7 +31,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
@@ -64,11 +54,10 @@ diff -ur libmowgli-patched/src/examples/listsort/listsort.c libmowgli/src/exampl
-#include <mowgli.h>
+#include <libmowgli/mowgli.h>
- int str_comparator(mowgli_node_t *n, mowgli_node_t *n2, void *opaque)
- {
-diff -ur libmowgli-patched/src/examples/listsort/Makefile libmowgli/src/examples/listsort/Makefile
---- libmowgli-patched/src/examples/listsort/Makefile 2007-10-21 15:48:02.014174342 +0200
-+++ libmowgli/src/examples/listsort/Makefile 2007-10-10 20:37:44.654012012 +0200
+ #ifdef _WIN32
+ #define strcasecmp _stricmp
+--- a/src/examples/listsort/Makefile
++++ b/src/examples/listsort/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = listsort${PROG_SUFFIX}
SRCS = listsort.c
@@ -78,17 +67,15 @@ diff -ur libmowgli-patched/src/examples/listsort/Makefile libmowgli/src/examples
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli
-diff -ur libmowgli-patched/src/examples/Makefile libmowgli/src/examples/Makefile
---- libmowgli-patched/src/examples/Makefile 2007-10-21 15:48:02.014174342 +0200
-+++ libmowgli/src/examples/Makefile 2007-10-10 20:37:43.653955022 +0200
+--- a/src/examples/Makefile
++++ b/src/examples/Makefile
@@ -1,3 +1,3 @@
- SUBDIRS = randomtest listsort formattertest dicttest
+ SUBDIRS = randomtest listsort formattertest dicttest patriciatest patriciatest2
-include ../../buildsys.mk
+include buildsys.mk
-diff -ur libmowgli-patched/src/examples/randomtest/Makefile libmowgli/src/examples/randomtest/Makefile
---- libmowgli-patched/src/examples/randomtest/Makefile 2007-10-21 15:48:02.014174342 +0200
-+++ libmowgli/src/examples/randomtest/Makefile 2007-10-10 20:37:44.654012012 +0200
+--- a/src/examples/randomtest/Makefile
++++ b/src/examples/randomtest/Makefile
@@ -1,7 +1,7 @@
PROG_NOINST = randomtest${PROG_SUFFIX}
SRCS = randomtest.c
@@ -98,9 +85,8 @@ diff -ur libmowgli-patched/src/examples/randomtest/Makefile libmowgli/src/exampl
CPPFLAGS += -I../../libmowgli
LIBS += -L../../libmowgli -lmowgli
-diff -ur libmowgli-patched/src/examples/randomtest/randomtest.c libmowgli/src/examples/randomtest/randomtest.c
---- libmowgli-patched/src/examples/randomtest/randomtest.c 2007-10-21 15:49:14.518306117 +0200
-+++ libmowgli/src/examples/randomtest/randomtest.c 2007-10-14 00:16:59.752080433 +0200
+--- a/src/examples/randomtest/randomtest.c
++++ b/src/examples/randomtest/randomtest.c
@@ -31,7 +31,7 @@
* IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
* POSSIBILITY OF SUCH DAMAGE.