summaryrefslogtreecommitdiff
path: root/src/libmowgli/container/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/libmowgli/container/Makefile')
-rw-r--r--src/libmowgli/container/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/libmowgli/container/Makefile b/src/libmowgli/container/Makefile
new file mode 100644
index 0000000..1c97ee9
--- /dev/null
+++ b/src/libmowgli/container/Makefile
@@ -0,0 +1,23 @@
+include ../../../extra.mk
+
+STATIC_PIC_LIB_NOINST = ${LIBMOWGLI_SHARED_CONTAINER}
+STATIC_LIB_NOINST = ${LIBMOWGLI_STATIC_CONTAINER}
+
+SRCS = dictionary.c \
+ list.c \
+ queue.c \
+ index.c \
+ patricia.c
+
+INCLUDES = dictionary.h \
+ list.h \
+ queue.h \
+ index.h \
+ patricia.h
+
+include ../../../buildsys.mk
+
+includesubdir = $(PACKAGE_NAME)/container
+
+CPPFLAGS += -I. -I.. -I../../.. -DMOWGLI_CORE
+