summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorFlorian Schlichting <fsfs@debian.org>2015-08-18 18:15:16 +0200
committerFlorian Schlichting <fsfs@debian.org>2015-08-18 18:15:16 +0200
commitf205c147abe36c1a3043cf68d9ff1bcfd6fcc534 (patch)
tree2d3e9acc46223fe9ad7672ba24155879a0394c36 /Makefile.PL
parenta5b394ff4bfd1c0f10f5dab078424e9f57a81a83 (diff)
Imported Upstream version 0.64
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 358b646..1b3a6a8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,7 +1,12 @@
use 5.008;
use ExtUtils::MakeMaker;
-$^O =~ /Win32/ and die "This module does not work on MS Windows.\nTry installing a real OS!\n";
+if ($^O =~ /MSWin|cygwin/i) {
+ warn <<EOW;
+Only a minor subset of the functionality of Net::OpenSSH is supported on Windows.
+It is OK to install it as a dependency of Net::SSH::Any though.
+EOW
+}
my $ssh_V = `ssh -V 2>&1`;
if (defined $ssh_V) {