summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrédéric Bonnard <frediz@debian.org>2020-07-16 23:37:44 +0200
committerSudip Mukherjee <sudipm.mukherjee@gmail.com>2020-07-16 23:37:44 +0200
commitba364925abf52e69be7016d562eed936d76e0e0e (patch)
treeb81a10c6a267d76ff9e1ffe5e95fddde3f4213db
parent87877e9df5ab4153a9ff8cc7357e40d2abff3f4e (diff)
Use local copy ocxl.h
Only check online if local copy is not found. Author: Sudip Mukherjee <sudipm.mukherjee@gmail.com> Bug-Debian: https://bugs.debian.org/963364 Forwarded: not-needed Gbp-Pq: Name use_local.patch
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 48d3cae..51c0c7e 100644
--- a/Makefile
+++ b/Makefile
@@ -24,14 +24,13 @@ CHECK_OCXL_HEADER_IS_UP_TO_DATE = $(shell /bin/echo -e \\\#include $(1)\\\nvoid
check_ocxl_header:
ifeq ($(call CHECK_OCXL_HEADER_IS_UP_TO_DATE,'<misc/ocxl.h>'),n)
mkdir -p kernel/include/misc
-ifeq (${HAS_WGET},y)
+else ifeq (${HAS_WGET},y)
$(call Q,WGET kernel/include/misc/ocxl.h, wget -O kernel/include/misc/ocxl.h -q http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/plain/include/uapi/misc/ocxl.h)
else ifeq (${HAS_CURL},y)
$(call Q,CURL kernel/include/misc/ocxl.h, curl -o kernel/include/misc/ocxl.h -s http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/plain/include/uapi/misc/ocxl.h)
else
$(error 'ocxl.h is non-existant or out of date, Download from http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/plain/include/uapi/misc/ocxl.h and place in ${PWD}/kernel/include/misc/ocxl.h')
endif
-endif
src/libocxl_info.h: version.pl
VERSION_MAJOR=${VERSION_MAJOR} VERSION_MINOR=${VERSION_MINOR} \